Ecs Z370h4em updating microcode

My knowledge is too small. I am asking for help in updating the microcode INTEL.
MCE … 5 CPUID is not supported.
Please help me.

BIOS-Z370.rar (4.49 MB)

@kruchydik - What does this mean, where do you see etc >> MCE … 5 CPUID is not supported.

What is your CPU model, and what is the SSPEC (number on top of CPU, similar format too >> SRCZV)?

My processor is i7 9700 SRG13, the board is on intel Z370, it should support most processors (coffee lake)
Now working on i3 8100, 9th does not get up, the motherboard beeps
I tried to use the guide from the forum but I don’t know how to go about it.
sorry for my English,I use translator :slight_smile:

MCE Z370.jpg

@kruchydik - i7-9700 SRG13 >> = R0 >> 906ED

Here is BIOS with updated microcodes, per the following changes -
506E8 & 50654 have been removed
906EC & 906ED Added
All Updated to latest version…946971994863764

I updated the bios.
i3 8100 works fine but i7 9700 doesn’t stand up.
the motherboard issues 5 signals probably because it does not detect the processor.
i7 9th works well with another motherboard
Do you still have an idea for i7 9th?

@kruchydik - Are you testing with onboard graphics or PCIE graphics? If onboard, test with PCIE real quick and see if same result.

@DeathBringer - Do you have any idea to help here? i7-9700 SRG13 - R0 / 906ED
Z370 chipset, 906EA/B compatible by default w/ ME 11.8. It shouldn’t need ME Downgrade correct, since already compatible w/ other Coffee CPU’s.
I assumed insert 906EC/906ED would be all that’s needed, but I guess not.

testing with onboard graphics…I will check for PCIE

still i7 9 does not start on pcie graphics

OK, please wait, and answer questions in PM.

@dsanke - can you help edit this one? I see in Revlaays tool, and Coffeetime looks like Init16CPU’s / HT needs fixed, and possible PCIE patch but not sure. See comments above to DeathBringer, this BIOS already Coffee Compatible (EA/EB), but need ED/R0 compatibility added

@kruchydik - Please test, this is same BIOS I sent you before, but with updated vBIOS, GOP, VBT (so test onboard GFX first).
This also has downgraded ME FW, but depending on how you are flashing on BIOS it may not go in (flash programmer, or unlocked FD and FPT needed to downgrade ME FW, or pinmod to unlock FD, then FPT)…601626771645811

* Edit - @kruchydik - Since you have programmer, program in the BIOS above, then remove ALL power from the board, short power on pins for 15 seconds, then let system sit for one minute with any power connected to board, to reset the ME FW state after downgrade. Then test.
If that does not help, program back in the BIOS below, this is same as above BIOS, but with un-edited ME FW back in there from original BIOS, and unlocked FD. So this contains updated vBIOS, GOP, VBT, and the inserted/removed microcodes…257489198965086

Try to disable HT.
Or read this - [GUIDE] Fixing HT for Coffee Lake CPUs on Skylake and Kaby Lake motherboards (Z170, Z270)

Thanks DeathBringer, I will try to do

@DeathBringer - Step #1 fail, so I assume step #2 null/void, but I will get into it next - On step #1 - UEFIPatch method fails, and manual hex & assembly fails as well (given examples not found, so nothing can be replaced)
* Edit - Step one, maybe? @ sub_FFEC7641 I found the following, is this correct, edit to what is in guide instead of current contents?
lea ecx, [eax+ebx+60578h]

lea edi, [eax+60000h]

mov esi, [edi+2CCh]

Never mind, I am lost at the math part >> “And we know that “m” (value stored in eax) is 64 or 0x40 hex for our CPU (we can get this value via cpuid instruction - cpuid(5):ebx[15:0]), we can replace it with” << I don’t understand this, nor do I know the value for i7-9700 CPU
So even if that is correct lines to edit, I would never have correct values to insert. This is above my editing skills

Would it help, for testing, to see if this is the issue, if I make him a test BIOS with HT Hard disabled (all possible areas, Setup, AMITSE-SD, ALL NVRAM+Shadow NVRAM)?

I tested everything. i7 9th works well on both modifications but only onboard GFX, no need to lower ME FW, I tested various graphics on PCI-E and the motherboard does not get up (beeps)
i3 8th no problems this and this works. We are close and I hope that the PCI-E problem can be fixed :slight_smile:

i7 9th.jpg

Try this - Fixing PCI-Express for Coffee Lake CPUs on Sky/Kaby Lake non-Asrock(and some new Asrock) motherboards

@kruchydik - Thanks for testing both, so first and last BIOS in post #8 works, good to know.
So yes, I’ll see about fixing PCIE for you tonight, thanks again DeathBringer
Quick check with tool, and manual, nothing found for the four patterns Did you test all PCIE Slots?
I don’t have any time right now, so will have to look into this tonight when I get back

I checked the additional PCIE1x connectors through the adapter. i7 9th works with external graphics.
problem with PCIE16x remains

Thank @Lost_N_BIOS refer me this thread, luckily I know what you need.
Here is the modified BIOS ,rename to .7z before you extract.

Remove DRAM SPD Write Protection
Enable PCIE
Fix 16-threads support
Update IGFX vBIOS to v1062, GOP to v9.0.1107, GOP VBT to v228
All CFL-S microcode (4.47 MB)

Checked and tested. Everything is working now. Thank you all very much.
You are amazing !!! magicians


@dsanke - Thank you! BIOS was already working OK with internal graphics, just needed second link BIOS in post #8 fixed for PCIE, maybe HT too not sure (He didn’t let me know yet)?
But anyway, yes thank you for jumping in to help!! Can you please Tell me which are the modified modules only for PCIE fix, so I can compare to originals and see how this one is fixed for PCIE - thanks!

* Edit @kruchydik - I see only 8C/8T, do you have HyperThreading Enabled? Sorry, never mind, I see this CPU does not have HT All along I thought it did

@Lost_N_BIOS Si/PlatformInit(PreMem) , total 4 PEI modules for PCIE fix. I modified that BIOS based on the main thread file, you can compare it.

@dsanke - Thanks, so to confirm >>
1. PlatformInitDXE - C5046EFD-7BC3-4206-987C-32DA45026E6D
2. SiInitDXE - ACD28235-075B-48B5-98A1-DA04FCAF84F3
3. SiInitPreMem - A8499E65-A6F6-48B0-96DB-45C266030D83
4. PlatformInitPreMem - EEEE611D-F78F-4FB9-B868-55907F169280

Correct? I appreciate your help on this!! I just want to see how this one is edited for PCIE fix, since patcher did not work and I only found part of the signature it checks for in some modules (but none of the above)

@dsanke I am having the same pcie 16x issue, my mb is Asrock B365M Pro4 and Processor is Xeon E-2246G(U0). I updated microcode, changed the ME to corporate version and disabled ME, I can boot normally but PCIE under CPU not working. I already patch 4 PEI modules in SiInit/PreMem & PlatformInit/PreMem, but still not working. I dont know if I have done it wrongly or something I missed out. I attached the Original bios file and dump mod bios file link here, please help me fix it, thank you.…iew?usp=sharing