ECS Z97I-DRONE BIOS downgrade issue


First let me say that English language is not me native language and i apologize if there is some kind of misunderstand because of this.

Now, as You can see from thread subject, i have problem to downgrade BIOS on this motherboard. I have tried with CH431A programmer and everything goes well but after flashing old BIOS, motherboard won’t boot. Before that i have tried with Raspberry Pi and flashing process is working also. This is not a problem.

NEW BIOS is 8 Mb in size and it’s INTEL encapsulated with BIOS Region.bin, Flash Descriptor.bin, GbE REgion.bin, ME Region.bin and OEM Section.bin.

OLD BIOS is 6 Mb in size and it’s just BIOS Region.bin file.

I have tried to create one big file with exact size as NEW BIOS witch is 8.388.608 bytes and with HEX editor in exact memory place i have placed contents of the old bios. After i have flashed BIOS chip MX25L6406E with this file, motherboard is not booting anymore. After that i have flashed new BIOS with exact method and board is booting successfully.

Let my say that i have successfully rebuild NEW BIOS file with “Flash Image Tool” from “Intel ME System Tools v9.1 r7”. I have inserted new ME, changed options inside BIOS Region.bin with “AMIBCP64” and inserted new CPU Patches with “MMTool”.

Issues with this new BIOS are that motherboard RTC is not working as it should (motherboard won’t wake in given time) and there is some kind instability under Linux. With OLD BIOS everything is working as expected .

Thanks in advance on answers and again i apologize if this questions is not formulated as it should be or this thread is in wrong place!

Open your 8Mb image with UEFITool 0.21.5, click right mouse button on BIOS Region and select “Replace As Is…”, select your 6Mb file of the older BIOS and save the modified image. I’m pretty sure this image will work after flashing with RPi.