EFI black screen while trying to load and efi file

Hello, as said in the title i want to load a .efi file in EFI shell and after i tell it to load x.efi it says success and it black screens and i need to restart the pc but without the efi installed.
Photo 1

@alekskz - In your first image >> “If you don’t see a cyan screen, please disable secure boot” << Did you do that, and then try again?
Other than that, I can’t really help here, and I doubt anyone else can either without knowing what your PXE.EFI file is and why you are trying to run it in this way (have you seen others do such, with the same file, in the same manner?)

yes i seen others run it and get past the cyan screen
i just get a blacm frozen screen

Ohh, OK, good to know. You mention Cyan screen, so did I and you didn’t answer about that? Sounds like you need to see a cyan screen (ie you want to see this, disable secure boot and then try again and if you have cyan screen then proceed)
Black screen in UEFI Mode, with or without CSM enabled, or with Secure boot enabled, often means you need to update your graphics GOP (if using onboard graphics, this is in main BIOS, if using PCIE Card it’s in GFX Card’s vBIOS)
Try with other graphics and see if you have better luck. Also, disable secure boot, and enable CSM, then try again.

ok i will try this

disabled secure boot enabled csm
still the same

@alekskz Mind attaching/ linkng this driver/ the procedure? What is it you’re trying? This seems to be an efi driver for pxe but with almost 16 MB?

@Lost_N_BIOS He has a display when booting into efi shell, that wouldn’t be a problem with GOP driver/ GOP VBT at first hand?

It is a bypass for a anti cheat program .
After i write the command load pxe.efi it s supposed to let me type exit and send me back in BIOS then into windows with that cyan screen
But after i type load pxe.efi it goes into a black screen and freeze
Other users got it working as intended with asus and msi mobos

Also in the black screen photo if u look closely up top u can see a line and that is the bios image background

@alekskz 16 MB isn’t just a simple driver, this is a lot of code/software and without knowing what it does it’s almost impossible to say why it isn’t working as expected. You say this runs on other ivy- bridge boards (see a Z77 bios in a picture)?

yes it runs for everyone except me on asrock board
its not the code that is the problem
its something on my end
i tried on my laptop HP with an i3 4005u and it worked flawlessly

pxe.rar (5.78 MB)

Sorry, no idea. It’s not as large than I thought in the beginning, over 15 MB “00” between some code in the start and in the end. Maybe som help to find where it’s developed? Good luck!

when i load it into laptop it works
no black screen

Any thoughts?