Enable MCE on Supermicro X11DPH-T

Hey All,

As a digression from the other thread about allowing engineering sample Xeon Scalable chips on the Asus WS C621E SAGE,
I wanted to ask if it was possible to enable MCE (multi-core enhancement) and/or other overclocking features such as voltage adjustment and multiplier adjustment on the Supermicro X11DPH-T.

Let me know what other information you may need.

Tanks @mitdal369 - I will get into this tonight for you, heading out right now. So, Intel ME is disabled totally, or that’s fine? Sorry, I think I got confused and thought you said ME was disabled on the other thread
If this BIOS contains MCE I can enable it, if not I will be able to do all other hidden overclock settings. Can you already see “Chipset” section in this BIOS or not?
Please zip up a few screenshots of the BIOS, one that shows all visible sections/tabs, and then one of main, advanced, chipset if you have it, security, boot, and save & Exit.

No, thank you.
Unfortunately, I can’t get screenshots of my board specifically for two reasons, one I’ll be in Singapore until the 23rd or so of this month, and two, I actually took the machine apart and shipped it across the country since I’m going to host it at another location (otherwise I’d just use IPMI remotely and get screenshots).
But I looked through the manual and found screenshots of the BIOS (they’re accurate to what I remember) and the manual also goes in depth about the settings available (https://www.supermicro.com/manuals/mothe…20/MNL-1912.pdf). The useful stuff starts at page 73.
The screenshots are attached.
Hopefully that’s useful enough, if not let me know.

EDIT: Woops, forgot to attach the images. My bad.

Supermicro bios.zip (1.76 MB)

Thanks, yes all of that should be good enough, maybe a few settings could be enabled that aren’t shown in the manual since those are sometimes dated and they later enable things that were originally hidden, but it should be good enough to guess

@mitdal369 - I checked right away for MCE or Multi-Core Enhancement, it’s not in the BIOS at all, not even left over in the help/text strings
But, there is literally 100’s of hidden CPU related settings, you may fall asleep looking through them all once enabled, these should be in new main sections (Socket Config & Platform Config)
I also enabled recovery section, and several subsections in various already visible areas (some in Advanced section, some in Boot, some in IMPI, and possible a few other areas I forgot)

Due to AMI Protected ranges, when edited I see the usual warning “Opened image may refuse to boot” So, please be ready to recovery BIOS, unknown outcome with this, sometimes it’s fine.
Stock BIOS already has BG hash protected ranges mismatch warning, luckily BG is not setup properly. If it wont boot due to the above, I’ll have to have you send me a dump and see if we can edit that instead, or if it’s the same too

Thanks Lost! I’ll attempt to flash it and see if I run into any issues however that won’t be until the end of December, in the meantime, in case there is an issue, is there a set of cables that you recommend that I order to pull a dump?

Let me know when you get a chance.

You’re welcome! Can you show me an image or two of the board so I can clearly see all the BIOS chips, I tried to find good ones online but none have good enough resolution.
You already have a flash programmer?

Nope, is there one you recommend I order? And I’ll get pictures as soon as I get back.

Once I can see the BIOS I’ll be able to tell you if you need something special, or if the normal $2.50 cheap programmer will be fine.
Can you find a good review of the board online, usually there I can find good image of the BIOS so I could advise on programmer and cable. I tried looking before but no luck, maybe because I am not familiar with the board, but this exact model name didn’t bring up any good review results

Hey, has there been any update?
I have also this board and My problem is that I wanted to update the bios to 3.0c but during update it tells me that my ES QL1K is not supported but in version 2.1 it was still available.

@Lost_N_BIOS would you help me playing around with this bios.

I could provide you pictures of the bios chip.
Have you any tools for this bios??
So I can have a look at it.

I would like to have 3.0c bios running on ES cpu due to the new 2933 memory support.

[ 7.268198] microcode: sig=0x50652, pf=0x1, revision=0x80000037

@XeonScalable - sorry I missed your post until now! Do you still need help with this? If yes, do you have flash programmer?

Hey Lost_N_BIOS
Do you know if Supermicro X11DPH-T BIOS 3.0c can be modded to work with ES QL1K processors?
Thank you for your assistance

Same as here, you see mentioned above in post #9, you need 2.1 BIOS
Modify the SuperMicrox11spa-t BIOS to support ES CPU B0 step

I have the necessary SECCore, but need 2.1 BIOS for this system and the one linked above.

I do have BIOS 2.1 if you are interested in that version.

Yes, if you send me that I can make you updated BIOS that will work with the Q1LK. The 2.1 may work as-is, but I can put updated SECCore and updated microcodes in it for you, then that will best best BIOS you can have since they removed compatibility for 3.x BIOS
Do you also have 2.1 BIOS for X11SPA-T?

Enable MCE on Supermicro X11DPH-T

Hi Lost_N_BIOS,did you get an opportunity to work on the BIOS V3.0 .I did attach a download link for the files you had requested.I greatly appreciate you doing this.Otherwise Happy New Year

Lost_N_BIOS thanks a lot for your work on this mb. Apparently, the link is dead or I’m blocked in some sort. Would you like to resend it? Thanks a lot. Also, Are you willing to tell me a little bit about how you unlock the platform config things? I checked your bios mod post but I don’t see any text related to platform config in setup.sct. Is it enough to just set the visibility to USER in amibcp?


Lost_N_BIOS is been away since the beginning of the year, better post a request in the appropriate section.

OK, thanks.