Erase BIOS chip fail

Hello everyone

I have BIOS chip MX25U12873F and I can read it with my CH341A programmer with 1.8V adapter and clips, but I can’t erase it before writing new BIOS file.

I checked with multimeter and all pins have connection.

I also tried to turn off protection of chip, but software says it’s already unprotected.

Reading chip takes about 3 minutes, writing is longer, 4 minutes, but because erasing is incorrect, the verification says there is difference. When I manually try to erase it, it takes up to 15 seconds, program shows success, but when I try to read or do blank verification I have alert, the chip is disconnected. It only happens after trying to erase it, after read or write it don’t happen (disconnected alert).

The BIOS chip is from my motherboard Gigabyte Aorus X370-Gaming 5 and someday that motherboard booted into Windows normally and it was working a few hours, when I saw the switching of BIOS LED (main BIOS and backup BIOS) and after 30 seconds it swapped again and again, so I rebooted computer and it don’t start any more.

On this motherboard I had few times something like that, the main BIOS has crashed and I had to start it on backup BIOS and from Windows flash main BIOS, so it helps and both BIOSes were working. So when I couldn’t boot it on both BIOS I was thinking “that time both BIOSes crashed”.

Motherboard showed RAM and CPU failure, but I tested them on two different motherboards and CPU and RAM are working. I also tried different RAM on this motherboard and the same issue.

So I bought new motherboard and new CPU and put them into my computer and I bought CH341A programmer to try flash BIOS on old motherboard.

Because my GPU is in my computer with new motherboard and new CPU, I’m trying repair my old motherboard with CPU contains GPU (AMD A12-9800E instead AMD Ryzen 5 1600X which was used with that motherboard before motherboard crash).

Because that motherboard support that APU only until F25 BIOS version I was trying to flash F25 and F5 BIOS version.

Coming back to the topic. I was trying to flash both BIOS chip (main and backup) with a lot of version NeoProgrammer, ASProgrammer, CH341A Programmer and I can’t erase it properly.

When I try boot motherboard (with AMD A12-9800E) after flashing BIOS I have different error codes on display (like 00, C9) and always diagnostic LED from CPU shines.
Before first flash (when motherboard was in computer with AMD Ryzen 5 1600X) I had error codes from 50 to 55 on display and the diagnostic LED from RAM was shining, when I tried start computer without RAM the diagnostic LED from CPU was shining).

I don’t have idea what to do next.

maybe this page can help you
https://khandishnetwork.com/2021/01/28/ch341a-flash-erasing-error-solution/

Thanks for reply, but I’m know this website and I already tried that, when I was writing “I also tried to turn off protection of chip, but software says it’s already unprotected” I mean I tried that.