Error 25: [Csme Binary Gen] Buffer offset out of bounds. FIT Build


I’ve been reading about UEFI security and that led me down the road of using chipsec on my BIOS, I found several open vulnerabilities and I’m working on patching them. One if them is Manufacturing Mode is enabled. Another thing I read about is how ME and AMT can allow remote access to my computer, so I want to enable the HAP bit I’ve read elsewhere disables some of the ME functionality. (can’t post a link, new member here)

I have a ROM dump using chipsec, which I loaded into FIT, I set the Reserved bit under Intel ME Kernel to Yes, and when I build I get the following error:

Error 25: [Csme Binary Gen] Buffer offset out of bounds.
Maximum file buffer size: 0x1000000
Space taken by current build: 0x118a000
REDUCE IMAGE BY: 1613824 bytes
Error 2: Failed to build.
Failed to build!

I get the same error if I use fresh rom downloaded off the MSI website as well.

I’m running Windows 10 Build 19041
Attached is a screenshot with my chipset info.

Can someone please tell me what I’m missing? I’m not sure how to reduce the image size.

Thank you.

MEChipset Info.PNG

What MSI model are you talking about exactly? I can’t check anything without the dump or original image.

It’s the MSI Z390 Ace the bios files are 16MB each, I’m a new member so I can’t post links… and 6MB is the file limit for posts.

I’ll PM you links to google drive. I’d appreciate if you can share them for me.

@plutomaniac Hey, I solved the issue, I needed to clean the Intel ME region in the dumpfile before rebuilding it. I’m just new to this whole process, this forum is a great resource I just started reading through. Thanks!