Error: AMIBCP 5.02.0023 language name present exceeds 0x08 in lenght

So I have an issue with AMIBCP v5 and the supermicro h11 series of mainboards.
I tried to load the rom and get an error: Language name present in rom exceeds 0x08 in lengh. Setup tap and bios string tab will not be shown.

Gigabyte and Tyan EPIC-Mainboards do not have that behavior.
I’ve looked around with UEFITool and changed some stuff but I wasn’t able to make it work, so I decided to ask some more talented people :slight_smile:

I couldn’t find and mention of this error online, so if you’ve got any idea feel free to help me

Screenshot @

Link to motherboard download page would be great, otherwise no one can try to help.

I’ve not seen this error, but looks easy to fix by changing the long string name for whatever language file looks the longest, or any language file name exceeding 8 digits.
You should be able to see and change that with MMTool, if not UEFITool etc.

If you still cannot make any progress please link to the motherboards main page and someone will check to see if we can help.


Thanks! What are your language choices in the BIOS GUI? I am only finding EN-US and EnglishDXE, no Chinese or Japanese etc

English, as I sad I looked around and I couldn’t figure out what the problem is

I mean in the actual BIOS, when you go to BIOS, usually you can change BIOS language somewhere in the BIOS. I wanted to know if you see other options for language choice while in the BIOS (Not with tools).

I looked around a bit in the AMIBCP program and see they added this language string limit a while back, way before all versions that will work for these type of BIOS files.

If it’s only English in BIOS, no other language choice, that’s OK, and all I wondered. If so, I will look through the English language files and see if I can find the issue.

I havn’t bought this mainboard, yet. I’m looking for an EPYC Mainboard and because I’m a passioned about bios modding (not saying that I’m good) I thought I’ll take a look with AMIBCP at most of the avalible EPYC Mainboards. So all Supermicro H11 boards(EPYC Boards) giving me this error , however Tyan and Gigabyte boards dont exhibit that behavior.
This Forum provided me with all my Bios modding knownledge. There was never a time where I needed further explanation. However this seems to be undocumented, so I decided to to make this thread.

As for your actual Question :slight_smile: I’m a collector of Highend Supermicro boards and I dont own a single Supermicro board where there is anything other than English. So I strongly suspect that there is no other language than English in the Bios. I have a friend who has this board - I can ask him, but at the moment he is very busy, so a definitiv anwser could I post in about a week.

Well I guess you can’t check in BIOS then I’m with you, this is the first time I’ve seen that message too! But I thought I’d easily fix by editing the language name to within the parameters mentioned, but of course finding the offensive module wasn’t as easy as expected, still looking.
I’m considering deleing them one by one and opening after each module delete until the warning is gone since there isn’t an obvious language module. I started that last night, and found it’s in the first main section, but didn’t start going through each one deleting yet.

You might be right about English only, since that is all I found in the usual locations and ways of looking, but I’ve not noticed that before with boards so I assumed I had to be missing something. Since you’re a collector and are familiar with these, then English probably is the only choice, and that explains why I wasn’t finding others.
I will look through the two language files tonight, first deleting them and seeing which if either is it, then maybe I can get this fixed! * It’s neither of those, nor about 50+ other modules I deleted in the offending volume. I know it’s in one volume though, with entire volume removed no error, so I’ll eventually find it now.

Supermicro should know better, this has been limitation by AMI in general since 2009, sure they may not always use AMI tools, but it’s am AMI based BIOS so they should be used to doing things correctly by now.
Maybe it’s a one-off mistake on their part though? I’ll see what I can figure out tonight

It’s too bad there is no verbose mod or logs for AMIBCP!!

Thanks for your help.
I dont think Supermicro is incompetent in making an AMI BIOS, because all boards I have/know/have seen are AMI Bios I do think its deliberate, all other AMI V Bios’s working fine but the h11 Series is the newest mainboard Series and the only exhibiting this issuse…

I know they know how to create, but doing something against the AMI rules which they know is out of line is all I meant

It could also be an incompatibility issue with current available versions of AMIBCP we have and that BIOS series too, making it look like a language length issue but really something incompatible with the version of AMIBCP we have.
I just helped another member here kept having NVRAM error when saving edited BIOS with AMIBCP, sent him the newer version and no error at all with same edits.

I’ll let you know once I find the module, and if I can fix or not. Takes a lot of time to write down 3-5 modules at a time, remove those, save and test, then go back for another 3-5 etc until I can find the culprit.
I swore I almost had it once, then lost track trying to find it too fast, had to start over, so started going slower and writing down each as I removed

Just to understand, you just delete a Module and save the file than test it with AMIBCP and check if the error still exists - if yes repeat the process?

Yes, that is what I was doing, and will still do when time permits. Here is the volume the offending module is located in.



And here is all the quick notes I wrote while removing and testing, all these already removed and error remains. Might be easier for you to just start your own list or method to test chunks as you go, too many to do one by one.
Not in setup or Amitse
Not in all the blank DXE free form sections that looked like possible language files
Not in english DXE
DXE Aprori
Rom Layout
DXE Core
Last DXE unamed driver and 5 blanks above it.
10 blanks in the middle
5 blanks above amitse
Legacy region
FCH x4 from the top
SMBIOS FullShell ShellFull (Not same as others checked)
PCA9545 and 9535 + Setup
bds genericSIO CF9reset OA2
bootscriptexecutordxe OA3 AMIBoardInfo2
CBSBasedxe CBSSetupDXE XGBEi2CMasterDXE SerialMuxControl BMCLanConfig
SMBIOSElogSetupScreen esrtdxe AMISerialUART0+1 Opalsecurity RSDPPlus SMBIOSBoard
KBCEmu UHCD FBOGroupform bmcelog generielog smbioselog commonelog
statuscodesmm pismmcore httputilitiesdxe networkstacksetupscreen
timestampdxe huge swath of "AMD names" towards the top above and below serverhotplugdxe (Also that one too)
SBinterface AHCIINIT12 IMPOSDReader severamanagementsetup dxe impiusb acpi
PCIRootbirdge PCIDXEInit ExpoerhiDB reflash
csmdxe eventlogssetuppage hardwaresignatureentry hddsmart hddsecurity nvmeiniti13
SATADevInfo AMITCGnvflagsample amitcgplatformdxe
tcgdxeplatform tcglegacy tpm20platformdxe
USBRTDXE USBINT13 pspplatform pspdxe

So, you started from the top - so I’ll start from the buttom of the offending volume

First I started with bottom, then top, then middle, then all without names/blank, in chunks, etc. Then I got lost and my eyes hurt so I had to stop. Sorry I have not been back on it yet, but I will when time permits.
If you find the file before me, let me know which it is and I will look and see if anything can be adjusted or not.

Hi !

I am facing the same issue with the BIOS of the H11 DSi motherboard. I tried different versions of AMIBCP (4.55, 5.01 5.02) but still ended up with the same error. Have you enventually found a way to solve this problem?

I gave up trying to find it, almost had it I thought, screenshot’d a few remaining files to remove that it had to be in I thought, then removed those and it was still there.
It’s in the region I showed above though, because I removed the entire region and issue was gone, put it back and back came the error, so if you go through one by one and remove, save, check, remove, save, check you will find it eventually.

I think that several modules cause the error. When I delete all the file inside "8C8CE578-8A3D-…" from the bottom up to "899407D7-…" (Setup) (not including this file) the error is still there, but when I include it the error disappears, which means that at least the file "Setup" is causing it. However, removing only "Setup" does not solve the issue…

**** EDIT ****

So, after a bit of work I found all the wrong modules. The list is:

- Setup
- ServerMgmtSetup
- ReFlash
- EventLogsSetupPage
- HDDSmart
- FboGroupForm

When all these modules are removed the BIOS can be opened in AMIBCP v5.02 without any error.

Is it possible to solve the problem with the modules without removing them?

Great, I was almost there too! And thought I had a list like that, but after further narrowing trying to find the one I couldn’t. Is that how you feel now too, you can’t delete anymore of those to narrow it further down, it must be all of those?
If yes, then maybe same error is in all. Please upload those files in a zip and post here and I’ll see if I can find the problem. Thank you for your work, I spent hours trying and every time I almost had it I got lost or it seemed the list I narrowed down to ended up not being it somehow.

Thank you :wink:

Yes, all of them must be removed…

Which files do you need exactly ? I guess that you need to original BIOS but do you want me to extract the "faulty files" as .bin ?

Thanks to you too! Yes, only those modules you pointed out, please extract each one as-is and zip. Extract them with UEFITool - as-is, at the GUID Root level on each one.