Error "file size exceeds the volume size" updating mCode for Asus P8H61-MX

Asus P8H61-MX BIOS v.0711
https://dlcdnets.asus.com/pub/ASUS/mb/LG…4231.1479928122
UBU_v1_72_1

!1.jpg



!2.jpg



!3.jpg



I need only one mCode 206A7. Attempt to delete mCode from mmtool command line output the error "Patch block size not known". What can I doing? Help pls.

@AnnaBraun - Sorry, I’m not sure how to make this work with UBU, or if that is even possible, you’d have to ask on the UBU thread.
I can tell you update ucode on this BIOS is not possible with MMTool (Any version), but UBU can do microcodes without MMTool in many instances, so you’ll have to ask SoniX and see what he says

Here is mod BIOS with updated 206A7 microcode only
[[File:Updated-ucode-206A7(ONLY).png|none|auto]]

http://s000.tinyupload.com/index.php?fil…154246648857019

Updated-ucode-206A7(ONLY).png

Thanks! It’s what I need. I’ve updated realtek ethc code and added slic. I’ll try flashing BIOS tomorrow.

You’re welcome! How do you flash mod BIOS on this board anyway, certain AFU?

Afuwin 3.05 for 6 and 7 chipset series.

Odd, been playing around with the 1003 BIOS for the USB3 version, and never had a problem… I might redo with a fresh version and the A4 MMtool - I was using the latest, before UBU had them as A4 and A5 (latest patched, If I recall).
Just need to get Afuwin 3.05 now, thanks for that suggestion

@Matth79 - if you need more BIOS 1003 let me know

Matth79

Afuwin 3.05
https://www.bios-mods.com/tools/index.ph…o+and+AMI%29%2F

Afuwin bios.cap
Afuwin mod_bios.rom /GAN


I’m hunting for where the “Multicore Enhancement” went, pretty sure I saw it in the original BIOS… did Intel lean on makers to get rid of it… AmiBCP, maybe?
Examined with AmiBCP, looks like it should be enabled, seems it may be tied to using XMP or user memory timings… current RAM is not XMP, but pretty sure I tested with a smaller set that was.

At the moment, I seem to have success with Microcode, GOP, and the Network adapter… not sure if it’s worth doing anything to the RAID (EFI IRST 11.5.0.1582), as I’ll only be using AHCI - and VBIOS seems to be rather more advanced level and not sure if it would be worth going into

@Matth79 - Yes, you can see it in AMIBCP, at least on the older BIOS, let me check 1003 for USB model - I see it in AMIBCP for this model, it’s enabled by default (The actual setting I mean, not visible in BIOS or not). Nothing to do with XMP or anything like that.
If you cannot see in BIOS, set Access/Use column to User in AMIBCP, then test again. If it’s still not visible after setting Access to User then you’ll have to edit Setup module and unsuppress it.

Here’s how to do that, extract GUID 97E409E6-4CC1-11D9-81F6-000000000000 as-is with UEFITool, edit as noted below via hex, replace back as-is

Suppress If {0A 82}
True {46 02} << Change to 47 via hex
One Of: ASUS MultiCore Enhancement, VarStoreInfo (VarOffset/VarName): 0x5CA, VarStore: 0x1, QuestionId: 0x498, Size: 1, Min: 0x0, Max 0x0, Step: 0x0 {05 A6 C4 07 C5 07 98 04 01 00 CA 05 14 10 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00} << Search this string in hex, right before it you will see the 46 above
One Of Option: Disabled, Value (8 bit): 0x0 {09 0E 05 00 00 00 00 00 00 00 00 00 00 00}
One Of Option: Enabled, Value (8 bit): 0x1 (default) {09 0E 04 00 10 00 01 00 00 00 00 00 00 00}
End One Of {29 02}
End If {29 02}

vBIOS mod will only help if you are using onboard graphics. It’s easy to follow along on the guide if you want to do it, don’t let all the steps intimidate you
If you are using onboard GFX, and end up not trusting yourself to do the mod but want it, let me know and I can do for you (If you do this, send your final mod BIOS so I can add it on to your already modified BIOS)

Do you have a link for download 32/64
afuwin 5.05.04 ?

@AnnaBraun - Choose Aptio V at AFU section - https://ami.com/en/products/bios-uefi-to…uefi-utilities/
This is version 5.11.06.1854

If you need 5.05.04 for some reason, google will give you plenty of download links - or send me PM if you can’t find.

Thanks!
I’ve flashed Asus P8H61-MX mod BIOS by EZ tool.
All works good.

@AnnaBraun - You’ve got a PM

@Lost_N_BIOS I think I’m ready to try and prepare Ultimate 1003 for P8H61-MX USB3
I’ve prepped the Vbios, the GOPs and LAN ROM come from UBU, not sure if there’s a more appropriate RAID EFI IRST to add than 11.5.0.1582 - I won’t be doing RAID (does H61 even have RAID)
Got the other tool to switch that setting
UBU to update to latest

Can’t seem to find an emergency BIOS repair if it goes wrong though, my old system had “crashfree” or whatever it was called, on a scale of 1-10, risky or nothing to worry about?.
Found 2143 as the version, 2143.bsf from the original, put it out to transfer.ssf, 2171.dat & bsf and then imported, saved (it calls the .DAT a BMP document - is that right - it’s 64k like the original file)

Sorry @Matth79 - I am unsure what all that is saying Your final comment “It calls some .dat a .bmp file” Is not the program itself, you can control/change/select file extensions when you save things, if something was saved with incorrect extension, or you are not sure, do it over again or rename to what you know it should be.
Size of file is not important, well it is, but you can’t assume since two things are 64k all is well. You need to be sure it’s correct files, correctly generated, correctly replaced, and that they start the same in hex (with header or without etc)

You’re correct, there is no RAID For H61, but I didn’t check the board specs or BIOS again, there may be other controller doing RAID but it wouldn’t use the Intel orom.

Emergency BIOS repair is CH341A + U type Flat CHIP IC puller / extractor (Or, if BIOS is soldered to the board, then you need SOIC8 test clip cable instead)

@Lost_N_BIOS UBU got all the things in ok, AMIBCP changed setting to User, flashed it and it seemed to do the right twiddling.

Multicore enhancement didn’t appear.

Couldn’t find any way to id if it has actually gone in though, couldn’t find any way to report any of the versions that were updated, tried turning ROM messages on.

I’m guessing that maybe Multicore enhance might not be possible with the current microcode, as I saw some other things asking for older microcode - and if it’s a choice between latest microcode and an extra 200MHz all core, then I’ll take the latest

@Matth79 - Seeing this in BIOS does not matter what microcode you have, it will show on microcode that don’t work too, once you make it visible

Did you set Multicore enhancement to User? If yes, try Supervisor instead. If that fails, you need to unsuppress it by editing the setup module using IFR output and hex.
Edit this, right before the setting
Suppress If {0A 82}
True {46 02} << Change the 46 to 47 in hex editor

If you need me to do that for you, upload your latest BIOS mod and I will send you few BIOS to try (all with this unsupressed, but additional BCP edits after that too, might need only the setup mod done or both that and BCP after too)

Did those changes (supervisor, & the 46 to 47), flashed, still not visible, tried GPU-Z but reported unknown for the BIOS of the HD4000 - maybe it can’t get because it wasn’t active, Still cannot find any way to prove the flash took, as I seem to recall that the flash method might not actually do it.
BIOS as I set it, also did the VBIOS, the GOP and the LAN just for completeness, as well as the microcode

bios.zip (4.1 MB)