Error Loading Rom Image :)

Hi,

i tried MM-Tool v3.26 & Aptio UEFI MMTool v4.50.0.23 but both say “Error Loading Rom Image”.
can anybody help me ?

The Bios i want to open is:
http://download.msi.com/bos_exe/7587v15.zip
from
http://de.msi.com/support/mb/H57MED65.html#down-bios

thx.

@ wedok:
Welcome at Win-RAID Forum!

After having opened the BIOS with CodeRush’s UEFITool I was able to extract the BIOS Region file, which can be opened and modded with the AMI MMTool v3.26.
To make it easier for you I have attached the extracted BIOS file.
Before you are going to flash a modded version of your BIOS, you will have to run the UEFITool again, to replace the original BIOS Region file by the modded one and to rename the file.

Good luck and happy New Year!
Fernando

extracted BIOS.rar (1.02 MB)

@ wedok:

Alternatively you can extract the original BIOS Region file and reinsert the modded BIOS Region file into the complete BIOS by using an Hex Editor like HxD.
The BIOS Region part of the BIOS begins at the offset 600000 and ends at the offset 7FFFFF, which is the final byte of the complete BIOS as well.

Hi Fernando,

I also am having a problem opening my dell A7 bios backup I made with universal bios backup software

I get the same error code Error loading firmware image with MM-Tool v3.26 & Aptio UEFI MMTool v4.50.0.23

Let me know if you can open it

@ talkmods:
Welcome at WinRAID Forum!

I cannot open the link to an attachement of another Forum.
If you want help from my side, you should attach the file within this Forum or give me a download link.

Happy New Year!
Fernando

Dell compresses their BIOS so I doubt you will be able to do anything useful with it either way. PhoenixTool is probably the way to go here.

I did not get the bios from dell. I read the dell bios with universal bios backup software

This forum is not allowing me to attach a file? Its attempts to but nothing is attached after.

Here is the bios backup rom file Gabriel http://www.filedropper.com/dellinc-a07

I am trying to turn off all boot error reporting on this 5150 a7 bios


I thought phoenixtools was onlly for SLIC mods; i cant find anything that will allow me to change error reporting on the bios boot

What is your computer model? If it’s Intel you may be have a locked descriptor so you cannot properly dump your BIOS that easily with a tool.

dell dimension 5150 with a7 bios

yes it uses an INTEL 945 chipset motherboard but the motherboard is a dell proprietary board

Im guessing the bios is phoenix because phoenix tools opens the dell a7 .exe bios for slic modding properly


Fernando I changed the bios backup link to this. http://www.filedropper.com/dellinc-a07

This Forum allows to attach a file, but it has to be archived as .zip or .rar file.

Your linked BIOS file has a size of 512 KB.
AndyP’s PhoenixTool shows it as Dell BIOS, but is not able to extract its content. The standard BIOS tools CBROM32_198 and MMTool do not work at all.
So I cannot help you. Maybe you will get more support at BIOSMods Forum, where you have already posted your problem.
EDIT:

Where did you get the a7.exe file (with included installer)?

The dell 5150 a7 bios exe file is on dells website; phoenixtool will open the exe bios for me

http://www.dell.com/support/home/us/en/0…riverId=R144763

I attached the exe file as a zip on this post too for easier access

D5150A07.rar (414 KB)

For me too.
Now you can search for the CPU Microcodes within the 23 DUMP files and change the hex code according to your wishes. Since I am not an expert with this sort of BIOS modding, I cannot help you.
Then you can let the PhoenixTool rebuild the BIOS containing the modified CPU microcode.

Thanks for having done that, but the attached file was not complete and not usable. I had to download the EXE file from the linked Dell site.

can you upload v2.5.9 of Andyp’s PhoenixTool or provide a link
pm or post ?

i could only find 2.19

You can find the download link >here< at the bottom of the start post.