error to load misc bin file [solved]

I tried to flash my bios of Asus M4A79 Deluxe and now I got the error: Error TO LOAD MISC BIN FILE…

what should I do now to re-flash the original bios ? :frowning:

thanks for your help in advance

Yes, you should be able to flash the original BIOS. This way you will get your system working again, but this is not what you wanted, when you have modified the BIOS.
Please give us some informations about your system (mainboard/chipset/SATA mode) and the details about your BIOS modding procedure. Which modules did you update, which files did you use and how did you do the update?

Mainboard: Asus M4A79 Deluxe
Chipset: AMD SB750FX
SATA Mode: RAID (0)

I connected 2x Samsung Sata-HDDs to a RAID0 on an AHCI compatible RAID controller.
I got my system to run now after this "accident" with the latest original BIOS (jumper CMOS reset).

to my procedure:

I used these files:

1. AMD_AHCI-ROM_DEV-4391_v3.1.2.0
2. AMD_RAID-ROM_DEV-4393_v3.3.1540.17
3. AMD_MISC-BIN_DEV-4393_v3.3.1540.17_non-UEFI

1) I loaded the latest original BIOS into MMTool 3.26. I replaced (as descriped in your tutorial) the module of the AHCI ROM (Vendor ID: 1002, Device ID: 4391) with the ones shown above and checked careful I replace the correct one.

2) then I replaced the RAID ROM (Vendor ID: 1002, Device ID: 4393) with the ones shown above.

3) then I seemly found the ROM Module "MISC.BIN" (in the original BIOS file) I had to change with the above shown MISC.BIN file.

How did I find the MISC.BIN module ?
- I extracted all "user defined or reserved" modules, opened it with a hex-editor and searched for the "misc.sig"-string. I found it within the ID "F0".

After I replaced all necessary modules I saved the modded BIOS file and flashed the BIOS.

I have attached the module with the ID "F0", the original BIOS file and the modded BIOS file, so you could take a look. I did not find any other module with the "misc.sig"-string. (32.9 KB) (747 KB)

M4A79-ASUS-Deluxe-4101 (764 KB)

Thank you for your detailed report.
Meanwhile I have done a deeper look into the original BIOS and the one, which has been modified by you, and probably found the reason for the error message you got.
You obviously have done everything perfectly, but it seems, that ASUS has done a mistake while building the original BIOS for your mainboard:

The original ASUS BIOS contains the AMD RAID ROM module v3.0.1540.59 and the related MISC.BIN module, which both have been designed for the AMD RAID Controller DEV_4392. You can verify it by openig the extracted AMD RAID ROM module with a hex editor. Then you will see in the Offset 20 (3rd line) the hex code "92 43 02 10 92 43". Nevertheless the inserted AMD RAID ROM is shown by the MMTool as being 1002-4393.
So I think, that you have replaced the AMD RAID ROM and the related MISC.BIN modules, which are only usable for the Controller DEV_4392, by modules, which are destinated for DEV_4393 AMD RAID Controllers.
Please check the Device Manager for the correct DeviceID of your AMD RAID Controller (right click onto it > "Propertes" > "Details" > "Property" > "HardwareIDs").
If the DeviceID should be DEV_4392, I recommend to redo your BIOS modding by inserting the suitable AMD RAID ROM and MISC.BIN modules v3.2.1540.15 (designed for DEV_4392).

Good luck!

I did it now with your solution =) many thanks !

The DeviceID of my RAID Controller is shown before and after the procedure as DEV_4393.

Does that mean, that you succeeded with the update of the AMD RAID ROM + MISC.BIN file v3.2.1540.15?
No error after having flashed the BIOS?
If you really succeeded, do you realize any benefit for your system by having updated the BIOS modules?

That is really strange, but obviously you have done everything as it should, if you succeeded with the AMD RAID ROM update.

yes, it succeded with the update of the AMD RAID ROM + MISC.BIN file v3.2.1540.15. no errors.
I realized, that the detection and booting of the RAID devices are much faster without any “RAID OFFLINE” error as was sometimes the case.
The sequential write of files is increased too. I remember that I had before ~90-93 MB/s. The sequential read is unaltered, if I remember accurate.

Here are my actual results of my RAID0 (2x SAMSUNG HD252KJ) (good old ones of 2006) =)

CrystalDiskMark 3.0.2 (C) 2007-2013 hiyohiyo
Crystal Dew World :
* MB/s = 1,000,000 byte/s [SATA/300 = 300,000,000 byte/s]

Sequential Read : 109.215 MB/s
Sequential Write : 108.358 MB/s
Random Read 512KB : 39.830 MB/s
Random Write 512KB : 58.821 MB/s
Random Read 4KB (QD=1) : 0.557 MB/s [ 136.0 IOPS]
Random Write 4KB (QD=1) : 1.540 MB/s [ 375.9 IOPS]
Random Read 4KB (QD=32) : 1.653 MB/s [ 403.6 IOPS]
Random Write 4KB (QD=32) : 1.534 MB/s [ 374.5 IOPS]

Test : 1000 MB [C: 36.5% (87.0/238.8 GB)] (x5)
Date : 2013/08/03 15:29:07
OS : Windows XP Professional SP3 [5.1 Build 2600] (x86)

@ Bugger Vance:

Thank you for your feedback!
Your experience will help other AMD RAID users, who are getting the same problem.

Have fun with your updated system!

Just registered to say that i’ve followed the exact same path as topicstarter did! (Hi again Fernando, we talked on another BIOS forum before… thumbs up for you)

Omg… working on same board,had the same error after modifying the bios and rebooting, found the same hardware-id mismatch, again re-modifying with the 4392 files…after finding this topic.
I noticed the same improvements in drive detection speed, same improvements in write speed…

I primarily updated the RAID modules because i also experienced erratical drive detection speeds, that routine sometimes even timed out.
That really bugged me, but all is good now… Detection now only takes a second!

@ IMweasel:

Welcome at Win-RAID Forum and thanks for your feedback!


I would like to add something nice… In the Raid-Xpert utility i enabled NCQ on my Liteonit LCS-256, and this gave a massive boost!

With NCQ