[Experimental] NVMe Option ROM

This is not a BIOS problem.
Try this if you get an error.
Fn + Shift + F10
list disk
select disk “(0, 1, 2 …)”
convert gpt

I tried GPT and MBR.
But it did not help. If the drive has a GPT, then the error is as in the previous message.


Which mainboard (manufacturer and model) do you use?
Please attach your modified BIOS.
Why didn’t you post your report into the linked thread?
By the way - Option ROM modules are only loaded while booting in LEGACY mode.

Hello everyone,

Great thanks to Ethaniel and everyone involved to make this mod work!

I use it for quite a while now on my Asus P7P55 LX
Inserting the ROM with AMI mmTOOL was very easy

Now I want to apply this mod to my Gigabyte GA-P55A-UD4

This Board features an Award BIOS which I have no experience with

Could anyone please help me out with a detailed guide for this task?

What are the correct commands for cbrom? Where to enter Vendor/Device ID in the cbrom syntax?

As you can see in the screenshot, the SSD I want to use is a Micron 2300 512GB (Vendor ID 1344 / Device ID 5405)

Great Thanks in advance!

Best regards

BIOS Modding: Introduction and Preparations - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

[Guide] Award/Phoenix BIOS Modding - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

[Guide] Enhanced BIOS Modding of Award BIOSes - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

[Request] NVMe Support for Phoenix UEFI BIOS - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

Thank you for your reply

Unfortunately this doesn’t help me much

Most of it I’ve already read before, but it doesn’t work for me

Here’s what I did:

I downloaded the latest BIOS for my Board from Gigabyte support site
which gave me the file “p55aud4.f15”

I ran the commands

“cbrom.exe p55aud4.f15 /d”

“cbrom.exe p55aud4.f15 /pci nvmeoprom.bin”

and checked the result by running “cbrom.exe p55aud4.f15 /d” again

But after flashing this modded BIOS file to my board the NVMe drive still is not recognized by the BIOS. It’s not showing up.

I assume it’s because I didn’t specify Vendor/Device ID, but I don’t know where to enter those values in cbrom

Please help me.
What exactly do I have to do to get my NVMe drive as boot option in my Award BIOS ?
What are the correct commands ? Where to enter Vendor/Device ID ?
Am I missing out any additional steps I’m not aware of ?

Better read it again because its MANDATORY to modify the ROM with YOUR vendor/device ID of each user NVMe disk controller, not the disk itself.

Although you have inserted the NVMe Option ROM module, you obviously cannot boot off the NVMe SSD.
Assumed reason: You forgot to customize the VendorID and Device ID within the NVMe Option ROM module, which are natively set to “0000”, but have to be customized.

It is written within the start post of this thread:

So the first step to do is to check the HardwareIDs of the NVMe Controller, which is within the chip of your in-use NVMe SSD. The Device Manager will show the NVMe Controller within the “Storage Controllers” section (provided, that the NVMe SSD is connected to the mainboard).

Hello @Fernando

So I’ve tried to do it again now using OpRomCfg.exe before inserting the rom

but still no succes…

What am I doing wrong / missing out?


Device IDs of Micron Controller


Commandline Output of OpRomCfg


Commandline Output of CBROM:

  1. “cbrom p55aud4.f15 /d”

  1. “cbrom p55aud4.f15 /pci NvmeOpRom_Changed-IDs.bin”

  1. Checking the result with “cbrom p55aud4.f15 /d”


Flashing Process


Still no NVMe in the BIOS

I don’t know it, because I didn’t sit behind you while you were working with the BIOS.
Try the following:

  1. Repeat the customization of the original Option ROM file, but without touching its name (NvmeOpRom.bin).
  2. Then insert this freshly customized module named NvmeOpRom.bin into the original BIOS.
  3. As last step reflash this modded BIOS file and look what happens.

Good luck!

Thanks for your reply

Unfortunately still no success

I repeated the whole procedure from start

Customized NvmeOpRom.bin with OpRomCfg.exe (Vendor ID 1344 / Device ID 5405)

Didn’t rename NvmeOpRom.bin

Inserted the module

BIOS file now looks like this:

But after flashing the new modded BIOS file there’s still no NVMe drive showing up in BIOS

Try this BIOS for Gigabyte GA-P55A-UD4.
This build was created for NVMe ven_1344 dev_5405.
I am not responsible for the BIOS firmware.
p55aud4.rar (813.5 KB)

Hello @Dagal

Thank you very much for being so kind of providing me a modded BIOS for my board

Due to my job I’m away from home until friday and can’t do any testing until then.
So I will test the file this weekend and tell you if it works.

Hello @Dagal

I returned from my business trip yesterday and flashed the BIOS file you kindly provided to my board and tested it.

Turns out I have partial success using this file

The NVMe gets detected by the BIOS and somehow it’s even possible to boot into Windows from this drive.
But the problem is, it’s booting very, very slow. It takes about 4 minutes until I see the desktop.

Crosschecking with another Board proves that the SSD is not faulty.
When installed to an ASUS P7P55 LX with modded AMI BIOS the same drive boots into Windows within seconds

So what is going wrong here?
How can boot time be improved?

Would you please tell me what you did different than me to get the drive even detected in BIOS in the first place?

I am trying to add an nvme module to the bios of my gigabyte “GA-P35-DS4 (rev. 2.1)” motherboard. I enter vid and did with opromcfg.exe and save them. Then I add the PCI module with cbrom. But the disk does not appear in the bios. I think award bios and gigabyte are problematic in this regard. The last point I noticed in my research is that NvmeOpRom.bin is 8kb, while the nvme modules I see on this site are 18kb. Even the nvme module made in Sierra’s bios is the same way. This is the last point I came to and got stuck in my research in my free time from work. What should I do after modding with opromcfg.exe? Where does this data size difference come from? I would be very happy if there was a source link or an explanation on this subject.
Although I do not have enough knowledge about modding bios, I would be happier if you could guide me on how to do it rather than making a modded bios. It is fun to deal with and spend time with the Bios mod.
Thank you.

motherboard “https://www.gigabyte.com/Motherboard/GA-P35-DS4-rev-21#ov

original bios file “https://download.gigabyte.com/FileList/BIOS/motherboard_bios_ga-p35-ds4_f14.exe?v=05708e6b4ecca86aa34e96264113d1b8

The modded bios I found except nvme is “P35DS4_mod2_15b

PCI vendor ID 1C5C Device ID 1327

oprom I created

Hello @cmz

Didn’t notice the difference in file size until I read your post,
but yes, in the BIOS @Dagal provided, wich is partially working for me,
the oprom has 17,5kb instead of 8kb

@Dagal did you use a different file than NvmeOpRom.bin of the start post?

Could you please specify the site you’re referring to?
Personally I haven’t seen any NVMe Modules of 18kb file size yet
(except the one in Dagal’s BIOS)

Same opinion for me.
For my personal understanding, the effect of learning something
and to solve possible future upgrade wishes by myself I would highly appreciate a detailed How To - Guide
Also this would be a great help for anyone with the same problem who might read this thread in the future

Is there anyone who’s been succesful with this mod on an Award BIOS / Gigabyte board
who would be willing to share his experience?

The procedure you all understood… the thing is this was developed/tested, aiming primary AMI8 core bios.
Users of Award bioses suffers the same “instability” results, just by trying basic mods like updated Oprom modules or cpu mcodes, the NVMe induction is not different.
Then the most unexpected results, is how each OEM Award bios version/release/mb model reacts to all this, against a modern tecnology/controller/modern OS… speaking for myself, i can say that there’s no “stable” method of expected results on AWARD bios mod users, regarding guidance.
We do see better results/expectations on AMI8…
Its only my opinion, good luck for both.

I am using orom from Samsung 950 Pro.

But the SEC 950 PRO has its own OpRom embedded, still its only loaded by UEFI environment, the mod in legacy bioses is still needed to add its ID, if i’m not mistaken.
EDIT: Correction in the above 2 posts.