Firmware for Samsung 840 and 840 PRO SSDs

As snout already has written >here<, there are new Firmware versions out for the Samsung SSDs of the 840 and 840 Pro series. You can get them >here< (you have to scroll down a bit).

These are the new versions:

  1. for Samsung 840 Basic SSDs: DXT08B0Q
  2. for Samsung 840 PRO SSDs: DXM05B0Q

Since I own 2 Samsung 840 PRO SSDs, I have already flashed both of them with the new Firmware version DXM05B0Q. Everything is working fine, no data of my RAID0 partitions were corrupted.

At first look I was a little bit unsure how to flash the firmware into my SSDs, because both of them are members of a RAID0 array and furthermore I am running on them Win8 x64, which has been installed in clean EFI mode.
As a consequence I had no chance to boot off the “normal” (non-EFI) image CD, which can be burnt using the bootable ISO file offered by Samsung within the download site I have linked above.

Guide how to update the Firmware of Samsung SSDs, which are running as members of a RAID array

This is how I managed to get the Firmware of my RAIDed Samsung 840 PRO SSDs successfully updated:
  • burnt the ISO file as bootable image onto a CD
  • saved my most important files (just as a precaution action)
  • entered the BIOS > enabled CSM and set the Intel SATA Controllers to “AHCI” mode > saved the settings > rebooted
  • entered the BIOS again > set the optical drive as bootable device > saved the settings > rebooted
  • booted off the Samsung Firmware update image CD
  • flashed the new Firmware version into both SSDs one after the other
  • after having gotten the message, that the Firmware update of both SSDs had been completed successfully > shut down and powered off totally the computer (important!)
  • turned on the pc again > entered the BIOS and set the Intel SATA Controller to “RAID” > saved the setting > rebooted
  • entered the “Boot” section of the BIOS > set CSM to “Disabled” > made sure, that my Intel RAID array was listed as bootable device > saved the settings > rebooted
  • Windows 8 x64, which is on my RAID0 array, booted fine at once - no data loss at all!

I hope, that this short guide may help other users with Samsung 840 SSDs running as RAID0 array.

Good luck!

I have found with the dos file that if you have an nvidia card installed it screws up the GUI, Thus makes it blank.
So if you have onboard do the switch, this is supposed to work.
And you have a blank screen do this :
1.Go into bios and make sure AHCI is enabled even if you are in Raid.
2.Reboot into dos disk and wait for loading to finish / blank screen or blank GUI.
3.Press Y TWICE and wait for it to stop flicking around usually a minute or so, then press Y again, it should take you into dos mode.
4. Power off, restart and you should be flashed / updated to latest version.
5. If you have raid / two drives still make sure you are in AHCI But just repeat 2 and 3 then power off before rebooting back into bios to put drives back into Raid, no need to power off after first drive flash as per 4. your just doing it twice over.
Finally its important that you power off once finished this enables the firmware to kick into place.

I have done it , and its worked a treat , non destructive, Put back into raid with no problems.

HI, i have tried firmware update on W7 64 RAID 0 SSD 840 PRO 256GB using the SAMSUNG CD bootable ISO image method.
Hardware: (ASUS P8Z77-V DELUXE) bios 1908, Core Intel i7-3770K
I have one Nvidia GTX 670 and onboard Intel GUI is deactivate (at bios level).

On this experience i have never get a blank screen but a totally unreadable text/menus and sub menus (like a 3D display without a pair of glass…) on the screen (Samsung Syncmaster F2380).

I have had to guess what should be the text/menu.
I can say that the only thing i have done was to click Y key, not twice but multiple times (may be more than 8 times, i have not logged in my memry…).
Pressing the Y key is the only thing to do for the process to progress step after step.
The most important is to observe the flicking submenu and wait for the stop flicking and press Y key, wait and observe…
if nothing happen press Y again , and so on until you feel the 2 SSD firmware have been updated.
Yes no need to power off after the 1st SSD flash.
When you see the system is coming back finally under DOS , you POWER OFF.
Then as explain in previous threats your restablish the RAID setting at Bios Sata level.
Yes, booted fine at once W7 64 - no data los !!!
TRIMCHECK replied OK without need an external TRIM command.
However, Performance seems to downgrade (ANVIL PRO score downgraded from 9068 to 8764).
Any feedback on your side about performance issue ?

Zitat von Gast im Beitrag #3
However, Performance seems to downgrade (ANVIL PRO score downgraded from 9068 to 8764).
Any feedback on your side about performance issue ?
Hello 100PIER,
welcome at Win-RAID Forum!

I agree, that the Firmware update didn't boost the performance, but I don't agree with the word "issue". Differences like those you have measured can happen without having changed anything within the system, just from one hour to the next. Furthermore nobody will be able to recognize a "drop-down" from 9068 to 8764 synthetic benchmark scores.


Hi Fernando,
I agree with you, 3% less performance is peanuts.
Yes, this is not an issue because a complex software machine such as W7 or W8 has variable performance from one hour to the next.
This was only a first observation i have done after the firmware upgrade.
About TRIMCHECK OK may be the new firmware improved the thing… ?

Do you have seen somewhere what are the fixes and improvements of this new firmware vs the previous version ?

Obviously not. I just have done the TrimCheck tool test again and got the same result as before I had updated the Samsung SSD Firmware ("TRIM appears to be NOT working"). As I have already stated earlier, this TrimCheck message does not mean, that TRIM is not active at all (the hex editor test verifies, that TRIM isworking nevertheless), but I got the impression (cannot yet verify it), that the TRIM activity within a RAID0 is less with the Intel RAID drivers and RAID OROM resp. EFI SataDriver versions of the v12 series than with the v11 series.

This is what you can read under “Description” of the new Samsung 840 SSDs Firmware versions, when you enter >this< Samsung download site:

What is DAS function ??

I have done again ten times the TRIMCHECK test and got each time OK (i wait only 10 sec after step 1). So, it is very strange you get a different result…
Main difference seems you use W8 64 and me W7 64.
I use iRST V in couple with 11.0.1339 OROM RAID because on my ASUS P8Z77-V DELUXE the Bios flashback is ‘dead’, so it was not possible for me to flash the last modded Bios 1908 with OROM RAID.

On RAID 0 performance i have done again the ANVIL PRO test , but after a ‘verify’ scan started from Intel “iastorui” Windows application , and after a TRIM command issued from bench/trim anvil option menu and finally got the better score (9094) result compared to previous firmware version tests (i have tried to attach the screenshoot but ‘uploading…’ function seems endless and not working on the forum…).

Found the answer on some german site - it is "Device Activity Signal" (not "Direct Attached Storage" ^^) so if you got some Laptop/PC case/External Case with an Drive-LED it shows an indication for activity. Meaning before it sent an constant signal while now it is blinking or changing color (depending on the LED)

It should be possible with the Flash Toolkit (FTK). For details please read >this<.

It works fine for diNovoM and Mazzocato (look >here<).


I have a couple of 256GB 840 pro in RAID-0 on Win7 x64.

I just tried to update my firmware using Fernando’s method above and didn’t have much success.

Firstly, the screen display was so garbled and that it was pretty much unreadable. I switched to my integrated graphics to sort that out.

Secondly, the update failed on both drives with a “timeout on device” error. I tried a couple of times, rebooting between attempt but no luck.

Has anyone seen this before and more importantly, know what I can do about it, short of pulling the drives out and using magician in another machine?

Edit: In case it’s relevant, I’m on an Asus p8z68-v-pro gen3 using garikfox’s bios which includes Fernando’ trim OROM.


Hi JohnM,

You are not alone. I also can’t update my single 840 pro on a similar (p8z68-v gen3 non-pro) motherboard.

Let me repost my post from another forum about the situation:

I’m just about to uninstall Samsung Magician 4 and try with previous version. Will post my results.


Failed through Magician 3.2. I created a bootable USB stick and went through that… Started updating, but it took a very long time, so I didn’t have nerves to stand there and watch it all the time… I left the room. When I came back, it had exited to DOS, so I shut down the computer. On the next boot… The firmware still is 4B0Q.

Here is the log from Magician:


18052013/02:51:51:026: UNKNOWN MAGICIANGUI *************************SAMSUNG SSD MAGICIAN STARTED***********************
18052013/02:52:29:581: INFO FWUPDATE Total Number of chunks : 2048
18052013/02:52:29:581: INFO FWUPDATE Ready to download firmware chunk 1 of 2048.
18052013/02:52:29:581: ERROR FWUPDATE IOCTL IOCTL_ATA_PASS_THROUGH_DIRECT for Firmware Download
18052013/02:52:29:581: ERROR FWUPDATE Unable to download firmware for disk 0.
18052013/02:52:29:581: ERROR FWUPDATE Firmware download operation failed on S12RNEACB26833Z SSD.
18052013/02:52:29:581: ERROR FWUPDATE Error Downloading the FW Update on Windows.

@JohnM On that “garbled screen”, didn’t update as i don’t need it but i i know that symptom from Secure Erase too. There was a command line option i could use to start the tool with a clear screen.

@GrofLuigi Well, the error just shows the image couldn’t be downloaded. May some firewall blocked Magician?

@both: You could try to disconnect and reconnect the sdd after the cd/usb-stick is loading. Else if you just used Magician to burn to CD/copy to usb you could also use other methods (burn iso with any recording-tool, resp copy with “ISO to USB” or simply google with “iso” and "CD/“USB stick” depending what you want to use).

Magician is unblocked on the firewall (I use third-party firewall). It downloads and unpacks the firmware OK (as I said, I binary compare it to a manualy downloaded FW, they are identical). I think the software meant to say it can’t upload the firmware to the drive.

I tried both from CD and from USB stick, it also failed. That baffles me.

Additionally, now Magician fails its “authenticate” feature (which previously worked OK). Here’s the log:


18052013/16:40:14:035: UNKNOWN MAGICIANGUI *************************SAMSUNG MAGICIAN STARTED***********************
18052013/16:40:18:285: ERROR SYSINFO OS: Microsoft Windows 7 Professional , English (United States), 6.1.7601, Service Pack 1, 64-Bit, 0
18052013/16:40:18:410: ERROR SYSINFO DISK: Samsung SSD 840 PRO Series, DXM04B0Q, S12RNEACB26833Z, 1, 0, 0, 0, 1, PCI\VEN_8086&DEV_1C02&SUBSYS_844D1043&REV_05\3&11583659&0&FA, 3
18052013/16:40:18:845: ERROR SYSINFO DISK: SAMSUNG HD103SJ, 1AJ10001, S246J9CZ703475, 1, 0, 0, 1, 0, PCI\VEN_8086&DEV_1C02&SUBSYS_844D1043&REV_05\3&11583659&0&FA, 2
18052013/16:40:19:055: ERROR SYSINFO IDE: Intel(R) Desktop/Workstation/Server Express Chipset SATA AHCI Controller, Intel Corporation, Intel(R) Desktop/Workstation/Server Express Chipset SATA AHCI Controller,, PCI\VEN_8086&DEV_1C02&SUBSYS_844D1043&REV_05\3&11583659&0&FA, 1, 3
18052013/16:40:19:095: ERROR SYSINFO SCSI: JMicron JMB36X Controller, JMicron Technology Corp., JMicron JMB36X Controller,, PCI\VEN_197B&DEV_2362&SUBSYS_84601043&REV_10\4&20221DEA&0&00E3, 0, 169080760
18052013/16:40:19:095: ERROR SYSINFO SCSI: DVDFab Virtual Drive,, DVDFab Virtual Drive,, ROOT\SCSIADAPTER\0000, 20, 169080760
18052013/16:40:19:140: ERROR SYSTEM TUNING CSysTuning:QueryStatus_Ser: Failed to get handle to CiSvc Service ;Err code: 1060
18052013/16:40:19:140: ERROR SYSTEM TUNING CSysTuning:QueryStatus_Ser: Failed to get handle to WSearch Service ;Err code: 1060
18052013/16:40:19:140: ERROR SYSTEM TUNING CSysTuning:QueryStatus_Ser: Failed to get handle to SDRSVC Service ;Err code: 1060
18052013/16:41:04:720: INFO SSD VALIDATION ValidateSamsungSSD is started for the selected Disk.
18052013/16:41:04:720: INFO SSD VALIDATION Select Device Number : 0
18052013/16:41:04:720: INFO SSD VALIDATION after the SSD validation initialization for the Select Device Number : 0
18052013/16:41:04:720: INFO SSD VALIDATION after the SSD validation payload creation
18052013/16:41:04:720: ERROR SSD VALIDATION IOCTL_ATA_PASS_THROUGH Failed for DV. Error Code = 24
18052013/16:41:04:720: ERROR SSD VALIDATION Write Log SMART failed for DV.
18052013/16:41:04:720: ERROR SSD VALIDATION Unable to execute S.M.A.R.T WRITE LOG Command
18052013/16:41:04:720: ERROR SSD VALIDATION SMART WRITE Log failed for validating the SSD

The errors might be caused by Intel RST driver (v12.6.0.1033), but then why would it fail from CD/USB boot? I even tried powering off the computer, pulling the wall plug, waiting few minutes and booting straight to CD - no luck.


Hm, you do have CSM enabled and UEFI Boot disabled? You have some setting to save options in BIOS? Then you could try that, load defaults and try again.

I loaded defaults and even reflashed the bios (from Garikfox, with Intel modified OROM - even though I don’t use RAID currently, I might in the future). Same errors after that.

But, the MEI firmware version didn’t revert to whatever it was with bios 3603, it’s still, which I flashed without thinking some time ago. I have growing suspicion that it might be the culprit. I will look for a way to revert it to version, for Sandy.

Edit: I don’t have CSM option, I guess the closest would be “PCI ROM Priority” which has two options: Legacy ROM and UEFI. I don’t and never have used UEFI.

Edit2: I flashed flat bios file with Flashrom and it reverted the MEI firmware version to I guess that was the version BIOS 3603 came with. Still cannot flash the @#@!$%@ Samsung.


Okay, what i would try in your case: if possible test on another pc. If not, beside default BIOS, also start with minimalistic Boot: just 1 RAM, no PCI(e) Cards (except Graphics if you don’t got IGP with MB/CPU), at best no USB components (just PS/2 Keybord if you have), etc. You might also try different SATA Ports and/or cable. If it still fails (or may if you found the problem too) contact Samsung.

I don’t have enough time for that. :slight_smile: That means I’d have to dismantle two PC’s I have (one of them is a laptop) for a day.

I just thought of something else… Maybe this is making me problems… I have a (not so) old IDE DVD-RW hooked to it. I will try just disconnecting it for starters.


Hi All,

I have managed to update f/w of my SSD by putting them into an old machine and using the update ISO burnt to a CD.

That proves that the CD is ok and that there is something about my rig that the update ISO/CD doesn’t like.

Anyway it’s all good now…until the next firmware update comes out :slight_smile:


It was the Sata<>IDE adapter that was making me troubles. Today I finally disconnected it and updating went smooth as butter.