Firmware update on NEC uPD720200F1 USB3.0 host controller

I recently refurbished and built two PCs with Gigabyte boards and Core i7-870 and Core-i7 880 respectively with the intent of running Win 10 on SSDs. The i7-880 is running in Win7 Pro and Win10 Pro with a Gigabyte GA-P55A-UD4P (rev.1.0) BIOS F14 with no problems whatsoever.

I built the i7-870 with a GA-P55A-UD3P (rev.1.0) BIOS F14 but I am having a problem with the Renesas USB 3.0 Host controller. The device can’t start (code10). I tried every possible driver I could find for it. It won’t start after a fresh install of Win 7 pro completely patched and updated. The same issues occur with the most recent Win10 build on the same PC.

The NEC device properties on both boards are nearly identical:

For the UD4P:
Device Description NEC uPD720200F1 USB 3.0 Host Controller
Bus Type PCI Express 2.0 x1
Bus / Device / Function 4 / 0 / 0
Device ID 1033-0194
Subsystem ID 1458-5007
Device Class 0C03 (USB Controller)
Revision 03

For the problematic UD3P:
Device Description NEC uPD720200F1 USB 3.0 Host Controller
Bus Type PCI Express 2.0 x1
Bus / Device / Function 5 / 0 / 0
Device ID 1033-0194
Subsystem ID 1033-0194
Device Class 0C03 (USB Controller)
Revision 03

Only difference is the Bus and Subsystem ID.

I am convinced I need to update the firmware on the UD3P NEC device and the problem might be solved. The Gigabyte FAQ on this board suggests doing just that:
How to improve the compatibility of USB3.0 devices? “Please download the "Windows Firmware Update Tool" and execute the file "F302108FWUP6.exe", then your firmware version will be updated to the latest. Note: Windows Firmware Update Tool is only for Windows 7/Vista/XP”

When I try running F302108FWUP6.exe or any other Firmware update tool and flash utility I have been able to find- they all fail to update the firmware and display errors.

Can anyone suggest anything else and or point me to the correct firmware update and utility for this chip.

Thanks for your help.

Maybe these firmware updates can solve your problem.

Thank you for taking the time to respond.

Sorry for the lengthy response but I have done some troubleshooting which I wanted to share.

Station Drivers was one of the first places I looked. It lists the most current driver for Renesas/Nec uPD720200/720200a as v Firmware is v

Windows 7 loads the Renesas Electronics driver version dated 25/10/2011 by default but with that driver it won’t start (code 10). Trying to update the driver by searching on-line comes back with “this is the most appropriate driver”.

When I try installing the latest driver version on the UD3P it goes through the installation and for a moment the yellow exclamation mark on the Renesas host controller in device manager goes away, starting it, but then immediately goes back to the code 10 won’t start mode.

When I try the latest firmware update from Station driver v it runs but stops ¼ of the way through with Error 10. If I uninstall the driver it runs but fails at the start, stating error 9. This tells me that it won’t update the firmware on a device that is stopped.

I recently tried the following: The GA-P55A-UD4P (rev.1.0) is running well so I tried to update the firmware listed on Station Drivers v It has the same RENESAS/NEC chip, the same bios version as the problematic UD3P.

It updated the firmware on the UD4P with no problems.

I then updated the driver on the newly updated UD4P firmware - no problems there either.

This confirms that it is the right firmware updater and driver for this chip.

I had a conversation with Renesas Support on this and they believe that either the UD3P has been loaded with custom firmware or it’s a hardware issue with the board’s USB3 controller.

This is why I came to this forum. You guys are experts at custom bios and firmware updating. Given the information above what is your opinion? Can someone guide me through how I might update the firmware on the UD3P device perhaps using custom firmware to see if I can get it back up?

By the way, the end goal here is to be running the UD3P in Windows 10 Pro. I only went back to Win 7 Pro to eliminate the possibility of a Win10 incompatibility issue.

The UD4P has been running perfectly in Win10 for 8 months now and now runs with the latest firmware and driver from Station Drivers as described above.

Thanks for your help.

Those are the Versions I have on a X58A-UD3R I did the firmware from SD several months ago to fix a Sleep problem with a 4bay USB3 Mediasonic Server.

In win10 it likes to replace the Driver with it’s own Driver , so to put NEC driver back I have to Force the install manually in DM and install BOTH INF’s in the Folder (Hub and XHCI) I downloaded from here on WinRaid. (You are trying the 64bit driver right?) I assume the Full package would do the same…

USB 3.0/3.1 Drivers (original and modded)

Perhaps Try F12 Bios if Renesas thinks F14 is corrupt , I see it mentions fixes for USB3

I can check my Other info if you need me too , (how did you pull the Bus info etc) but looking in DM it appears to be the same as your Board


an after thought is that I have the Marvell 9128 Controller disabled on this Board , perhaps try that too incase it is effecting PCIe lanes for USB3 too.

(I use the Intel and JMB Sata Controllers only)


I will try that and let you know thanks.

I had another thought. Perhaps there is a DOS based firmware updater for this chip.

The updaters I have tried are all Windows based so if I boot into DOS and run a dos based firmware updater for the NEC/ RENESAS that might work. Anybody know of a DOS based Firmware updater for the NEC uPD720200F1 USB3.0 host controller?

Oh and BTW I used the AIDA Extreme free version to get the bus info and other information on the chip

did you see…

[Guide] Flashing and Updating Renesas/NEC USB 3.0 uPD720200AF1/uPD720200A Firmware


I did read

[Guide] Flashing and Updating Renesas/NEC USB 3.0 uPD720200AF1/uPD720200A Firmware

thanks but the link to the firmware flasher is broken

I think that the 4.xxxx firmware is for the Rev. 4/200A Revision Chips not the Revision 3 Chips/200AF1 like ours ? so YMMV

I was wondering if you had tried the W200FW35.exe with commandline switches actually

did you try PMing the OP of that thread ?

no need another link in that thread further down… not sure if right file though……ware-4021.shtml


Hi KB.

thanks for your response. Haven’t been able to find the time to get back to this until tonight Nov 6,2016.

I tried Flashing the bios to F12 as you have previously suggested. Now running bios F12.

then went to Softpedia site and downloaded latest firmware updater: W200FW36 and firmware F402103.mem and used
[Guide] Flashing and Updating Renesas/NEC USB 3.0 uPD720200AF1/uPD720200A Firmware

Command line in elevated command prompt:
w200fw36 /srom 0 /address 05-00-00 /write F402103.mem cfg.ini

[Target Device]Bus:0x05 Device:0x00 Function:0x00
This Device is uPD720200(Revision 3).
Can’t get Serial ROM Information (-51)