Fitting BIOS of Akoya P8610 to Akoya P8612

Hi to all,

my problem is as follows:

I own a Medion laptop model Akoya P8612. It has a NVIDIA 9100M G chipset (MCP79) and uses hybrid SLI with a GT230M.
Acouple of month ago I believed there was a BIOS update released which I flashed. Unfortunately it was for the previous model Akoya P8610 with a 9600 GS for hybrid SLI. Never the less the machine is still working but not the second graphics adapter of course.
I tried to get the original BIOS in different forums and also contacted the manufacturer because they don’t offer the original release for download.
But I did not have success (they wanted me to send the machine and pay about 150 € for servicing).
Now I found out that I can open and modificate the 8610 BIOS file with Phoenix BIOS Editor. I found the secondary graphics adapters BIOS as an optional ROM inside the BIOS. From Techpowerup I got a BIOS for a GT240M (GT230M was not to find) and replaced it with the 9600 GS BIOS but still the card won’t work.
I think there are some other points to change but I’m lost where or what to look for as I don’t know much about Phoenix BIOS and this tool.

Does anybody have an idea or some know how to share?
Any answer would be highly appreciated

Best regards hanson


Since I haven’t yet tackled Phoenix, I’m curious enough to try. But you should know that the first thing to do would have been to upload this BIOS file. Run the devcon.bat attached and post the pci-list.txt file created. Also run PCI-Z and attach a report. What I am interested is the ID of the cards. It is more than likely that 240M has a different ID, thus needs patching to match your current 230M ID.

One thing confuses me in this sentence - “replaced it with the 9600 GS BIOS”. You are trying to get 230M to work or 9100M/9600M? If so, do you want the 240M VBIOS to be down-clocked to 230M speeds? Do you have some references clock or this is good enough?

Note: devcon is usually found in WDK (Windows Driver Kit). If anyone has it installed, please upload a clean copy. I took this from DDU and use it to batch enable/disable of devices.

I can’t edit the previous message, so here is the file containing devcon.

PCI-Find.rar (105 KB)

Hi and thanks for your reply. I will attach the BIOS for you. I will check the ID of the 230 asap and submitt. For the clocks they should be standart (RAM 1600, GPU 550 and shader 1100). Regarding the 9600 GS: of course I want to use the GT230, the 9600 is inside the wrong bios I used.

I take a quick walk with the dog and take care of the rest of your requests.

Best regards hanson

Forgot the Bios… (1.2 MB)


The device ID’s for the GT230M are:


Also please find attached the requested report files…

Best regards hanson (1.55 KB)

I have attached some files that needs your moderation. I cannot vouch for their safety, because I had troubles with the tools I worked with. That is why I have also attached the modules for your own “pleasure” of trying to insert them.

File “FLASHABL - 230M.ROM” is done with Phoenix BIOS Editor and has a real 230M VBIOS from a Toshiba laptop, just the platform ID has been changed to Medion. It is your risk using it, because PBE showed some warnings when opening the file (the PBE I found is infected with a trojan) and PhoenixTool didn’t knew how the handle the bigger module. Just rename the file to FLASHABL.ROM, replace the original one and flash.

File “FLASHABL - 240M_mod.ROM” is done using PhoenixTool (since the VBIOS had the same size as original 9600M) and has a 240M VBIOS from Acer, but with ID&clocks changed to 230M and platform ID changed to Medion. I can not guarantee that everything is in order!

I have also attached UPDATE0.ROM with updated microcodes, too many to count. Since I have attached all the needed modules, it would be best to try modding yourself with the desired VBIOS and also changing DMI to P8612.

P8610 - mod.rar (1.33 MB)


thank you so much for taking the time to do it all for me :-). I’ll test everything right now and report asap…

Best wishes hanson


Hi again,

unfortunately I have to report that your mods don’t work. It’s similar to the mod I did already myself. Flashing and restarting is no problem. But inside Windows in the device manager the card is just listed with a yellow mark as “microsoft basic display adapter”. The error code is"31". “Windows could not load the driver, because the driver that is started is not identical with the driver for the provided graphics adapter” Whatecer that means :-(.

I think there are some “connections” inside the BIOS structure somewhere else. Anyway I’ll try a mod myself with the provided roms and give it a try…

Thanks a lot so far and have a nice evening.

Best regards hanson

And if you like here’s the Bios Editor (surely free of virus :wink:

BIOSEdit2.2.13 (6.07 MB)

I think you need to reinstall graphic drivers, since the device slightly changed. But you must choose between latest 337.50 drivers (for 230M only) or 258.96 for hybrid sli, at least according to this.

Use DDU to fully uninstall current drivers, then reinstall the above drivers and test with each one. There is nothing else that could be done inside PBE. The OROMs should be picked based on their signature _R0x and loaded for each ID. It has already been attempted with success by others to add support for other cards than original.

It could be a false positive, but I’m getting the same warning from KIS about this PBE

No success unfortunately. I get the same error text for the adapter directly after cleaning with DDU and also after installing the 337 beta release (old one does not support Win 8.1). Maybe the BIOS itself can’t handle the card because she was released after the BIOS was built…

Anyway thanks for your time and effort and I could learn a little about Phoenix BIOS (I modded one by myself, I found newer LAN rom and RAID rom in the web)

Best regards hanson

I didn’t add this yesterday because I thought it will work as it is. But you can give it a shot. Here is an older VBIOS for 230M, not sure from what card, I think HP or Dell. Try with each one and reinstall drivers every time.

GT 230M.rar (83.9 KB)

Thanks a lot mate. Did not lead to success unfortunately, I get the same error each time… :frowning:

Best regards hanson

I still think this is a Windows bug. The Nvidia installer clearly detected the card, based on your report, the device manager did the same. Here are some tests for you. When you flash a BIOS with an original 230M or 240M VBIOS (not Medion ID), does the full ID of the card changes in PCI-Z? Do you have the time or will to flash a BIOS with a modded 230M VBIOS (with Medion ID) and clean install a new OS, to check if the card works in this new environment?

You can also ask this user for a dump of his BIOS, maybe he still has this laptop.

Hey, I’ll start testing by this evening after work. A clean OS would be a good idea probably. I could use the OEM Win 7 that came with the notebook, In that case I could use the 258 driver without problems. I’ll let u hear about the made (or not made) progress.

So far hanson

OK, so I did a fresh install of Win 7 with the modded BIOS. The problem remains the same even with the original OEM driver v182.xx… The card refuses being started or properly installed :-(. I think there must be other positions in the BIOS that make the difference between 8612 and 8610 machine. I’ll try to contact the guy to recieve a proper dump if I’m lucky but I tried this method probably 10 times already. Normally I don’t get a reply because the related threads are quite old…

Will cross my fingers :wink:

Best regards hanson