FIXED! - INCOMPATIBILITY after installing RST Drivers (Gigabyte P965-DQ6)


I have a Gigabyte P965-DQ6 with ICH8R and I had 3 WD setup as two volumes of raid 0 and 5

I recently reinstalled my OS and updated the Rapid Storage Technology driver to version

Now I cant boot as my Raid Rom does not recognize my raid volumes, it just shows the discs as incompatible.

Please help me, I have valuable information on my Raid 5 volume and I really need to get it back, what should i do?
I figured i need to update my ROM but to what version, and how should i proceed?

Thanks in advance

@ zone2097:
Welcome at Win-RAID Forum!

It was not a good idea to let your Intel ICH8R SATA RAID Controller work with a RAID driver, which has been designed exclusively for Intel 8- and 9-Series Chipsets.

Which Intel RAID ROM version is within your BIOS?

It depends on the location of your system drive. Is it inside or outside the RAID5 array?
If the current drive C is outside the RAID5 array, you can recover the data easily by the following procedure:
1. Unplug the power cables of the HDDs, which belong to the RAID5 array.
2. Reinstall the OS (which one is it?).
3. Install the Intel RST driver v11.2.0.1006 WHQL.
4. Reconnect the power cables to your RAID5 members.

The method depends on the BIOS architecture (Award/Phoenix or AMI). You can find the related guides within >this< Sub-Forum.
Regarding the Intel RAID ROM version I would recommend to insert the v11.2.0.1527, if there is enough space within the BIOS.

Good luck!
Dieter (alias Fernando)

Thanks for the quick reply Fernando,

My system has an Award Bios with Rom version and i was running windows 7 ultimate

The System was installed on the raid 0 volume but both volumes were spanned over the 3 HDD so the rom doesn’t recognize any of them.

I do however have a spare drive I could use to install a new system… maybe that could be of use?


Zitat von zone2097 im Beitrag #3

Ok, this explains the problems you got after having installed the Intel RAID driver v13.2.4.1000.
[quote]The System was installed on the raid 0 volume but both volumes were spanned over the 3 HDD so the rom doesn’t recognize any of them.

If the RAID ROM wouldn’t have detected the RAID members, it wouldn’t have been able to create the RAID arrays.

Yes, you can use the spare drive for doing a backup of your most importanr data.
The next step would be the update of the Intel RAID ROM module of your BIOS. In your case I would insert the Intel RST RAID ROM v10.1.0.1008, because it is much smaller sized than the later ones. The jump from an MSM v6.0 module to an RST v11.2 one may be too far.

Ok just making some stuff clear as I feel you need some clarification.

The volumes have been created a few years ago. one raid 0 volume and one raid 5 volume, both using the same 3 HDDs

I formatted the raid 0 volume and installed a new system, I did not remake the volume just formatted it. Then proceeded to install all the drivers, which included RST13.2.4.1000

After rebooting the rom did recognize the discs but not the volumes. Listing the disks as INCOMPATIBLE.

So, as i understand, my only option is to reflash the bios with an updated rom module right?

Does that mean, that the RAID0 array is a member of the RAID5 array? I have never heard about such RAID configuration.

The formatting of a RAID volume doesn’t touch the RAID configuration. So if you just formatted the previously used system partition, all RAID partition tables should be still within the boot sector.
The main question for me is: Did the Win7 Setup detect the RAID0 array at the beginning of the OS installation or not?
If you dont remember that, you can verify it by booting off the original Win7 image until the point, where you have to decide where the OS shall be installed. What do you see then?

I am not sure, if you will be able to re-establish your previous RAID arrays, because I suspect, that you may have destroyed the RAID partition table, when you installed Win7 the last time.

No, no… This is all a misunderstanding… i’ve created 2 arrays but both use the same 3 disks.

Correct, when i installed windows it recognized both volumes, i then formatted the raid 0 volume using windows setup and installed windows on that volume again.

The system booted up correctly and both volumes were working.
I then installed the RST driver and the computer rebooted.
Then, and only after installing RST, my RAID rom stopped recognizing the volumes, and is now identifying my drives as INCOMPATIBLE.

I assume the raid configuration was updated by the new driver and that my old rom cannot make sense of it.

That doesn’t make any sense for me.

It seems possible, that the old RAID ROM (= actual Firmware of your on-board RAID Controller) was incompatible with the installed RAID driver version, but it should still be able to show the RAID configuration, when you hit CTRL+I while booting, because at this time the Windows driver is not yet active…

It doesnt, it just shows the disks as incompatible.

Here take a look:

So. I’ve managed to install a new system on that spare drive, installed RST v11.2.0.1006, and you want to know what? My volumes are there and are recognized by the OS!!!

Its just my bios who cant handle the information and therefore cant boot from there…

I’ll probably just backup the data and remake the volumes… but before remake them i’ll try rebuilding them with an older version of RST.

Thanks for your time, i’ll post my results here when i’m done fiddling with it.

That’s great - congratulations!

Hello again,

So, i’ve backed up my data and decided to fiddle around a bit now that the important stuff is safe.

I’ve tried updating my rom by following your guide.

I was able to flash the modded bios and boot.
I even modded the bios logo (just because) and it worked.
However my RAID module doesn’t seem to be working properly, my bios doesn’t seem to be able to load it and i cant enter the configuration (ctrl+I)

I’ve tried versions v10.1.0.1008 and v11.2.0.1527 with the same results.

Even though the bios module doesnt seem to load, the OS is able to see the volumes and i am able to access all the data.

Could i be doing something wrong?



No, you’re not doing anything wrong; the simple fact is that any ROM newer than is too big for the GA-965P-DSx BIOS.

I had exactly the same issue - cannot access the BIOS config via CTRL+I.

Go for as I did and you’ll have no issues.


Thanks I’ll try that.

Updating the rom to fixed all my issues.

The system now correctly recognizes all my volumes!

Best regards to both of you!

Thanks for your final report and congratulations for your great success!

Have fun with your updated system!
Dieter (alias Fernando)


Glad to hear it worked for you too.