Fixing certain memory timings bugs on Gigabyte Z370 Aorus Gaming 5

Hi guys, Gigabyte have been unhelpful in rectifying these BIOS bugs so I would like some assistance to fix the memory timing bug issues that are plaguing this motherboard.

Bug 1: It doesn’t accept TRC values higher than 64 so if I set higher timings I will need to increase TRC value to match the Intel formula of tRP+ tRAS thus unable to clock the RAM higher.
Bug 2: Certain timing combinations will refuse to POST which is anything higher than 17-21-21-41 will refuse to POST
17-21-21-39-2T – POSTS
18-22-22-42-2T – NO POST
Tested at 3733MHz in this case using Hynix CJR DDR4 kits.

Link to latest BIOS:…

@Lost_N_BIOS and @dsanke Any way to modify the modules to fix these issues?

@rootuser123 - Does #2 happen at 2666-3200? If yes, does the same happen at 1T?
I don’t get what you mean at #1, in your #2 example 18+22 (=40) does not = over 64, so what is the issue or need to set more than 64?

I am not super skilled in DDR4 OC, so please forgive me if any ignorance is posted above

@chinobino @ket - can you advise, or mod BIOS here?

Yes, my bad, it should be tRC = tCL + tRAS
For #1 it does happen at lower clocks. Looks like the BIOS was more optimised for tight timings like Samsung B-Die.

@rootuser123 - Ahh, thanks, now that makes more sense for #1 I can increase the max allowed, but I don’t think the way I know to do that always actually changes the max applicable allowed amount, you’ll have to test and see if it works or not.
Thanks for confirmation on #1 also happening at lower speeds, wait… I assume you meant #2 happens at lower speeds, correct?

Here, flash via Qflash, check if you can set more than 64 now, and if it actually applies (Check in OS)

It’s terrible that they are now commonly tying tRCD/tRP together, that severely limits some possibilities with certain memory!
And for #1, I assume you did mean tRCD, second main memory timing as shown in CPU-z, correct?

Wait! Before I do anything here, please show me image of tRCD selected in your BIOS, so I can see it’s “help” text.
The area that does not have these two tied together, looks like it’s set to allow anything as max, but the other area where they are tied together and named as such (tRCD/tRP), doesn’t look like the one you’d see in BIOS (but it’s max is 63/3Fh so 64)
Also, this will help to clarify if you are talking tRC or tRCD, since I’m not 100% sure due to the “rule” you gave - for tRC it should be as noted below, so not sure which rule = what you mentioned
tRC = tRAS + tRP

For #2, yes same issue at lowered clocks. Setting tRC value involves adding tRP and tRAS together. Btw, you forgot to link the BIOS in the post.

This is where I got the rule from. This is the answer from Gigabyte.



@Lost_N_BIOS attached is the memory timings page.


Hi @Lost_N_BIOS , have you had the time to modify the BIOS yet?

Also if you can, are you able to PM on how to accomplish the mod? I am keen to learn how you did it. I want to learn to do it myself in the future.

@rootuser123 - Please use edit to add more info/questions etc, instead of making multiple posts in a row - thanks
I did not add BIOS because I said wait, needed to see something from you first. Yes, Answer from Gigabyte is same as what I gave you above at post #4 tRC = tRAS + tRP (Does not match what you said in #3 tRC = tCL + tRAS, but is what you said at #1 )
Thanks for memory page image But it’s skewed and I can’t see everything (can’t even see name of setting selected). Please make a new one and use F12 hotkey to screenshot to USB, then zip that image max compressed and attach

Yes, once we test mod, and if it works, I will show you how to do the change.

@Lost_N_BIOS Hi, I can’t find my posts at Tweaktown about this issue (they delete some threads?) but I have 2 sets of Patriot RAM that need tRC to be above 64 on my Z390 UD and at some point Gigabyte released a BIOS that fixed it (possibly F9 with the new GUI) - I am currently running 4 x DIMMS @ 3733 MHz and tRC on Auto is set to 68 from the 4000 MHz XMP profile.

I know that people complained of the same issue on the Z390 Aorus Pro, 390 Aorus Master and Z390 Aorus Elite (and possibly others) which have all been fixed with a BIOS update.

IIRC the Z370 Gigabyte boards didn’t get the new GUI and therefore were never fixed, although I’d like to be proven wrong.

@chinobino - I’m not sure about Tweaktown deleting threads, probably not though. I did see the updated forum software, so maybe old links would be broken and you’d have to hunt stuff down again.
I know I can raise max allowed in setup, which will allow higher entry, but I’ve done same before on voltages and it doesn’t let actual more be applied, so unless I know how that actual change is made in assembly or something then I’m not sure I can fix this.
Unless, this edit works for this setting and just fails at voltage related stuff (where I’ve mainly/only possibly, done before, I can’t remember if I’ve done on memory timings or not)

@chinobino I requested Gigabyte to fix it but they have refused to, what memory kit are you running btw? I will pass it on to Gigabyte to see if they can make it compatible.

@Lost_N_BIOS I will make a new screenshot soon later tonight. Thanks for the help.

@rootuser123 I am using Patriot Viper Steel 4133 MHz but they only run 100% stable @ 3733 MHz.

@Lost_N_BIOS Attached is the screenshots of the BIOS.…CIK?usp=sharing

@chinobino Any ideas on how to edit the BIOS to accept higher tRC values? I think @Lost_N_BIOS is taking a break for a little while.

Unfortunately not, hopefully Lost_N_BIOS will bbs.

@chinobino Can you do me a favour and take a pic of those Patriot ram modules with the serial numbers blurred out? Gigabyte wants that part number so they can ask Patriot to give them a test sample.



@Lost_N_BIOS Are you able to teach me how to mod the BIOS? I really want to try it out.

Gigabyte got back to me and fibbed that it only works on Z390 to avoid fixing the issue.

@rootuser123 - First I will make you BIOS and you test, then if success I will show you how to do the edit.
I don’t think it will work though, but maybe we’ll get lucky and it’s not same as doing this to a voltage related setting?

*Edit -
17-21-21-39-2T – POSTS
18-22-22-42-2T – NO POST << This should post, if you set tRC to 64 or above, can you not?
This (tRC) is already unlimited setting in BIOS (?), if you have max 64 I cannot change in the way I was thinking, it’s already set to unlimited (65535/0xFFFF), and not max of (64/0x40h)

Test this >> 18-22-22-38-2T Does it boot? If not, try this >> 18-22-22-40-2T

@chinobino - Due to the edit above, is crossflash Z370 > Z390 possible, or too different of chipset?
I looked at Z390 Ultra F9 BIOS, same as this one here, unlimited setting for MAX allowed, so the change made, if in F9 BIOS, is not done there.

@Lost_N_BIOS Z370 pch is a derivative of the Z270 chipset. Z390 is entirely different with different ME firmware.

Thanks, well I guess that’s a no-go
Did you test the two scenarios I mentioned above? Is the BIOS telling you 64 is max for tRC, or does it just auto-change it back?