Flashed wrong ME FW, help to downgrade

Hi, i think i flashed the wrong ME Version, since after the FW update, i took it off the MEI Thread here, my Audio Application shows issues. I Think i had to flash 11.8 Slim, but i flashed 11.8 consumer.

My board is asus z170-p d3

So, now i tried to reflash to the old Asus ME.bin, but it gives me error 8758. Sais its not supported by the platform.

Tried to reflash bios, but nothing, ME stays the same …

What can i do? Thank you :slight_smile:

How did you ‘update’ the ME firmware? Which tools/ commands did you use?

There’s an ASUS update, this (unconfigured) FW is 11.8 “Consumer H”??

Hi, i performed per Fwupdlcl64.exe -f me.bin from the me tools.

consumer h, yes i chose the consumer, but i think its meant to be the "slim" version

- edit: Oh sry my bad. I accidentally chose the right "consumer" … i downloaded both, slim and consumer and wanted to update slim, but chose consumer… but thats perfect because thats the right one… ^^

my audio dropouts occured, while by changing the me firmware, my authorization recognized a hardware change and when that license is missing there is a audio dropout every 5 seconds.

I thought that could be the issue of a broken MEI update… My bad thanks for your help :slight_smile: