Flashing Gigabyte while avoiding "Invalid BIOS image"

yea but what method 1 2 or 3 should i use ? i am rlly lost in that. Maybe litle help it’s black magic for me.

@2625055 Method 1 is the easiest as it can be done from Windows.

Just make sure to write your MAC address down somewhere before you attempt to flash the older BIOS as your board has an Intel ethernet adapter and it will get overwritten (erased) by FPT if you forget to ue the -savemac command.

THANKS !!! UR best. I love u i can be at my old moded bios. THANK U SO MUCH <3 !!!

Hi everyone, hoping someone may be able to help, I followed the instructions (i may have messed up) But i got all the responses as list to each step, finally restarted via the command and the PC just kept turning on and off. Would not post. any ideas. I have the copy of the Bios i want, is there a tool or something i can flash to a USB to now install and get going again. Please and Thank You.
Z390 Gigabyte Pro.

@Dopescustoms Hi, have you tried clearing CMOS?

If yes, then remove all power from the motherboard by unplugging the 24-pin atx power connector and CMOS battery and leave it without power for at least 15 mins, then plug everything back in and try to boot.

I will sure try that. I did clear the cmos and upon trying to bring it on again, it just flashes the heatsink lights and one on the top. No attempt to power on at all. I think shes GONE! Sad day really, been gaming on her for years but this will give me an opportunity to upgrade. Any ideas on a new board. I have a i9900k, I am upgrading to 64 GB of ram too. Would like some input there as well. Thanks in advance for all the help.

A bad flash can be recovered with a hardware programmer (CH341), if the vendor provides a complete firmware image or there’s a complete valid dump of the firmware in a working state.

You sure that the image you flashed would work properly if flashed correctly?

1 Like

I downloaded it straight from Gigabyte. I would think it was good. Ya never know though. Regarding the hardware programmer, I am unable to get the board to power on at all. Just flashes, about every 2 seconds. Thanks

That’s not necessary. The programmer is powered by another computer:


(Not especially recommending aliexpress, just as an example)

1 Like

I sure do thank you!! I will be looking into this when i get back home in couple weeks. Again, Thanks!

OK, I was able to get through the house during the week and I went ahead and stripped everything off the board except for ram, nvme, cpu, ect. Upon trying to power it on it has now went back to just powering on trying to post powering off powering on powering off, it stopped the flashing thing so I’m assuming that’s a good thing. Can I attempt to flash a new bios on it in this condition if so, how do I go about that?. And I do really appreciate all the feedback that I’m getting, just wanting to say I have not forgotten anyone I drive truck so I’m gone most of the time and I’m trying to troubleshoot this while I’m at home. Thanks

Hi there,
I´ve got a Problem flashing my MOBO GA-Z270-HD3P with a modded BIOS. I hope someone of you can help me, not crashing my MoBo. I did an upgrade to Ver .F9d with Q-Flash, worked fine, then put in an NVMe-Driver small compressed with the UEFItool an tried to flash again with Q-Flash and now I get the Invalid BIOS Error… One more thing, if I compare the source with the mod BIOS I have a “protected range has mismatch” parser-message, see the pic, does this mean anything bad?

I have the same layout in b660m ds3h ax bios, but the flag is not 1. The qflash says the file is not good, so they changed the flag i think.

I think i’m late to this party. Can’t flash the bios file with efiflash because the spi error.

0.87 mod worked.

It did not worked. Stuck at transfering success.
No flash edited.

87 sortof works. It tells me that it writes and verifies the chip, but the bios still at lower version, not what i flashed.

Hello @chinobino
Is it possible to bypass the “invalid bios file” error on a Gigabyte Z790 XAX?

I’m trying to install an Intel i9 14th Gen but cannot for the love of me update the bios to any higher versions. I can confirm I am downloading the correct rev1.1 versions but they ALL give me that darn error.

I’ve got an i5 13th gen on it on bios F5 atm and tried all F6-9, no luck.
Please, let me know :pray::pray: thank you!!

@Wno66 Hi and welcome to Win-Raid forums.

I don’t have a Gigabyte Z790 XAX to test with but if you aren’t having any luck with Q-flash or EFIflash you could try using the Q-flash+ button method.

Hi mates! I’ve gotta problem - got mb gigabyte a320-mh from oem supplier, so I just can’t flash any bios by any means, to use bios from supplier - i need a sn of pc which i don’t have. I always have oemid missmatch or bios id error, triend everything i can - nothing worked. My last resort was modified efiflash, and it does work but after reboot nothing happes - bios version is the same and from 2020. Any ideas how to fix that? thank you :slight_smile:

1 Like

Hello, how can i add the NvStrapsReBar.ffs to B360M DS3H (rev. 1.0) bios version F19 ? i tried Q flash and get “invalid bios image”.
While using freeDOS with efiflash, if i try using B360MDS3H.F19 i get a error but if i use something like b360m.rom it checks the corrent bios and the new bios, after that a countdown appears from 5 to 1 saying that the pc needs to restart and when it gets to 1 nothing happens, when i restart using ctrl+alt+del and check the bios, the version is still the same.

Thank you.

A similar issue to @Infarcire

I’ve just inherited a prebuilt system from a family member with a Gigabyte Z490 Aorus Pro AX motherboard and i9 10900K CPU. The Bios can only be flashed with offerings from the OEM supplier. CPU benchmarking scores are half of what they used to be so I can only assume the newer bios is a downgrade with no way back.

Is there any way the bios can be downgraded or at least reverted to the Official bios? I tried everything in DOS using Efiflash but it threw an error saying the bios file can’t be read!
I stumbled upon a Reddit article where some guy with the same kind of locked setup says he had success downgrading using Efiflash, sadly no luck here.

Thanks in advance.

As an Intel platform, there may be a chance with Intel FPT tool from ME FW 14 tools package (14.0 or 14.1 ONLY) from C. Intel (CS)ME System Tools on the linked thread…this besides EFIflash…
This this requires a little knowledge of it and requires that SPI access to regions be unlocked for read/write, at least to bios_region.

Still…the results can be unpredictive, but at least this board USB Q-Flash that may provide a bios recovery, again unpredictable.
Last resource is using an SPI programmer like CH341A or similar.
You should wait for other users, before any action with this tool.

Carefull, this tool (FPT) will write ANY DATA to the SPI without any warnings of bad user actions or wrong data provided to it.

Good luck.

Thanks for the help @MeatWar

I’ll try everything you suggested, failing that It will be used for some project or another. :+1: