[Tool] EFIFlash v0.80/v0.85/v0.87 for Gigabyte Mainboards

Hi guys,
I have Gigabyte Z690 Gaming X DDR4 (v.1.1) mobo and I can’t flash modded bios even with modded efiflash 0.99 :confused:
Bios was changed with UBU tool - standard update of cpu microcodes, vga module etc.
To original bios from gigabyte site new efiflash v1.0.1 was attached. Maybe someone could modded this version?
Efiflash_1.0.1_not_modded.zip (57.4 KB)

Doesnt that board have USB Q-Flash Plus feature… not accepted? Asus still does…
Intel FPT tool can also be used if possible… and internal EFI Q-Flash fails verification of the file?

EDIT: I didnt suggested to use the presented EFIFLASH mod files on this thread as they were for previous motherboard models, i asked if you tried the other options…

When I use modded efiflash with bios file which was changed in UBU system read file then reset into the q-flash and after that error appears:
Invalid bios image

Those with Intel chipsets that want to flash a recent Gigabyte BIOS that has a capsule and has been modified will likely need to use the relevant version of Intel’s Flash Programming Tool (FPT) for their chipset.

WARNING: You can erase/overwrite the MAC address of all Intel ethernet adapters on the motherboard with FPT so make sure you have made a full BIOS backup and record your Intel MAC addresses somewhere!

NOTE: The “-savemac” command should be used to retain the MAC address(es) for Intel ethernet adapters when flashing anyt BIOS with FPT.

1 Like

It is clear for me that I need to use FPT but which version is suitable for Z690 chipset?

P.S. I was able to update modded bios using USB Q-Flash Plus method - thanks to @MeatWar. But the quiestion is still open: which version of FPT should I use and where can I download it?

The Intel FPT tool is related to the ME FW version from the chipset.
Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15) - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (16+) - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

Theres no tools for ME16 at least to my knowledge.

Agree. I do not have any luck finding ME16 package tool. There is only FWUpdLcl64.exe and FWUpdLcl.exe on ASUS webpage here - inside MEUpdateTool.

how to download this amazing tool?

@acseyang Hi and welcome to Win-Raid forums.

As you have not tagged anyone or mentioned any names I am not sure who your comment to directed at.

The EFIflash links are in the first post and I have now uploaded all EFIflash versions to this MEGA folder.

Currently there are no tools for ME 16 (if that is what you are asking).

The problem I encountered was as follows.
After getting a completed BIOS update screen after launching efiflash with the needed version, the BIOS version didnt change at all after checking after the first reboot. There too were no reboot time that took more than one reboot to return to a boot from my normal drive.

What were the differences between the firmwares?

If you mean the BIOS Version then i tried to Update from F23 with EOMID to a F24 comercial. Because my retailer i bought the PC from may have used custom Gigabyte Mainboards but thats Not so likely, i Just wanna Test Out ever Software option i got.

This is an older thread with rather low activity about a tool that doesn’t seem to work for very new boards according to chinobinos post from february.

So to get a constructive answer it might have been useful to provide some more details like tool- version used, system used, commandline used, type of board, type of ‘custom’ gb board, maybe even a screenshot of the process, maybe add link(s) to actual firmware and firmware that’s to be flashed?


Otherwise maybe:

Good luck


I have a b660m motherboard. I tried to flash the bios uding the modded one, but it gets stuck after the transfer success line. It does not touch the flash itself.

Try the fpt method from your SKU ME engine. ME FW 16 if not mistaken

Hello. I have very strange problem with flashing my motherboard Gigabyte AX370M-DS3H which is branded with TERRA logo. There is F23 BIOS. And now: Q-flash giving Oemid Mismatch error. So I tried 4 versions of moded efiflash, I tried flash F23 (this have older date than installed on motherbord), F24, F31 and finally the newest F51m. The flashing seems to be successful. Always reads the Bios file, writes, verifies, restarts, but i have still F23 bios with TERRA logo. Any sugestions?

@erni123321 Hi and welcome to Win-Raid forums.

For your OEM AMD chipset you may need to use a different tool such as Flashrom.

As I do not own any AMD motherboards I can’t test this - if you can’t recover from a bad BIOS flash it might not be worth the risk.

I have a Gigabyte B550M DS3H AC and I am using the Efiflash_v0.87_DOS_Mod but for some reason it wont complete the “Transferring Bios Data” and it does not reboot automatically. When I reboot manually the bios has not changed.
If I use the original Efiflash with an original bios file it works fine but I cant use my modified bios. I have tried all of the different modified versions of Efiflash.
Any idea why it is not working or what I can do instead?

@SteveW Gigabyte has implemented new security for the B550M DS3H AC BIOS as of F14.

Once you have flashed any capsule BIOS you cannot downgrade or flash a modified BIOS using Q-Flash or EFIFlash.

As I mentioned in the post above, you could try Flashrom - other than that you will likely need a hardware programmer.

1 Like

Hey all,

My goal is to flash a retail BIOS onto a GIGABYTE MODEL X 11TH (intel) prebuilt that seems to have an AORUS Z590 XTREME motherboard, but Q-Flash and EFI shell methods have not worked. Q-Flash tells me that the BIOS I’m trying to install is incompatible, and when I tried via the EFI shell… nothing seemed to happen. Perhaps I did it wrong in the EFI shell.

I bought this thing secondhand for an absolute steal of a price, not aware that the thing comes pre-loaded with a dummy-proof BIOS that disables overclocking. Lesson learned, I guess. Nevertheless, I’ve spent a little over a month searching for some guidance on how to go about this. Surely it must be possible, right? I’d like to know if any of these EFIFlash tools posted here could help me out. If not, surely an SPI programmer could get the job done, no? I’m not a layman when it comes to technology by any means, but I’m definitely not up to speed on BIOS hacking/modding. If any of you brilliant folk have any insights on how to go about this, or any guides to SPI programming (given that it is possible in my case. By the way, is it?) I would greatly appreciate it.