Flashing Gigabyte while avoiding "Invalid BIOS image"

Yeah I understand that it can be whatever name I want it was just an example to make it easy. are you saying I have to take the <> off?

1 Like

YES DAMMIT, oh my god…unbl, my kid when it was 13, stoped asking me any cmd line help…

Do you know you can check the cmd help text with -h or ? or /h… please try it, you may learn something

EDIT: Wotever garden of grass BOY.

:joy: touch some grass my guy

When I try to downgrade from f12 to f9 on a z390 aorus pro, I get a message about error because secureflash is on, and that in 5 seconds there will be a reboot … Then a countdown of 5 seconds passes and nothing happens, the command line restarts. Only mod 0.87 works for me, other versions give a file error. But still no results.

@zoomcool7 Yes this is a deliberate decision by Gigabyte to stop you from downgrading to previous BIOS due to “major vulnerabilities concerns”.

The F12 update for the Z390 AORUS PRO says:

Introduce capsule BIOS support starting this version.

Customers will NOT be able to reverse to previous BIOS version due to major vulnerabilities concerns.

I have posted a guide on how to get around this limitation here.

Please read the entire guide carefully as you can overwrite/erase your Intel ethernet MAC address!

1 Like

Thank you so much!
However, this did not solve my micro freeze problem =( *

im on the latest capsule bios F12 on my z390 aorus pro and i’m trying to flash a modded version of F12 that has the fastest microcodes, so far i’ve tried many modded efiflash files from here but none seem to work, i still get the invalid bios image erorr. so i’m guessing FPT is kind of last resort for me atm.

noob question: the bios i’m trying to flash is named 2.F12 (F12 being the actual extension of the file) will this be a problem? or i need a bios file that has the .bin extension?

@selfcontained The filename and extension do not matter, you can call the BIOS whatever you want and FTP will flash the file to your board.

@chinobino ok thank you, does it matter if im already on latest official F12 and trying to go on a modded F12? any risks?

or should i just rollback to an official older bios (F9) and upgrade to F12 from there. sorry but its my first time ever attempting something like this

@selfcontained It does not matter what is currently on the EEPROM it will be completely overwritten.

I am running a modified F10 (capsule BIOS) on my Z390 UD and a modified F12 (capsule BIOS) on my Z390 Pro WIFI that I flashed with FPT.

1 Like

@chinobino thanks so much for all your help, it finally worked. first had to install intel ME drivers for my mobo to work, and i after i entered the last command to restart pc stayed back screen with no signal for 3mins until i shut it down forcefully and kinda shit my pants, but when i turned it on again it worked and booted into os with the new bios :smiley:

once again thank you sir for this bypass to get rid of capsule bios

1 Like

@chinobino Thank you very much, followed your instructions carefully and managed to downgrade my Z390 GX GIGABYTE from bio f10 (2021) to bios that worked stable for me f10c (2019).
I have Intel Gigabit Ethernet Adapter so i used command -savemac. Also my bios file have extension xx.10c so i usde insetad of .bin, -f biosname.10c.
Worked like charm spend more than 12 hours to find solution, did it in 3 minutes with ftp 12.0 and your isntructions.

1 Like

@selfcontained @mixeray You’re both very welcome :slight_smile:

Hey, i have 2 computers runing a motherboard from PCWARE (Gigabyte based mobo), their model are APM-A320G, i needed the F55 bios to run Ryzen 5 4500 in them, but PCWARE couldn’t provide them the day i was building those 2 machines, so i downloaded the F55 bios from gigabyte for the mobo A320M-S2H and forced flash using the modded efiflash 0.87 i found in this forum, modded by Dsanke’s, that made the two machines works properly with the new ryzen, everything was okay, but the VGA vídeo out isn’t working, so PCWARE sent me their new F55 bios for this particular mobo APM-A320G, i tried to flash them, using the same efiflash 0.87 modded, but i got this error message: “BIOS is protected by SecureFlash” “System must restart to complete BIOS update process”, i restart the machine, tried to flash many more times and always got the same error. i’ve read something about capsule bios but i haven’t uderstand it, i have an SPI programmer that i will use as last resort, but i wanted to flash them in DOS as i did before, have any clues in how to resolve this? tried to turn secure boot off, CSM off, TPM off, etc but haven’t worked… Pleaaaaaase help :slight_smile: @chinobino

@Natalinus007 [Edit] FPT will not work with an AMD chipset - my apologies.

1 Like

@chinobino is possible to use FPT 12 to flash an AMD BIOS? (Gigabyte in this case) i’ve think that FPT would only work to intel based motherboards.

Of course not, FPT is an Intel tool platform.

EDIT: Good question… besides the modified/patched Gigabyte EFI flash tool.

@MeatWar yeah, i’ve think that too, how can i do that in an AMD platform?

Intel are now killing off any kind of legacy booting, therefore 11th gen upwards breaks legacy booting completely, there will be no legacy BIOS compatible motherboards or graphics cards from any manufacturer, this means FREEDOS or Any other type of Dos WILL NOT work, in turn forcing people to flash modified uefi’s from within windows (at an extremely high risk)

The pc will still boot to setup using CSM (cant see the point in this) however Dos based flashing tools of any sort will never work, the original IBM compatible Bios as we know it has gone forever. Next manufacturers will encode UEFI files with encryption/high level protection in the end making it impossible to do, and will only be possible via windows update.

Intel and AMD made it pointless to overclock, now theyre going to make it impossible to flash custom firmwares, i am beginning to realise that owning a modern PC is going to be a very boring experience in the near future. And then theres the fact that windows10 and 11 are both completely crap (which all modern pc’s are stuck with) until these companies start to cummunicate more with the end users and give them what they want, the humble PC will end up being killed off.

Apple have now made laptops that are on par/faster than desktop systems fitted with RTX 3080’s which means the tables are going to turn around big time, making apple the new mainstream number 1

Im getting sick and tired of all the antics computer companies are coming up with now, theyre on a mission to lock down computers so much until in the end it will be pointless for enthusiasts to even own one. im to the point now that i would rather use an old 2015 macbook air, especially with great emulators like OpenEMU (which is better than anything on windows)

My next computer purchase will be a desktop Mac Pro, then i wont have to deal with all these stupid problems, you think macOS is locked down? yea well ive never had any virus of any kind on any of my macs, plus the OS itself is 10x better than anything microsoft have ever made. Windows has more bugs than those found in Madonnas knickers.

Yes my friends, the modern PC as we know it has turned to shit.

Its a scientific fact, if you introduce something slowly enough you can get away with anything.

No one knows how to force flash AMD-RYZEN gigabyte motherboard? mine says “BIOS is protected by SecureFlash” and i can’t flash it… FPT is for intel, i need an RYZEN compatible flasher… pls help :frowning: