Flashing modded Rampage V BIOS

Hi All,

Just to let you know, I removed the header from the 4.5 RST ffs I had, and then replaced the body with UEFItool. RST EFI now showing in the BIOS and all working fine. Thanks for the help Fernando.

Also, until UBU can modify Aptio V, I think it would be helpful to have a clean version of future EFI modules available with the others.

Such “pure” Intel EFI RaidDriver variants without header are already available >here<. I will offer such modules for all new versions.

Thanks for your interesting report.
Questions:
1. Do you really run your X99 system in LEGACY mode, which uses the Option ROM instead of the EFI modules?
2. What sort of problems did you get with the v14.0 RAID modules?
3. Have you tried the LEGACY and the EFI RAID modules v14.0? If yes, has there been a difference?
I ask this, because I got severe freezing problems with my Z97 RAID0 system after having flashed a BIOS containing the Intel EFI RaidDriver v14.0.0.2234.



Hi Fernando,

So to answer your questions…

1) I’ve tried both. I installed Windows 7 in UEFI on GPT disk, but I really really hate the Windows bootloader - it sinks it’s claws into every Windows installation it can find on all available disks. This leads to problems in more advanced hard drive / boot scenarios. I don’t like having a ‘ssytem’ partition in front of my Windows partition either. I always pre-create my partition via Paragon Hard Disk Manager Pro so that all the boot files are loaded onto the Windows partition. I want ALL my individual partitions to have mutually exclusive booting schemes. For this reason, I switched back to Legacy mode. I did however try UEFI & Legacy modes with the v14.0 OROM on the Maximus VI Extreme, and I had the same problem I described earlier (which I will repeat below in answer to one of your other questions).

2) "Well I had the same problems some others in the forums sparatically posted after injecting those modules into the Rampage V Extreme BIOS. When I flash those modules and I go into the BIOS, none of my SSDs are listed in the PCH section of the BIOS. If you then enable RAID and save changes and exit, when you get the the point when the Intel Option ROM SHOULD post, it doesn’t…it just keeps rebooting and rebooting when it gets to this stage."

3) Yes I tried both Legacy & UEFI with no difference.

Funny you should talk about “freezing”. I’ve had EXACTLY the same problem with the latest Intel Rapid Storage Technology drivers in conjuction with the updated v14.0 and v14.5 option ROMS. The v14.0 is what I tested on the Maximus VI Extreme…after a few minutes in Windows, the system just freezes. I did however notice I was getting freezing problems as well after doing some Windows updates. Did MS release something buggy to frustrate the hell out of people just in time for Windows 10? O_o This happend less frequently on the Rampage V Extreme with the v14.5 OROM and current drivers, but it still happened and I don’t want to run my system like this. For this reason, I backflashed to v13.5 OROM to the Rampage V Extreme, and am running the v13.6 RST drivers in Windows now…havn’t had any freezing issues since. At least it’s nice to know that I’m not the only one that was having freezing issues with the v14.xx OROM/Drivers… O_o

1st timer here, glad to see a flashback file ready to go for my current 1502 Bios, I think I know the answer to this question but best to ask!

If I have flashed the modded 1502 Bios will I lose the updated 14.5 rom if I flash to the new 1602 Bios?

Thanks.

@ GoNz0:
Welcome at Win-RAID Forum!

The answer is: Yes!
When you flash a new BIOS, you will get the BIOS modules, which are part of the new BIOS. All previously used ROM and EFI modules will be overwritten resp. replaced.
So if you had previously used a modded BIOS with updated Intel RAID ROM and/or EFI RaidDriver modules and you want to use them further on, you have to modify the new BIOS the same way as you did it with the old one.

Regards
Dieter (alias Fernando)