Flashing modded Rampage V BIOS

Hi,

I’ve used UEFITool to replace the SataDriver EFI with the 14.5 version (replace body) and saved it as .CAP
Problem is using USB flashback, it flashes 2/3 times then stops.
Any ideas?

Thanks

Have you checked the result by extracting the uncompressed EFI SataDriver module and opening it with an Hex Editor?

Are you familiar with the USB Flashback method? Does it work with the original (untouched) BIOS?

Hi Fernando,

Tried with the original and failed also. Used a different USB stick and it worked.
I got the FFS from station-drivers. Checked with HxD and the headers are different.

Original is :
EB A4 3B 79 E9 A6 26 45 99 6D 79 39 3F 51 B4 43 01 AA 07 00 40 39 03 F8 16 00 00 13 02 80 47 E2 AE 11 45 23 4F A0 28 EB 82 04 D4 82 9C 08 FD FD E4 38 03 10 4D 5A

14.5 FFS is :
C1 D9 B4 91 1C 14 24 48 8D 02 3C 29 8E 36 EB 3F C5 AA 07 00 A0 34 03 F8 16 00 00 13 02 7C 75 D5 99 06 D9 E0 11 8D 78 8D E4 48 24 01 9B 08 FD FD 44 34 03 10 4D 5A

Can you advise what I need to do to get this working. With CSM disabled the EFI RAID option is not there when using the new RaidDriver

Thanks

@ jezj:
The GUID (first hex codes) of the updated EFI SataDriver should be exactly the same as the GUID of the module, which is within the original BIOS.

If your mainboard has an AMI Aptio V UEFI BIOS, you should have a look into my guide, which you can find within the Chapter B of the start post of >this< thread.

Here you go - make sure you are in the right USB port as per instructions in my post: Asus Rampage V Extreme BIOS 1502 w/ Injected Intel RAID Option ROM 14.5.0.2241

Note that the two other v14.0 Intel RAID Option ROMS listed in the forum stickys are NO GOOD and should be removed from the site. ONLY the v14.5 Option ROM is clean.

By the way, if you already have a certain BIOS version flashed on the board and you try to flash the same version
even thought you have modded it, it won`t re flash it because the same BIOS version is already installed.
You must re flash to an older BIOS version first then flash it.

That might be the issue you’re having.

@ voodoo:
Welcome at Win-RAID Forum and thanks for your contribution!

What do you mean with "NO GOOD"?
Which problem did you get and what lets you think, that they are not "clean"?

Hi Fernando,

First off thanks for such a fantasitc website… :slight_smile:

Well I had the same problems some others in the forums sparatically posted after injecting those modules into the Rampage V Extreme BIOS. When I flash those modules and I go into the BIOS, none of my SSDs are listed in the PCH section of the BIOS. If you then enable RAID and save changes and exit, when you get the the point when the Intel Option ROM SHOULD post, it doesn’t…it just keeps rebooting and rebooting when it gets to this stage.

Note that I had the same problem with the v14.0 ROM files from station-drivers.com with the Rampage V Extreme. However, the same file from station-drivers DID work fine with my Maximus VI Extreme where all I had to replace was the CSMCORE file - the files on this site likely would have worked as well. That said, so far, the only one that successfully worked with the Rampage V Extreme was the v14.5 when one follows the intructions on the page of this thread: Rampage V modding bios

So since they appear to work fine when replacing just CSMCORE on older BIOS’, maybe ‘unclean’ is not the right word…perhaps just not fully prepped to work with boards like the Rampage V Extreme… -v

Not on Asus boards…it will overwrite. The problem he is describing is exactly what happens when you try to initiatie USB Flashback from the wrong port. Counter-intuatively, and inconsisent with other boards of theirs, the USB Flashback USB port is the LOWER one on the PS2 Mouse/KB hub NOT the top one like on all the recent Maximus boards… -v

Thanks for your reply, which verifies, that the Intel RAID ROM modules v14.0, which are offered here, may not work with an ASUS Rampage V Extreme, but are not faulty.
Note:
Contrary to the EFI RaidDriver modules, which may have a different GUID (=start hex code of the header), there only exist 1 single “clean” Intel RAID ROM module for each version and exactly this one I am offering within the start post of >this< thread.
Maybe there is another module within the Rampage V Extreme BIOS, which does not properly work with all inserted Intel RAID ROM versions.

The issue is the EFI RaidDriver modules offered on here contains sections as well which means in their current form are not compatible with the Aptio V BIOS modding
with the current compatible tools that are available. When modding the Aptio V BIOS we need clean EFI RaidDriver modules which does not contain any sections.
Member SoniX knows more about this and explained it to me.

The OROM modules offered here are ok but the EFI RaidDriver modules are not compatible with the Aptio V BIOS in their current form shared here.

I hope now this explains it all.

@ sinders:

When you write "Apollo V", do you mean "Aptio V"?

Sorry, yes I meant Aptio V. Typo corrected. Thanks for the heads up.

The best way to get clean EFI RaidDriver modules for the Aptio V BIOS which do not contain any sections is to use the latest UBU Tool version on a compatible BIOS to
upgrade the EFI RaidDriver to the version of the EFI RaidDriver you require then load up that BIOS in UEFITool and search the GUID where the EFI RaidDriver is located
in the BIOS then extract the EFI RaidDriver module only without the sections. Once you’ve found the location where the EFI RaidDriver is located, you extract the EFI
RaidDriver module from the PE32 image section only by right-clicking on the PE32 image and then select Extract as body to get a clean EFI RaidDriver module.
Then the EFI RaidDriver module should work on the Aptio V BIOS.

It would be great if the clean EFI RaidDriver modules were offered here as well for motherboards with a Aptio V BIOS since the EFI RaidDriver
modules currently shared here are ok in their current form with older BIOS but not compatible in their current form with the Aptio V BIOS.

It seems, that you mean “header”, when you write “section” and “without header”, when you write “clean”.
If this should be correct, the procedure to get a “clean” Intel EFI RaidDriver, is much easier than you have written.

Here is the way:

  1. Open the desired Intel RaidDriver module version (whatever GUID it has) as uncompressed file (ca. 200 KB size) and open it with an Hex Editor.
    Example: When you have opened the Intel EFI RaidDriver v14.0.0.2234 GUID 91B4D9C1, you see this:

    EFI-RaidDriver-Header_present.png


    Note: The blue marked first part is the header of the RaidDriver module, here starting with C1 D9 B4 91 (which means GUID 91B4D9C1) and ending before the hex code 4D 5A. The "body" of the modules starts with the code 4D 5A (= text code MZ).

  2. 
    
  3. Mark the module header as shown above, right click onto it, choose the option "Cut" and click "OK" regarding the changed file size.
    Now you will see the "clean" body of the Intel EFI RaidDriver module:

    EFI-RaidDriver-Header_removed.png

  4. 
    
  5. Save the product of your operation (module without header) somewhere and give it a meaningful name like "Intel-RaidDriver_v14002234_body.ffs".

That is all!

[quote="sinders, post:15, topic:30987"] It would be great if the clean EFI RaidDriver modules were offered here as well for motherboards with a Aptio V BIOS since the EFI RaidDriver
modules currently shared here are ok in their current form with older BIOS but not compatible in their current form with the Aptio V BIOS. [/quote] It would be not a big problem for me to add a "body version" of the latest Intel EFI RaidDriver modules.
Is it that, what you and other users with an AMI Aptio V BIOS mainboard want?

Yes that is correct the way you described it. That’s the way to get the current EFI RaidDriver modules shared here in their current form compatible with the Aptio V BIOS
or using the method I mentioned which is a bit more work involved to get the clean EFI RaidDriver module. It would be nice if you did start to include the “body version”
of the latest Intel EFI RaidDriver modules and mentioning it on the page that these EFI RaidDriver modules are for use with the Aptio V BIOS.


Intel EFI “SataDriver”/“GopDriver” BIOS Modules (21)


Note that the v14.5 ROM module offered here DOES work perfectly with the Rampage V Extreme though, just not the v14.0 modules. I have posted the R5E.cap BIOS file with the injected v14.5 ROM module in it’s own separate thread so people don’t have to go to the trouble of modding themselves and can flash it direct… -v

Thanks for your interesting report.
Questions:
1. Do you really run your X99 system in LEGACY mode, which uses the Option ROM instead of the EFI modules?
2. What sort of problems did you get with the v14.0 RAID modules?
3. Have you tried the LEGACY and the EFI RAID modules v14.0? If yes, has there been a difference?
I ask this, because I got severe freezing problems with my Z97 RAID0 system after having flashed a BIOS containing the Intel EFI RaidDriver v14.0.0.2234.