Flashing modified ASUS P9X79 DELUXE Bios V4801

Dear fellows!

After trying more than 12 hours until early in the morning, I was not able to flash a modified BIOS back into a ASUS P9X79 board.
Since I got Samsung 750 pro drives, I wanted to use the hardware encryption by using a ATA security hdd password on my P9X79 board.
Well , nice idea, but difficult to realize… :wink:
First I wrote ASUS, but they don’t support the ATA security feature on desktop boards and have no interest in supporting it in the future…
So I went on and tried to include the ATA Security eXtension BIOS from http://www.fitzenreiter.de/ata/ata_eng.htm into the BIOS by myself.
After config the bios with BROMCFG as an PCI extension for the realtec card with the correct vendor id, I used Aptio UEFI MMTool v4.50.0.23 to include the extension into my bios file.

Now the problems start: how to get the modified bios back to the ASUS board?

After reading many threads and posts about flashing ASUS bios, nothing worked for my P9X79 BIOS version 4801:
- The original EZ flash 2 tool says: security verification failed,
- the hardware bios flash button with the white usb connector doesn’t start to flash with the new bios as P9X79D.ROM (the original bios 4801 flashes…),
- all linux (flashrom) and DOS utilities (AMIBIOS AFUDOS and APTIO AFUDOS, BUPDATER, FTK) didn’t work, either ROM got corrupted (flashrom) or program refused to burn modified bios (checksum incorrect, wrong size of bios)…
- also tried to modify bios with UBU_v1_43, FD44 editor,…

Does any fellow here know, how to flash a modified bios back into a P9X79 deluxe board?

Here my system data:
- P9X79 DELUXE board, BIOS version 4801
- SAMSUNG 850 PRO SSD

Last note: it is even not possible to flash an older original version of the bios back to the board, EZ flash says : Image outdated, for example version 3501.


Any help is appreciated,
cheers,

ATILIUS

@ ATILIUS:
Welcome at Win-RAID Forum!

Provided, that you have properly inserted a matching and checksum-8 corrected variant of the "ATA Security eXtension" BIOS module, you can find the solution for your problem within the start post of [url=http://www.win-raid.com/t455f16-Guide-How-to-flash-a-modded-ASUS-or-ASRock-AMI-UEFI-BIOS.html}>this<[/url}] thread.

Happy New Year!
Dieter (alias Fernando)

Dear Fernando!

Happy new year and thanks for the quick response.
As mentioned, I tried the solutions mentioned on your post before: Neither the USB flashback method nor AFUDOS (I tried several versions) worked.
It is even not posible to flash an original bios with an older version (3x, 2x or 1X) back to the board.

Cheers,

ATILIUS

AFAIK you have to rename the modded BIOS to P9X79D.CAP instead of P9X79D.ROM.

Hello ATILIUS, you wouldn’t want to ignore the checksum warnings as incorrect checksums can result in a nice brick. The only way to revive a bricked motherboard would be to use a SPI programmer.



Yes, you are right, Sorry, I was trying the whole night several hundred times with different parameters and programs to flash the BIOS, and - as far as I remember - I used P9X79D.CAP too.



Yes, there is a risk.

One time, flashing of the BIOS resulted in a messed up BIOS on board and the board didn’t boot anymore. This was with linux and flashrom. This made my scared, but then I put the original 4801 BIOS as P9X79D.CAP on a 32 FAT formated USB stick and used the USB flashback button, which worked with the original BIOS.

Anyways, I still don’t want to give up, as we just got new year;-) and I will give it a few more tries…

Can anyone help me please with the checksum-8 corrected variant of the “ATA Security eXtension” BIOS module?
What do I need to do after using BROMCFG.EXE ?

Also I would like to know, if loading the original P9X79-DELUXE-ASUS-4801.CAP as an image into Aptio UEFI MMTool v4.50.0.23 and replacing the one line of CMSCORE (VOL 2, Index 4B) with the correct link present and saving the image as P9X79.bin is enough in order to burn this file into the board, i.e. if some more steps are needed after saving the image, as some checksum corrections or so…

Maybe I can help you, if you attach the original and the modded file as .ZIP or .RAR archive.

If a similar module is already within the original BIOS, you may try to replace it by using the AMI Aptio UEFI MMTool v4.50.0.23. If the tool should successfully replace the module (without giving a warnig message), you can nearly be sure, that the tool has been able to correct the checksum-8 of the module. After having stored the modded BIOS, I recommend to extract the freshly inserted module as uncompressed file and compare its checksum-8 value with the source file.

As I already have written, you have
1. to use the ASUS USB Flashback method to get the modded BIOS properly flashed and
2. to rename the BIOS file to P9X79D.CAP, before you are going to flash it.


Thanks, enclosed is the zip file (both modules have a length of only 6KB :slight_smile: ).


Also I will export the module uncompressed and will compare the checksum-8 value with the source file as you suggested, as soon as I have the correct "ATA Security eXtension" BIOS module to include.

Also I will try the ASUS USB Flashback method with the correct filename (even though I tried it before, but maybe some checksums or something else was wrong).

Thanks for your attention, I appreciate it.

ATASX.zip (7.54 KB)

Oh, before I finish the BIOS, one more question:

Currently I am using the ATA Security eXtension BIOS from http://www.fitzenreiter.de/ata/ata_eng.htm .
This version usus the IDE interface for the disk access.
Does anyone know, if there is another ATA Security module, which uses the AHCI mode?

The checksum-8 values seem to be fine (both files have a checksum-8 of "00").

I cannot answer this question.

Finally it works!!! and I am happy. :slight_smile:

Here are my exact steps:
1. Got the ATASX BIOS from http://www.fitzenreiter.de/ata/ata_eng.htm.
2. Changed ATASX ROM with BROMCFG.EXE to PCI extension with vendor id for realtec
3. With Aptio UEFI MMTool v4.50.0.23 I loaded original BIOS V4801 and replaced CMSCORE (VOL 2, Index 4B) with the moded ATASX ROM.
4. Saved file with “Save image as” with file type “capsule file” as P9X79D.CAP.
5. Used USB stick, FAT32 formatted, deleted all files, copied P9X79D.CAP (with CAPITAL letters) to USB stick.
6. Used the ASUS USB Flashback method with the white USB port and the switch beside the port.
7. After flashing, set disk access to IDE and enable realtec rom option.

If someone else is looking for the CAP-file, I enclose the final file here.

Thanks again for your attention, because I almost gave up and finally made it.

P9X79D.zip (4.77 MB)

@ ATILIUS:
Thanks for your final report. It is fine, that you succeeded!

Just to prevent any misunderstandings: Users with an ASUS P9X79 Deluxe (like you) have to rename the BIOS file to P9X79D.CAP.



Sorry, you are right, I changed the post accordingly.

Hi, does anyone know how I can flash a P9X79PRO with a modded 4801 bios? I would like to boot from a NVME drive and have inserted the 3 NVME modules into the stock 4801 bios, but cannot seem to find a way to flash the modded bios. I have tried AFUDOS, AFUWIN, EZ Flash and also BIOS Flashback. Does BIOS Flashback also do a security check? There seems to be different opinions on this. On my board, when I try, the button stays solid blue and the modded bios is not flashed. Thank you! Hammer

@Hammer :
Welcome at Win-RAID Forum!

Yes, but it nevertheless allows to flash a modded BIOS.

Then you have done something wrong. You have to follow the ASUS Flashack rules (put the FAT32 formatted USB 2.0 Flash drive into the special Flashback USB port of your mainboard and rename the modded BIOS to the special ASUS Flashback name.

Regards
Dieter (alias Fernando)

Hi, I have a P9X79 PRO board and an experiencing the same issue…flashback does not work and I get a solid blue light. Can someone tell me what the .CAP file should be named? I have tried P9X79PRO.CAP and X79P.CAP.

Thank you.

name look good but may be stick is too big :
http://www.tomshardware.co.uk/answers/id…ios-button.html

try to use a 4 Go or less , with formatting it fat16

Thanks. I tried again with a brand new stick and was able to load the modded bios. Unfortunately, the modded bios with the NVMe modules inserted still does not allow me to boot from the Samsung 950 PRO Nvme card…but I’ll start a new thread on that. Thanks again!

Hi All,

I just wanted to thank Fernando and all the contributors to this thread for the valuable info on BIOS modding and how to install 970 Evo sticks.

I’ve just built a stonking system from Ebay parts and am very happy. At the moment I’m putting it through it’s paces with Sandra benchmarking.

Cheers All, Dekker.