Hello there!

It’s the first time i actually ask something, but im reading this forum since i started working with computers, so
first of all i want to say thanks for helping out the people out there.

My english skills aren’t as good as they used to be, so please forgive me on that.

Now lets talk about the problem im facing.

Ive got an MSI MPG Z390 GAMING PRO CARBON from a friend who said, that after he updated the BIOS to the latest version the motherboard wont star’t anymore,
or starts for one second or less after holding the power button for exacly 20 seconds.

So i took the motherboard and wanted to try to repair it, actually just for my personal education.

I tried out every reset on the motherboard, but still no success, so i thought i should just flash the
BIOS-Chip and it should do the trick.

I ordered the CH341A Programmer with the SOIC-8 test-clip and got the software for windows (im still working with windows 7).

So i was trying to locate the BIOS-Chip but that was kind of tricky, because i was looking for an MX or WINBOND chip, MSI told me
that the BIOS-Chip is located on the left side below the battery, but that chip has no manufacturer written on it, but i tried out.

It was kind of hard to put the clip right on the chip i tried many times, before i could read out something in the software.

But somehow the Chip isn’t recognized correctly by the software, i could read out something of the chip but in my opinion it didnt looked like a BIOS
file, im a programmerer so i understand a bit of what it should look like, i also compared it with a bios file.

My first thought was that it has to be the wrong chip then i looked for another one and found an WINBOND chip above JCOM1 but i cannot reach that one with the clip, i have to desolder
that one to read it.

A guy from the MSI-Support told me that he doesnt know if its an WINBOND or MX chip, he just reads them out, lol.

Now i dont really know what i should do, i thought maybe i didnt set up the programmer correctly, i checked for the first pin to match the cable and socket, but one thing
i didnt really know was in which socket should i put the cable-usb-thing, i placed it in 25XX because i thought it should be newer i didnt tested it with the other socket yet.

Should i try it with flashrom, since the software doesn’t seem really good for windows.

Im actually having plenty of fun doing this kind of stuff, so it would be amazing if
get some help or directions here :slight_smile:

Thanks in advance!

The Chip MSI told me i should flash is not the correct one, the one above JCOM1 is the right one, it’s an WINBOND chip.
I had to desolder the chip, because the clip couldn’t fit because of the PCIE-Slot, but i lifted some contact pads,
i used a heatgun but actually for the first time, so it was obvious its not gonna be easy.

Anyways i was able to read out the chip and also to verfiy, that the bios was corrupted, i saved the corrupted bios and flashed
a new BIOS on the chip, everything went smooth.

Well i dont know if im able to restore the contact pads, i think i should at least try, but anyways i had a little of success
and that is what this was all about.

If anyone has an idea oder instructions on how i can restore the pads, i would appreciate that.