FPTW64 Error 204: Data verify mismatch found. on Haswell mobile MB

Guys please help me, I can not flash bios region on my motherboard (Asus N56JR). The permissions in the Flash Descriptor is FF, in ME BIOS Flash Capable is true. In the BIOS settings - BIOS Lock is false. Tried using HDA_SDO - same error. I need to flash BIOS frequently, need to do some tweaking. After error 204 i need to flash the original dump, otherwise the laptop becomes a brick, i have to flash via programmer. Tried via DOS - it didn’t turn out. The most fun that ME Region the Descriptor Region, the PDR Region flashing successfully. What the hell? I’ve been digging around for a week, I can’t figure out what’s going on. It never happened on ivy bridge. Went through a bunch of ME regions, from 9.0 to 10.5. No result. Help me please :slight_smile:

Boot guard is NO_FVME

You can’t use ME 9.0-10.5, and that is unrelated to your issue, so not sure what you are doing there. Put ME FW back to what was originally in there, and then update it to the proper allowed compatible ME FW per that ME FW within the update rules.

I have seen this issue a few times, sometimes due to FPT version (ie don’t use x64, or try in DOS instead - “didn’t turn out” tells me nothing), and sometimes it’s something to do with the BIOS chip itself (ie replace chip, issue fixed)
It could also be badly modified BIOS

You mentioned a lot of unrelated stuff, so I’m not sure what all you’ve done to your BIOS already, or what your end goal is, or if any of that is compounding the issue. I assume you want to be able to use FPT without getting error 204, I get that.
Edit your original unedited programmer dump, unlock FD for all BIOS regions and then program it back in, then with FPT Dump BIOS region and try to program it back, what error do you then get when you try to flash BIOS region via FPT?
If error 280 or 368, then disable BIOS lock and SMM/SMI Lock, then try BIOS region flash again, what error do you get now? If error 204, then issue may be one of the 3-4 things I mentioned above.

You can rule out FPT version thing I mentioned if at this point, you can then flash back your unedited BIOS region with FPT without issue. If this is the case, it may be the chip itself, some byte is locked/bad and not allowing an edit.
To see if you can fix that, since you have programmer, you can try >> FPTw.exe -bios -rewrite -f biosregion.bin
^^ That will erase BIOS region before writing it, if you try this and you can only write back in with FPT your original BIOS dumped region and boot (ie others can be written in, but fail to boot)
then it’s probably faulty BIOS chip and that one byte is still stuck, only matches with stock BIOS contents and all else fails due to it’s location.

I do know your pain here, I’ve tried to help a few people who’ve ran into this, it’s a major pain in the rear! CPU type or ME FW have nothing to do with this

I tried to replace flash chip - nothing. BIOS is not corrupted me, I just unblocked the chipset tab and added OptionRom for GP107 in CSMCore. If i flash this BIOS via programmer, everything works. I began to swap different ME Regions after failure. And 9.5 works, even his version in BIOS is displayed if BIOS is factory clean, and unlocked, stil not. AfuDos flashes successfully, but for me it complicates everything. I need to use Fptw. Fptw is not working in dos too. May be this is some kind of ASUS protection?

There is no try, only do. So what happened, did you replace the chip or not? Your second sentence is not constructed properly and I cannot understand what you mean there. And you said “Works” then not works in same sentence, so I’m very lost on what you are trying to explain.

I agree, I dislike AFU too, and suggest no one ever use it unless it’s the only and dead last option. you have a programmer, so AFU should never be used.

FPT works in DOS even if ME is corrupted, the only reason it wouldn’t work is if you are not using the correct version for your ME FW. What error do you get in DOS with FPT?
No, there is no Asus anti-FPT protection Maybe you are doing the mod incorrectly? Give me your working FPT Dump, that you can FPT back and it allows it and boots properly etc.
Then tell me what updates/edits you did exactly and I will do my way, then you test my file.
However, I do expect the same outcome/error, I hate this 204 error!

There is no working FPT Dump, because any edited dump cant be flashed. But it can be flashed by AfuDos, and after that, if i will try flash it again in fptw it will show fpt operation passed (because there’s nothing to change) Fptw is changing data in Bios Region, but to a certain address it not. My changes have nothing to do with it. AfuWin hangs my system, on another system (ivy bridge) too, so this is not my problem too. Only AfuDos can flash, but it is too poor, and booting DOS takes some time, and I need to test the graphics card in real time, without reboots. I already did this on ivy bridge N56VJ, and here on haswell N56JR this damn fptw does not work :))) Here is my current bios: https://yadi.sk/d/VAQp02jF774HXw. Perhaps you can see something there and still help me, thanks :))))
There is: Unlocked Chipset tab, Updated ME to 9.1, in flash image tool Boot Guard is set to NO_FVME, Intel Anti-theft disabled, Bios Reflash Capable is set to true, added nvidia gp107 oprom (Because fucking NVIDIA came up with a new CERTIFICATE 2.0, and now I can not flash a new modified video BIOS by nvflash, and hack it too, and cant flash it in linux). All these is works - Chipset tab is enabled, ME shows correct version in bios setup, oprom is loading to GPU

P. S. In fptw DOS error 204 too. I have tested all versions on this forum
And fpt can dump my bios without any errors. And flash ME, Descriptor, Pdr. But not Bios Region

Your FPT dump after a stock BIOS flash, that is bootable, is a working FPT Dump. If you can and do flash with AFU, which I suggest not using, but it’s working for you, why do you care which way you flash?
FPT does not change anything, it only flashed what you give it. however, if you give it some AFU dump, or edited AFU or other dump, that will always fail, because FPT flashes the BIOS region differently than AFU dumps or flashes the BIOS region.
And same in reverse, if you give AFU a FPT dump to flash, then an entire NVRAM volume will be lost, due to FPT dump only contains one NVRAM volume.

I wanted your original FPT dump, before you modified anything. IS this what the above BIOS is? Sounds like a mod BIOS, which is OK, I will check it. But I want your original FPT Dump if you have it

Boot guard setting doesn’t matter to any of this, why do you mention that? Please show me a MEInfo report, I need to see the bottom of the report only >> MEInfoWin.exe -verbose

Yes, error 204 sucks! This we know This is sometimes caused by AFU flashing, especially if using /GAN, and you mentioned using AFU in general, so it could be the main culprit.
Do you have any super old backups of this systems BIOS, before you flashed any BIOS in any way? AFU backup would be fine for this, but it needs to be from before you did any AFU Flashes aside from if stock BIOS package has you flash via it’s own AFU method.

When you do flash with AFU, what commands are you using?

Also, please link me to Asus website page where you download this BIOS, I can only find N56JRH 204 BIOS when I download from the following page

Ahh! I see, 206 is hidden and 204 shown as latest BIOS, maybe there is a reason for this!

* Edit - your mod BIOS has added padding file above second microcode volume, stock does not. First NVRAM volume is missing entirely, this may be due to how it was dumped, or current BIOS contents are blank there, due to how it was flashed previously.
These two things = messed up BIOS to me, it may not be fixable to where you can FPT properly unless you have some unedited programmer dump of this system, even someone elses would work.
What will not work is a fake dump, from a BIOS recovery or BIOS dump site, those are almost always not actual dumps, but stock BIOS repackaged as a dump, to get peoples systems running again.
To get an actual proper dump you need to find somewhere someone personally posted a programmer dump from this system asking for help. Then, with that, w ecan rebuild both your NVRAM volumes, put back in your board specific details, correct the volume that now has added padding file in it, and probably then FPT flash without issue.

Oh, this is interesting. I bought this motherboard as a part, and it was have engineering bios. I have it, but its clean too. 204 is N56JRH, i have N56JR - 206. N56JR - LVDS, N56JRH - DP. I did everything exactly the same on ivy brigde, everything worked well. It seems this one has nvram, but i dont know where it is located https://yadi.sk/d/RP-QCgz5H4wMpQ. Why i need to use fptw: i can change nvidia oprom on a working system - reflash bios, send reset to pci-e or put system to sleep and GPU will be reinitialized. With my new timings, settings etc. Native graphics card is 760m, i installed 1050ti, it shows code 43. I don’t know the new generation of graphics cards yet, so I can’t find the bug right now. 960M is works fine. Commands for AFU - AFUDos bios.rom. Firmware updating succeeds. Here is my MEInfo report: https://yadi.sk/i/6jm_r1YFonnphA :slight_smile: It is not working with full stock bios too. https://yadi.sk/i/qqYbomSa4feKPQ
Maybe this? -verbose option

P.S. I didnt use AFU before this error, i tried it some days ago, because im tired with fptw)

So… Can you help me?

Some ES systems can ONLY use the ES BIOS that was originally on them. I’m not sure what you mean by “Clean too” This has nothing to do with CPU model, or type, please stop mentioning this it’s confusing to read and it’s confusing you.

All BIOS have NVRAM. So, now that you have mentioned ES, please upload for me the original dumped BIOS from this system, before you did ANYTHING to the BIOS. If you do not have this, you may not be able to fix in any way further than you have possibility to do already.

760M original, replaced with 1050ti is huge difference! You would need GOP and vBIOS within the BIOS changed out to a GOP/vBIOS from a same Asus system with this model, or you cannot use that card.
Other vBIOS from other systems that did come with 1050ti will not work as they wouldn’t be configured for this exact models layout and configuration. I highly suggest you remove this card and put back in the original, I doubt you’ll find a BIOS for this system that contains a vBIOS for that card, since they are so far apart I doubt they ever shipped with those.
Unless, retail shipped with that and only your ES has the 760M, then something might be able to be worked out, if the board between ES and retail didn’t change too much. You can’t simply find some random vBIOS and insert it

With AFU Flash, at minimum you should be using >> AFU filename.bin /P /B /N /K

Once you used AFU, the problem is compounded now (ie additional issue you cannot remove now, without flash programming in your original ES BIOS that was dumped with flash programmer)

I’m betting the main issue here is the vBIOS is missing, plus you now have messed up NVRAM from AFU Flashing.
That, and ME FW version needs to be the same Major ME FW version that this originally came to you with (ie if 8.5 was there, 8.x is all you can use, if 9.0 was there, possibly 9.1 but even that is not ideal, if came with 9.5 then last 9.5 is all you can use etc)
Additionally, you need to transfer settings from the original ME FW to the new ME FW before flashing it, if you already do that with the guide, good.

Do you have the original dumped BIOS from this system, untouched by you? Hopefully made with a flash programmer, if not FPT will have to do.
If yes, put in your original graphics card, and FPT flash back in that original BIOS

I cannot see any of your images above, that site is terrible to download from, if you want me to see images either put them in a zip and upload to another free file host, put them on an actual image hosting side instead, or use full/advanced reply here and attach them to your post.

Don’t worry about 1050 ti, VBIOS for it is compiled personally by me, with my memory, GPIO, DCB and so on. I disabled DCB, changed Class code to 0302 (3d device), deleted all Display Scripts, reduced frequency (vBIOS is from the desktop video card), disabled the GC6, memory voltage adjust (fixed to 1.55 v). Logic power is down to 1.8 v (the new generation of graphics cards only works on this voltage). Naturally I recalculated all checksums, changed offsets in places where it was necessary to add the new code. Summary: mats sees the video card, check all 4GB of video memory with result PASS, but in windows error code 43, as somewhere in the BIOS there is an error. I know where, maybe DCB, because the new version is now 4.1. On maxwell gpu it was 4.0. But I need experiments, that random figure out the problem. The original DCB I can not use, because my Board does not have any output ports from the board, and the class code 0302 does not support the presence of any powered display port. It’s also possible that now it is necessary to sign the BIOS, I couldn’t find any information whether it is possible at 10x to edit something, but in spite of this, people can mine on this cards. So, apparently, i can edit it without signing :slight_smile: it May be that PMU just does not run the firmware, as there is no certificate

My questions now: I sent the BIOS 204, it might have all the nvram partitions, since there are serial numbers, i can enable uefi, there is a key for Windows 10, and i can enable secureboot. Can you check pls? Or tell me what and where to look so I don’t ask every time)
I tranfered settings from my original ME firmware - its OK. On my system, as it turned out, working all the ME firmware from 9.0 to 10.5. On all of these firmwares can I change the contents of the flash via fptw, well, except for those specific addresses. I found out that only these 428kb Bios Region Are not programmed. Starting adress: 0x200000, leinght 6B000 in Bios Region. ALWAYS. https://drive.google.com/file/d/1Ia-zyD1…iew?usp=sharing What is it? I dont know, maybe you know) All other parts of the bios region can be flashed properly. If i use -erase command, those 428kb will not be deleted. Whaaat is it)))
204 bios https://drive.google.com/file/d/1VCkhYxn…iew?usp=sharing


What you mention about vBIOS has nothing to do with what I mentioned in regards to using that vBIOS, everything I mentioned still applies and is 100% valid. This all ever more of an issue since you are using desktop vBIOS and then wondering why you have graphics card issues.
These vBIOS are edited with system specific settings sometimes, like enable HDMI or Disable VGA on this plane, etc, much like you can do with Intel vBIOS, that usually display is ran out of before it hits your screen anyway.
In the end, the intel vBIOS may be the only thing you need to adjust if anything isn’t working correctly, and luckily we can heavily edit and changes 100’s of settings in the Intel vBIOS.
Sounds like you know a lot more about this than I do though!

On NVRAM, there is usually two volumes, this you can only see with a programmer dump, software will usually only dump one. Stock BIOS usually only contains one, with standard stock stuff, which is 95% less than what an actual dumped BIOS would contain for that same NVRAM volume.
Current contents are left in tact during BIOS update and only if changes in the stock region would that be reupdated with the source data.

ME - good you are transferring settings, but generally with ME FW major version changes, many other BIOS modules also need updated, so what you are doing may seem like it works, may work in some ways and not others, or may be OK until you tried to use something ME FW specific.
I know very little about ME FW, but based on plutomaniac’s warnings on the ME FW clean and update guide, and the ME FW update download threads, this sounds like something that isn’t good for the system.
I do know what I mentioned about the other BIOS module changes are required from Ivy/SB ME issues and other similar, we can’t just upgrade ME Major version, due to the other BIOS modules need edited as well, so based on my experience there and plutomaniacs info in the guides and download threads, that is why i say all this.

Sounds like you need to unlock your FD if you cannot write to some region with FPT. Or, as I mentioned, your chip is bad at that spot, and needs replaced.
What you uploaded that is 428KB is not what is at the BIOS at offset 200000. That file is part of a the microcode volume (end of this) and the entire S3 Restore compressed BIOS module located near end of BIOS starting at 457FF8h (This is where the microcode volume starts), last microcode in part + next BIOS module (compressed) is what you’ve uploaded
End of that last microcode (7E 7A 0A 99 0A 15 26 50 E6 E8 9A A8 4B 63 9D 46)is at 468800h, this is near end of your file, following that is a compressed BIOS module S3 Restore.
FPT can and should write this entire area, it’s all in BIOS region (-bios) You can try -rewrite before your -bios flag and try to rewrite the entire BIOS region, but if it fails and can’t erase that bad part of the chip then be ready for programmer recover on reboot
To me, what I see, those 428KB as not erasable to you means bad BIOS chip, there is nothing that should or would stop FPT from being able to erase or simply write over this area (unless you couldn’t write the BIOS region in general due to BIOS or SMI/SMM lock but you already can so this is not issue, and those would stop any write at all anyway)

I’m not sure what you are showing that image in regards to? That simply means you either do not have ME drivers installed, are using the wrong ME System tools version, or ME FW is corrupted.
Try whatever you’re trying to do there in DOS instead, this will rule out a driver issue, then you are left with wrong version or corrupted FW in some way.

It is good that you recalled at the expense of intel vbios, I forgot about it. Last time I changed the gt 635m for GeForce gtx 950m, chip gm107. Ivy bridge processor. vBios is also desktop. Everything works well there, with my changes of course. They were much more global. I had to completely change the system power management in vbios, because the NVDD PWM controller had a very different control method. But never mind. You say you can modify Intel Vbios as I please. Can you tell me how to do it? Maybe there’s a guide somewhere. I have already seen something like this, the program was official from intel, but there is nothing useful at the expense of discrete graphics I found. Can you give me a link? P.S. As I said earlier, the problem in the faulty flash is excluded, since I installed this spi flash on ivy bridge, and there it is succefulu flashed in any region. Thank you for explaining the unprogrammed section. I have no idea how you know this:), so this information is very useful to me.

On error 204, I see here user was able to get around it using DOS FPT, did you try that yet?
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash (6)

Yes, you can use Intel BMP tool to modify internal vBIOS from the main BIOS, here is guide for updating in general, but once you get there you’ll have the tool with all the options via GUI interface
[Guide] Transfer of specific Intel VBIOS settings by using Intels BMP tool

This has nothing to do with PCI/PCIE graphics cards vBIOS, only onboard/internal GPU’s and output from those ports, which 99.8% of laptops all display output is rendered out through this so it all passes through these settings/vBIOS
[Guide] Transfer of specific Intel VBIOS settings by using Intels BMP tool

I meant a faulty BIOS chip itself, not the flash or image etc. maybe we mean same thing, again your mention of CPU only confuses me on this because CPU type is not related to BIOS flashing success or failure
Unless possibly some CPU is faulty in some strange way, causing a funky issue like this? I guess anything is possible, we’re talking computers and problems at same time here

If you want me to show you where that bit of data is located in a few BIOS tools and how I see it, let me know and I will put together some images for you. Mainly hex and UEFITool

Yeah, I mean flash is a Bios Spi chip, in my native language it is same words) I tried to solder it to ivy bridge mb - flashed sucessful. I don’t think that I need to edit Intel vbios, 760m uses optimus such as 1050ti. It is controlled by nvidia driver , not Intel vbios. Dos fpt throws error too, same 428kb

I cant understand,why afudos can flash it properly? Whyyyyyy…

By the way, about Nvidia GOP. It seems that in laptops it does not exist, because vBIOS is common, shortened. There is no pointer to the second part with GOP. Maybe it is somewhere in another section, but UEFI Tool can’t find it. 950M works fine with enabled UEFI, but there is no GOP too. what is it :slight_smile:

OK, I see what you mean now, on the IVY board, did you erase the chip and reflash the chip in full? Did you test in DOS, as I mentioned, it may be a windows issue like other user found I linked above. I guess yes, you did!
See, I told you this error sucks! What it’s always said to me, every time I’ve seen it, is bad chip at whatever address it’s failing to write, but that doesn’t explain how it works in DOS for that one user, but failed in windows. I’ve tried to help a few people though this issue too, never the same address, never the same fix, always the same pain though

AFUDOS is probably not flashing this area, AFU doesn’t flash a lot of the BIOS areas, nor erase them.

All laptops, final display output goes through Intel vBIOS and out to the display ports, panels, etc. This is why in 99% of systems you cannot disable the internal graphics or you get black screen.

If you have a dump of your nvidia vBIOS, I may be able to put GOP/EFI module in there if you wanted? Yes, it’s true, even for desktop cards, many do not have GOP/EFI modules
If you do send me this, are you taking it directly from the card with programmer? If not, please do, if you can, if not, tell me how you dump it. UEFITool has nothing to do with this, GPU-z or programmer would be only way to dump, edit, see the NVIDIA vBIOS.

If your 950M works fine in Secure Boot, UEFI Mode, with CSM 100% disabled so it’s actually secure boot mode, then it’s vBIOS contains a UEFI GOP module.
GOP is UEFI “orom” for lack of a better term. vBIOS for graphics cards can have legacy vBIOS only (orom), or GOP UEFI/EFI module, or both.
Motherboard BIOS contains either/both of this for the internal CPU graphics, sometimes there may be copy of PCI/PCIE external graphics vBIOS but not always.
Your stock BIOS has a copy for GK106/760GM, yes, legacy only, no GOP here but it could be added on this since it’s in BIOS and size would not be an issue, unsure if that would get copied to or used by your card though, doubtful
Normally oncard vBIOS would be used, that’s why I asked you for the direct card dump above.

I can add a GOP, I know how to do it. PCIR need to add 1 bit (a flag that the GOP’s present), and just add it at the bottom. I’ve been doing this with my 950m. In laptops, the graphics card does not have its own BIOS chip, the video BIOS is loaded from the main BIOS as an option Rom. I do not know exactly, using smBus or via pci-e, but it happens this way. Basic settings are still stored in legacy vBios, such as timings, GPIO settings, voltage settings, init scripts, Display output settings and so on. Honestly, I have no idea what the GOP is doing. I soldered the BIOS chip to the graphics card with wires, loaded the full BIOS with GOP. But there are no visible changes, only vBios is read earlier, and the card is initialized before main POST. There are 3 types of laptops: the integrated graphics is disabled, the display port is output from the discrete, and the display is connected to it. These cards often has a Bios chip, but on my second laptop with 1080M there is no :slight_smile: The second type: Optimus. integrated graphics is main on the motherboard. Its the one displaying the image. A discrete graphics card is used as a 3d device. Class code 0302. This is similar to mining video cards, it do not have ports for display output, but can perform calculations. This decision is made by NVIDIA Driver. Any, even desktop graphics card can be used as a 3d device. There’s nothing to do with Intel Vbios. But there is 1 thing, which from him depends. This subsystem id. Onboard graphics card assigns its own subsys, if discrete does not have its own bios chip. And the third: integrated graphics have same output as discrete graphics. Motherboard decide, which card will work now and switches output to chosen card. It can be detected by blinking display.

On account of ivy mb - Yes, I completely rewired the bios chip. Uploaded there its native firmware, then took changed firmware for 950M, there is changed the module setup, updated the microcode and so on. It loads successfully, with and without -rewrite option. Even my random file, which is not even firmware, loads without problems. However, then the computer becomes a brick :slight_smile: - its normal. Noticed another thing: on ivy bridge during firmware, keyboard, touchpad, all usb ports is not working. This does not happen on haswell. Maybe that’s the reason? Should it work?))) Specifically changed these 428kb on haswell and flashed via AfuDos. Firmware successful. I feel bad already, what the hell ?)))

P.S. I love when the graphics card firmware is on a separate bios chip. This allows you to flash even faster, therefore the debugging process is also faster. But 10xx graphics card and gtx 965, 970 and 980 have a 2.0 bios certificate, and nvflash refuses to flash the edited vbioses. Bypassed version does not work too. I tried to hack myself, but nothing good came of it, as the PMU inside the graphics card checks firmware, known as the Falcon Microprocessor. There’s nothing to be done, because if bypass firmware check in nvflash, it will be checked second time in gpu, and will be aborted. On the website of NVIDIA, I was told that the PMU can be switched to non-secure mode. Same as boot guard. But they did not say how to do it :slight_smile: And do not say anything more :DDDD I learned how to cert my bios by myself, by using a trick with nvidia display script updater. But its too hard and slow.

I want to repair it faster, because i want to make a new motherboard for rtx, to update the processor to last generation. But I can’t because fucking intel and nvidia are making shit up again) All cadence programs is horrible with integrated gpu. It’s time, apparently, to move to AMD: D

Many laptops do have vBIOS on the card, you’ll have to look if you want to be 100% sure. You can try updated GOP in the BIOS then and see if it allows Secure Boot mode to function with whatever card/GOP combo. GOP is for UEFI / Secure Boot mode, legacy orom part is for CSM or non-UEFI booting
Yes, display output is decided by the BIOS, and what traces and laid out for each output, and then finally what is and isn’t allowed by the vBIOS from CPU source.
That is the main output source for most laptops, if you edit the BIOS and disable this, or try to enable switchable graphics and disable the CPU graphics then 99% of laptops fail to display, since final graphic output is ran through this controller.
I make mod BIOS all the time for people, unlocking all the hidden settings, and almost always, without fail, if I forgot to remind people not to try that then there very next post is “I bricked my BIOS / My Screen is blank/black”
Of course BIOS is not bricked, just display output is now disabled since they tried to disable this as main and enable their other as main instead (only few laptops can do this, as you know)

FPT does not erase entire chip or region either, even with re-write, often one NVRAM volume will be left in place and not erased or written no matter what you tell it to do.
Flash programmer is really only way to make sure all is erased. But, in this case, your problem bytes are not in an area that FPT wouldn’t erase if using re-write, so that may indeed prove your chip is OK

Your question about KB, touchpad etc, all is about drivers, and how the BIOS is configured to use those items, and drivers.
Some of that may be in ME FW settings, which even if you transfer from SB ME FW to updated Ivy version, all that I mentioned before applies here, you don’t know what would be applied by manufacture for the major ME FW version change, so you can’t apply those unknowns
And the other BIOS modules that would also get updated for that Major ME version change also do not get updated, so all and or any of this could be the reason you are having those issues.

There is a modified flasher out there for those 2.0 nvidia BIOS, or you could always use flash programmer instead I believe. Or this the one you meant didn’t help? I see people using it all the time with mod vBIOS

Nvidia is the issue yes, I use Intel and AMD graphics always, never any issues

I met error 204 on colorful P67 mobo.
And I tried to flash it by afudos,it prompted 12-error ------NO non-critical blocks found in ROM file.Finally I add /gan order,it could be flashed but it’s unuseful after I reset the machine.

AFU flash (previously) is the only thing I’ve found to cause this. So now you can only flash with AFU, unless you find stock non-AFU Flashed BIOS dump, edit in your info, program in it, then you can use FPT.
/GAN is made for BIOS long before P67 BIOS series, not suggested to use even on boards this old either. So I expect bricks anytime AFU ES that allows /GAN is used on large majority of Aptio IV BIOS (even more so on Aptio V)

You should have flashed it with proper AFU for that BIOS series, not used /GAN and /K or Kxx where xx is a number is how you program in non-critical blocks.
If those left out, or forced in when not there originally = brick, same as using AFU ES (made for BIOS8) on many Aptio IV/V

I suggest you find dump BIOS, edit in your serial, UUID, LAN MAC ID, program it in and hope that it’s never been flashed with AFU before, then if not you can use FPT.
If you get error 204 again, try same with some other dump, until you find one that has not been flashed with AFU.