Fujitsu Primergy RX300 S7 D2939-A17 Microcode update

I have some RX300 S7 systems equipped with E5-26XX CPU. Few days ago has seen RX300 S8 server and found that mainboards are absolutely identical on all elements, chipset and just have D2939-B17 revision, and working ok with E5-26xx V2 CPU. I have a CH341A SPI EEPROM programmer, also has 8 and 16 pin clips and some experience with modifying and reflashing BIOS. Want to try enable support on BIOS level for v2 CPU series, cause as i can see it can be supported by hardware. May be some can help me to found a way for update microcode section in BIOS, or have working S8 dump? On Fujitsu website exists BIOS both for S7 an S* systems in 2 different formats , but as i can understand it cannot be flashed directly to board without modifications and have some check of board revision. Thank you in advance for any ideas or help.

I have same issue: does anybody have solved from February on? Thanks also from my side

Hi, You don’t need the RX300S8 Bios to use E5-26XX V2 on RX300S7 boards !!

Fujitsu PRIMERGY RX300 S7
D2939-A1x bios v4.6.5.3 - R1.32.0 (24/06/2019)
which cpu you want to add exactly?
Intel Xeon E5-2600 v2 microprocessor family

Untitled.jpg

I think i need 306E4 CPUID support. I see most of E5-26xxv2 family using that CPUID number. I have now for testing E5-2620 V2 CPU.



Yes i know that i need just add some microcode support to BIOS. I was tried , but with no luck still.

microcode updates with extra 306E4 D2939-A1
if it does not work as you claim,may need vbios update and maybe more

[GUIDE] Fixing HT for Coffee Lake CPUs on Skylake and Kaby Lake motherboards (Z170, Z270)
[GUIDE] Coffee Lake CPUs on Skylake and Kaby Lake motherboards



Hi, I’ve come across this thread - are there any other changes in that BIOS or is it just the microcode added? I’m a bit reluctant to flash it, I don’t want to brick my motherboard; but if it’s just microcode, the worst thing could happen is that v2 won’t boot but v1 will do still, is that right?

Hello everyone. Have any progress?


Link is dead. Can you upload this file again?

Me too, would you be so kind to upload the BIOS with V2 support once again ? Does it work ?

Hey, any new solutions here?

Trying the same but with no luck to get it work.

This is the updated bios from the original bios update DOS folder, dont ask how to flash or the successful way to flash, as always the risk of using mod bios files IS user own risk, specially on OEM brand bios files the risk
of fail operation is even higher. Ensure that u know the risks envolve, OEM recovery methods…if available and the knowledge of a system recover by CH341 programmer.
Do please report back the operation for future users guidance.

Source V4.6.5.3 - R1.32.0 (24/06/2019)

EDIT: Seems that a simple mcode update by UBU/MMTool its ineffective (28-06-2021).

Thank you,

i managed to edit my original bios file for myself but the flash process aborts and the system goes for a reboot.

Trying to flash with Freedos.

I will report back when i get a Successfull flash process.

An FPT dump/edit/flash operation is also a good option on an Intel system.
Of course, it needs access/unlock to bios/fd/me regions for successful operations.

bios.JPG



its now written to BIOS but it still doesnt boot )=.

@kimmelbaer
My provided file or ur moded file? Normal flash or FPT tool?
I need to know in order to decide leaving link or remove it.

my modded file with normal flash.

I will try out your file in a sec, you can remove it i got the file already.

Thank you very much

Now i just got a blackscreen and after 10 secs booting the server immediately turns off.

Got it back to work but the Screen still remains black, i think i just brick the Bios ;D

Anyways i got some of thoose boards and i really want to know if its possible to get thoose Microcodes of the V2 series working.