G7-2043SF brick / doens't want to turn on after flash

The HP PC I own no longer starts after an official update …
The board is DA0R33MB6D0 REV : D
I launched the installation by Windows and I now find myself with a black screen, orange WiFi led and that’s it. I tried to unplug the battery, do the key combination etc, nothing helps.
I have a CH341A programmer but I don’t know how to get a clean file.
Can you help me please?
Thank you in advance !

PS : Here is a link with my dump file from actual state : https://www.dropbox.com/s/60cxaqpfl9j9jc9/DumpHP3.rar?dl=0
and the link of the original firmware that i try to flash : https://ftp.hp.com/pub/softpaq/sp77501-78000/sp77532.exe

Definitely not a valid backup! What chip is this? And try to read it until you get at least two a 100% identical reads which give a structur in UEFIToolNE!

Definitely not a valid backup! What chip is this? And try to read it until you get at least two a 100% identical reads which give a structur in UEFIToolNE!

It’s the dump from my Bios chip for sure… I do it 6 times and i unplug the CH340A, do all again and i have allways the same result. All my files are similars.
If you see the dump is not a valid backup, that can explain why the laptop doesn’t turn on anymore :confused:
What can i do now please ?
Thank you

If the programmer does read the chip properly they’re not similar, they’re identical bit for bit. And if you can’t read a chip properly, you can’t write it properly…

This dump looks very much like a bad sitting soic-clip or an incompatible program. And never seen a bricked update process looking like this dump does.

Which chip, which software?

I don’t understand. My programmer read the chip properly, it detect the MX25L6406 if my memory is good (the laptop is at work) and i can read it many times i want without any error.
I use the original software (CH341A programmer) and a version from this website : https://khandishnetwork.com/dl/ch341a-ne…ted-15-10-2021/

Results are similar and if i compare files on an hexeditor software, all are strictly identicals.

Well, the chip you mention has 64Mbit, 8MByte, but your dump has more than 8.8 MB. In addition the size of a complete bios image I can extract from the update file you linked as appropiate for you machine is 4MB (32Mbit) which is quite normal for such a notebook.

- You got the wrong chip?

- You didn’t read it properly- how were you able to read 8.8 MB from a 8 MB chip?

(The data in the dump do look far too structured to be corrupt, it’s only hex- values with ‘.’ and ‘:’ as dividing signs?)

I’m not sure about the chipset reference. I don’t have the board with me. I can add valids informations tomorrow at work.
Can you help me to create a valid dump please ?
Thank you.


So i try to dump 2 more times my Bios chipset and the result is similar ! I use 3 differents software to be sure of them and all are similar.
Here is my latest dump : https://www.dropbox.com/s/oilaxo37utm37et/DumpNew1.rar?dl=0

The chipset is : MX25L3206E. It seems to be a 4Mb no ?
Can you help me ?
Thank you very much.

Fun fact : the Fan started every time i plug the CH341A. I don’t know if it’s normal but it’s the first time i see that.

Congratulations, you got a bios dump!

Left side stock bios, right side bricked dump- search the difference…


HP fix gives you possibility to extract, run InsydeFlash=> copy file. You find a 5120 kB file, which has ‘something’ first 1.2 MB, 4 last MB look like a stock bios.

Try attached file, unpack, flash it, read the chip again in new process, save in different file. Original file and dump have to be a 100% identical!

(File is stock bios from update with own data transfered, empty/clean NVRAM. it normally should work.)

0183cut_short_own.zip (2.7 MB)


Thank you so much. I’ll try to flash it today and see if the laptop want to turn on. I hope all will be ok. I’ll come back with the result today.
Thank you again !


Sorry for being late, I got sick and couldn’t take care of the PC.

The bios seems to be ok, thank you very much but I still have a problem with the image:

I have a screen with a simple backlight only. I tested by connecting an external screen and there, I have the HP image with access to Bios.
So I changed the connection cable between the screen and the motherboard but still the same.

What do you think ?

Thank you very much again.

UPDATE : I reassembled the hard drive in order to start under Windows from the external screen and I just noticed that once the BIOS POST is passed, the PC screen displays the desktop!

Basically, the HP logo, the Bios etc. is no longer visible but Windows then starts normally on the screen.
I admit not understanding how is this possible … Thank you again.


That’s quite normal, windows has direct hardware access, it’s not dependant on bios support for video output.

Bios video support for UEFI: DXE driver and GOP VBT for settings
Bios video support for legacy boot: video orom

So try to boot in the ‘other’ mode, see if this is going to work, or of both UEFI and legacy have the same problem. Basically the configuration stored in the orom and/or in the GPT seems not to be compatible with your LCD.

BIOS Platform - InsydeH2O

[EFI Drivers - Find and Extract]
Intel GOP GUID FF0C8745-3270-4439-B74F-3E45F8C77064
Intel GOP GUID F706D0C8-F6FC-4F7A-AC98-96BA5CC43AAA
Intel GOP VBT GUID 878AC2CC-5343-46F2-B563-51F89DAF56BA
Intel GOP VBT GUID 58C207D6-A0E2-4655-81A7-22C3B49FF4FA

[OROM - Find and Extract]
VBIOS in GUID 2F68BB71-F949-407A-BE3B-BE49AC07C131
VBIOS in GUID 926B366B-741C-45E9-A99C-BFC2737E1A52
VBIOS in GUID 8DFAE5D4-B50E-4C10-96E6-F2C266CACBB6
VBIOS in GUID 5264D44A-7C8C-4289-BB5D-D1B5CE4257B2

Main Menu
[Current version in BIOS file]
1 - Disk Controller
2 - Video OnBoard
EFI GOP Driver SandyBridge - 2.0.1019
EFI GOP Driver IvyBridge - 3.0.1016
3 - Network
4 - Other SATA Controller
5 - CPU MicroCode
0 - Exit
RS - Re-Scanning
Look into this thread, there you get an explanation for the settings:
[Guide] Transfer of specific Intel OROM VBIOS and GOP VBT settings by using Intel BMP tool