GA-X79-UD5 & Intel C600: Poor performance with HDD, good with SDD. Any ideas?

I’m dealing with a weird problem regarding the performance of my mechanical hard drives in my main computer, a custom built PC running Windows 8.1 Pro de 64bit (Gigabyte GA-X79-UD5 motherboard with the latest F13W BIOS, Intel Core-i7 Sandy Bridge-E processor @3.6GHz, 16GB RAM) with three mechanical hard drives and two ssd drives.

After running some Crystal Diskmark Benchs, the symptoms are clear: the mechanical drives are running at almost half the speed of the manufacturer specs, while the SSD are running nearly around them. These are the results:

The motherboard features two storage controllers, and as you can see in this AIDA64 capture, the five hard drives are connected to the same Intel C600 controller, part of the Intel X79 chipset. The second controller is a Marvell 91xx in which I’ve plugged two optical devices. There’s also a virtual controller run by VirtualCloneDrive.

I’ve been checked the Intel RST driver version downloaded from the Gigabyte support website, and I’ve also tried version downloaded from this forum. I can’t install the latest version 13.x drivers because the installer says the platform isn’t supported.

I’ve also tried uninstalling Intel RST driver and letting the Microsoft driver take control, but the results are the same.

Yo can check the hard drives datasheets here

I’m quite sure that a Windows 8.1 fresh install will resolve the issue, but I’m really happy with my setup and I want to avoid reinstalling. Maybe you can help me identifying and resolving the problem.

Thanks in advance

Welcome at Win-RAID Forum!

This is what I recommend to do:
1. Read the start post of >this< thread and follow the advices, which are valid for HDDs.
2. If this shouldn’t help, run the Diagnostic Tool, which has been delivered by the related HDD manufacturer.
3. If the HDDs should be fine and the available AHCI optimizations done, but the HDD performance hasn’t increased, you may try to change the SATA ports and AHCI driver.

By the way: Since your problem may not be Intel driver related, I propose to move your thread into >this< Sub-Forum.


My rig is x79-chipset too - ASUS P9X79. It has only two SATA3 ports and four SATA2 ports via Intels controller (other ports are ASMedia controllers ones). My two HDDs are connected to SATA3 ports and have high scores in CrystalDiskMark. OS is Win8.1 64bit. But drivers are RSTe 4.1. But earlier on Win7 I tried RST drivers and the performance was the same (normal).

Have you connected the drives properly?

Your motherboard has 6 SATA 3 (6Gb/s) ports, two from the Intel controller (SATA3 0 & SATA3 1) and 4 from the Marvel one (GSATA3 6 - GSATA3 9).

Your motherboard has 4 SATA 2 (3Gb/s) ports, all part of the Intel controller (SATA2 2 - SATA2 5).

Make sure all SATA 3 devices (830, ST2000DL003, WD30EFRX) are at 6Gb/s slots starting from Intel and then going to Marvel. Meaning, populate both Intel 6Gb/s slots and 1 from Marvel.

Also, try removing some drives to see if the HDD numbers change. For example leave only one 6GB/s HDD at the Intel controller for testing and try again.