Getting Windows 7 installer to boot on Tiger Lake laptop


I have my laptop, which has an i5 11400H + RTX 3050M combo, and I’d like to get the Windows 7 installer to boot. Not necessarily install, because if I can get modifications done in e.g. the boot.wim, I can modify the install.wim file as well.

My problem is that it’s stuck on “Starting Windows”, without even the animated logo. I’ve tried UefiSeven with no success. However, I’ve managed to get my hands on the bootmgfw.efi file from FlashBoot Pro, and it gets me a bit further! I can actually see the logo animation for a few seconds, but it freezes like mid-way.

I’d assume it’s an ACPI driver problem, however it’s weird that there is no BSOD for that. Perhaps the file from FlashBoot Pro doesn’t allow BSODs to be shown without proper graphics drivers, I’m not sure.

If anyone has potential solutions or help, I’d greatly appreciate it!

It may be, but the fact though you have an Nvidia graphics card suggest this should work with Windows 7. Do you have a Legacy Mode in BIOS (the standard Intel only Tiger Lake’s do not, but ones bundled with Nvidia should)? If so, just use that. I’ve tried to no avail to get Windows 7’s ACPI to work under my Lenovo IdeaPad 3 with Intel Tiger Lake (It’s the only GPU in it).

Nope, it has no CSM/Legacy mode in the firmware.