Gigabyte Alpine Ridge Rev 2.0 NVM firmware?

Does anyone know where I can find an update of the NVM Firmware for Alpine Ridge card?
My card have NVM Firmware: 20
The card use DSL6540 C-step Thunderbolt controller (15D2)

I found everywhere on the internet and could not find any that I can use, the closest one being the Lenovo one but that one is vendor specific so I cannot flash it onto my Gigabyte card.
The reason I am looking for a new firmware will be written below (long text but for anyone is interested or might have other solutions, I will worship you as god. I literally ran out of options.

I have an Alpine Ridge Rev 2.0 add in card using on my Asus Motherboard (Asus Prime X299 Deluxe with latest BIOS: 3006) to replace the Asus ThunderboltEX3 card that came with the motherboard because I need 2 TB3 ports now for a TB3 dock.

I am connecting 2 device to the Alpine Ridge Card.
Port1 : Antelope Audio Orion Studio Rev 2017 Thunderbolt Audio Interface
Port2: Elgato Thunderbolt 3 Pro dock.

Everything been working fine for 1 week(the time I bought the Elgato dock), then yesterday Windows could not detect the TB3 Dock in Port 2. I tried to connect the dock in Port 1 instead and Windows able to recognize the dock but the Audio interface failed to recognize in Port 2.

So I googled A LOT, someone suggest to move the Alpine ridge card to another PCI-E slot ( all my PCI-E x16 slots are able to run x4 or higher, as I have 44 lane CPU). I move the card from slot 4 to slot 3.

It works fine for both port. great! Then today, the thunderbolt dock disappear in Thunderbolt control center again.
I tried to connect the dock to port 1 again. Only this time even port 1 cannot recognize the dock. I moved the alpine card from 4th slot, 3rd slot, 2nd slot and tried all combination of different port. Still in thunderbolt control center, I cannot see the dock.

So I think maybe my dock is dead… As last resort I connect the dock to both of my 16" Macbook Pro and iMac Pro. The dock works fine in both machine.

So I google a little bit more, seems that my Alpine Ridge card have quite old NVM firmware. NVM Firmware: 20

Then I tried to find the newer firmware on the internet but could not find any. I am wondering if Gigabyte have a newer firmware? Maybe the firmware is the culprit.
I ran out of options. Looking for your help. Sorry for the long text.



I have a Gigabyte Alpine Ridge PCIe card (DSL6540) that I updated to firmware 21.00.

[[File:Current Thunderbolt3 Firmware (21).JPG|none|auto]]

The device ID is different to yours though;

DSL6540 Thunderbolt 3 NHI [Alpine Ridge 4C 2015] 1577 PCI\VEN_8086&DEV_1577
DSL6540 Thunderbolt 3 Bridge [Alpine Ridge 4C 2015] 1578 PCI\VEN_8086&DEV_1578

Yours looks to be the newer JHL6540 with power saving features, also found in the 2016 Mac Book Pro.

JHL6540 Thunderbolt 3 NHI (C step) [Alpine Ridge 4C 2016] 15d2 PCI\VEN_8086&DEV_15D2
JHL6540 Thunderbolt 3 Bridge (C step) [Alpine Ridge 4C 2016] 15d3 PCI\VEN_8086&DEV_15D3

Here is the firmware if you want to compare it to what you have;

Current Thunderbolt3 Firmware (21).JPG (138 KB)

Thanks man! I think yours is Rev 1? Mine is Rev 2. Your firmware shown incompatible, probably this is the reason but thank you anyways!

Yes mine is revision 1, it seems there has been no firmware updates for revision 2 unfortunately.

@darkinners - Contact Gigabyte directly and ask for copy of latest FW for this model card, they will probably send to you

@Lost_N_BIOS Thanks I already did. Before I posted here.I am awaiting their feedback .

Hopefully they will send to you! If not, keep asking, use different ways, they have a few forums, and also try direct email etc.