Gigabyte Aorus Elite Z390 Disable HPET


I am looking to deactivate hpet in the bios, but this option is not available, I have a bios already modded (F10h), from another forum, which has the fastest microcodes, since I am looking to optimize the FPS more among other things

I don’t know if anyone can do this please

I have AMIBCP, and I found the option, and in fact the HPET - Disabled is saved, but I am a little scared when arriving and flashing something that does not make me feel sure if the changes were saved well, also I can not find the option of how to do it visible in the bios, since it is in PCH-IO Configuration …

(In the event that the latter is well done, could you guide me last …)

Thank you.


You could refer to this thread.

thanks @genius239 for the link, does the bios have the fastest microcodes?

No ,that mod was made based on gigabyte official bios ,only did menu edit ,no edit microcode.

oh, no problem, is it normal that it takes time to write the bios? it’s quite slow


I don’t have actual experience to flash bios on this motherboard ,i only provide mod to users.

Refer to some feedback from user ,some is write slowly ,but some is normal ,so i guess it caused by different version of cracked Efiflash??


It is quite strange, I am with version 0.87 of efiflash mod, it goes at 13.47% I can not stop it and change to another version of effiflash? the first 10% is fast but the rest is slow, should I use version 0.80?


Yes, it’s very weird.
But you can’t interrupt the flash progress. Although it’s very slowly but i think it still can be finished , please wait a while.

Modified efiflash seems has issues.


just finished, it took 1 hour more or less,
I have a question, I did not find the option to deactivate the onboard graphichs permanently

I mean that before it showed the option of internal graphics, and I could deactivate it, now they tell me 3 new options to allocate memory to the integrated gpu, but when entering windows it does not appear, this is automatic?


What stuffs does not appears in windows?

On this mod i let options “DVMT Pre-Allocated” and “DVMT Total Gfx Mem” to compulsorily appear in menu , on normal they are hidden ,only when you set “Internal Graphics” to enable then they would appear ,but now it didn’t need


is reelevant only if you occupy the integrated card

I found a bug, but I don’t know if it is, when deactivating c-states, it does not take effect, I must put package limit, in c0 / c1 so that it is correctly deactivated *

My other question is, is it very difficult to integrate the latest microcodes to this bios?

thanks for all


You could try to replace microcode via ubu for thyself.
[Tool Guide+News] “UEFI BIOS Updater” (UBU)