Gigabyte Aorus Master Z390 (Bios menus unlocking?)

Hi, is there any way to unlock extra menus on the Z390 bioses? (in this case, Gigabyte Aorus Master).

I was able to dump the “F8b” beta bios with FPTW64 -d biosname.bin -bios successfully but AMIBCP 5.02.0023 returns a lot of ‘undefined’ values for selections (and some other options are in german), and attempting to save anything just crashes AMIBCP.
Is it even possible to unlock menus without doing really confusing things? (I tried reading some UEFItool guides but all that stuff confuses me (except extracting the “setup” module for universal IFR extractor, which I did on laptop MSI bioses).

Sorry for any trouble I’ve caused anyone. Thank you for your help. (5.12 MB)

@Falkentyne - You’ve attached F7b, is this mistype when naming, or is this not your FPT dump and some F7b BIOS or dump?

Oh that’s right. I updated to f8b a few days ago. I’ll attach that later. I forgot that dump was f7b.

Yes, lease latest dump, and then some images of all your currently visible BIOS settings if you really want everything enabled that’s not currently in all current sections/subsections.
You can use F12 hotkey to make a pile of bmp screenshots on a USB Stick, then 7zip those up if you don’t batch convert them all to PNG

Here’s the f8b dump.
Still can’t find SVID enabled/disabled option.
I have no idea how I’m going to explain this to Unclewebb. He thinks svid support is disabled.
But HWinfo64 reads the SVID VRM temp and says (VRM xxx (SVID)).

f8b.rar (4.95 MB)

@Falkentyne - I thought I replied to you about SVID and what I found, did it not get posted, or maybe that was in PM or another thread? That’s why I dislike PM’s. You did read something by me about SVID in reply to what you mentioned vs Asus BIOS correct?
I can’t remember exactly, and I’m not looking in BIOS right now, but I think it was along the lines of SVID has a value added entry (input offset amount) in this BIOS, but no enable/disable, thus always/automatically enabled.
I need to see your BIOS too please, all main sections and scroll down for any that have long list of submenu entries so I can see all visible submenus. And then inside images of your BIOS for any submenus that interest you in AMIBCP that you see missing settings in, for enabling more.

Yes you’re 100% right :slight_smile: I’m just waiting for Unclewebb to reply to my PM on notebookreview because he thinks SVID support isn’t enabled. I referred him to this thread but I don’t know if he’ll see it.

@Falkentyne ,

Any luck unlocking bios menu options on the Auros Master Z390? I was able to successfully change menu option open rights to USER using AMIBCP 5.02.0023 without issue on F8b. I even translated some of those german menu names to english. I haven’t tried flashing it though as not in such a rush…

@davidm71 - use this new AMIBCP 5.02.0031, then you wont have German name gibberish issue anymore
Unlock Aptio V Z170 Board Menu Chipset unhide and other Menu

@Falkentyne - BIOS images please and thanks Can you not see the SVID Offset I mentioned? If not, I’ll be sure to make that visible for you first.
It’s located at >> Advanced Voltage Settings >> CPU Core Voltage Control >> SVID offset (And is Disabled by default!) So Unclewebb is correct, but you can enable it
Sorry I missed that previously, when I first looked at the IFR I didn’t see it correctly I think due to it’s name I assumed it was an “input value” type offset setting, now I looked in AMIBCP and see it’s an enabled/disabled setting

Hi Lost N Bios.
SVID offset has always been there, but when I enable it, I get post code 0F and then I have to clear cmos. I have no idea what its for. Enabling it makes vcore control become grayed out completely. Even DVID is grayed out.

Are these the bios screenshot captures you wanted?

Bios.rar (1.54 MB)

Thanks! So you can see it always, I didn’t know that, I must have misunderstood you if you mentioned that before. This is something I do not use or know about, simply enabling it should be causing you a non-boot state.
Maybe some other setting needs enabled/disable first, or this is BIOS bug. Does that happen same way on other BIOS versions too? I read around about it, and seems it should be disabled (default) if you using manual voltage, only enabled if using adaptive or offset voltages

Thanks for the images, will get on BIOS mod for you tonight

Hi, @Lost_N_BIOS
Did you have any luck with anything with the bios?
I figured you were busy so I wasn’t sure if there was a problem. It’s not that important. I just wish I could do stuff like enable the iGPU without switching the display output to iGPU (I don’t know why it doesn’t enable if you turn it on, unless the dGPU is physically removed).
Wanted to mess with a few things as long as I don’t cause a brick or something.
I’m sure there are other things a bit more dangerous as well. (like changing the wrong value in Overclocking performance menu, etc).

@Falkentyne - sorry about that, yes you are correct, this got lost and buried when I got behind over the holidays! I just now checked your BIOS images above, and those are not BIOS images, that’s AMIBCP images??
I need to see actual BIOS images so I can see what’s visible to you and what is not, use F12 for screenshots to USB, then 7zip because BMP is huge MB’s per image.
I will set Internal graphics to enabled, since I don’t think I can make chipset visible for you. Default is disabled for fail safe, and Auto for optimized, which sounds like disabled unless dGPU is removed from what you mentioned.

Did you know real time BCLK is enabled, changes apply directly in real time with F4 hotkey in the BIOS?

Ok I’ll get this later. I had a very stressful day and am in a very bad state of mind.
I did not want the iGPU permanently enabled. That just causes problems. :frowning:
I just wanted to be able to manually enable it. Not have it enabled by default.
It’s really not a big deal however.
I need to rest right now. I’m sorry.

@Falkentyne - it’s OK, no rush at all, hope you get to feeling better and more calm soon! And sorry, I meant we can disable iGPU if you wanted, from same setting, just got confused when I wrote out the reply I think.
But I guess I may be confused too You want it to auto enable when no GFX card installed, but be auto disabled when GFX Card is installed, is that correct?
If yes, I’m not sure that’s possible, since it should act like that now but is not doing so, unless maybe SG is enabled by auto for primary display (I’ll have to check and see if I can tell what auto uses, nope it’s not defined or obvious what auto sets)
I think setting that to PEG may make this act properly, if SG is being selected by Auto currently. Will be good if I can get chipset visible for you, but initial check into this is making me think it may not be possible. Do you have flash programmer, or does this board have BIOS switches?

I have a Skypro programmer, Pomona 5250 clip and so on, and it has primary and secondary bios dip switches.
To be honest, the only thing I wanted visible was the “System Agent” menu and “Overclocking performance menu” but I think I’ll skip on that right now
I’m in a panic right now and I’m dealing with very serious things and i need to be stable before I risk bricking my board.
And just thinking about modding the bios is driving my “problems” to a point where it’s making mentally unstable. I need to fix a few personal things before I go through with this. I’m sorry.
I’ll take the pictures later, however. But to be honest, the system is working as intended. I’m sorry I caused you and anyone else any problems. Thank you very much for helping people with all the mods.

@Falkentyne - Good, with onboard switches, no matter what then no programmer would need to be used if recovery was ever needed. You can’t brick your board, you have BIOS switches and a programmer, both mean bricks are not possible in your house or with that board etc.

You shouldn’t let modifying BIOS give your mental health stress, I’m doing the modifications, so your mind should be at ease not having to struggle with trying to figure it out yourself
You’re no problem at all, nor is your asking for a mod BIOS, all perfectly fine and you’ve not caused me or anyone else any problems!! ?? Sorry if you thought anything I said meant that, I didn’t intend for anything to sound that way
I’m here to help you get into this whenever you’re ready!