Gigabyte Aorus Z390 Ultra bricked after M.2 SSD insert, corrupted BIOS?

Hello. I have Gigabyte Aorus Z390 Ultra motherboard (full configuration here: link). PC worked for 3 years perfectly.
I’ve just inserted one more SSD Samsung Evo 980 NVMe M.2 1T into M2M slot, since that time my motherboard can’t POST, CPU LED is on, and it’s turning off/on PSU every ~10 sec.
I’ve tried everything found on forums (CMOS clear, etc…). Finally, I’ve read main BIOS with CH341A programmer (cloud drive download)
With UEFItool I noticed, that it is corrupted. Can anyone comment this and advice how to fix this issue?

F9 bios region with intact code volumes but both NVRAM stores have a shot header and are moved?

In addition changes settings regarding RST PCI / PCIe lanes:

These settings are stored in FD, so possibly changed when inserting second NVME.

Gigabyte has complete firmware images, you might try to just transplant the GbE into a stock bios. Or you might try this bios, replaced NVRAM headers from stock, unclear if this will work. (7.0 MB)

Thank you very much for fast reply. I’ve already tried both methods, but will try your created image, maybe I’ve made any mistake. Will report if it helps.

Always nice to get relevant information little by little :roll_eyes:

If you did that already this might not be firmware, but hardware, even if the firmware showed significant errors. But it’s unsure if these errors in both headers of the NVRAM stores weren’t added under your tries.

will see… Unfortunately I’ve burned one more programmer during trying to flash your image (it is third one). Will try when another programmer arrive, supplier says that will be in five days. Thank you very much

So, programmer arrived, I’ve flash your image, the same MB behaviour. Seems it is hardware trouble, I’ll order another MB (so hard to find that model our days)