Gigabyte B85M-D3H strikes back (every 30 minutes)


I am coming here after having found this topic. It seemed I’ve found the exact solution… but as the OP’s case got more and more complicated, so got mine. And since Lost_N_BIOS advised caution and I am not sure the issue was resolved, I decided to start a new topic.

Gigabyte B85M-D3H (1001 revision, the same as OP’s)
Windows 10 64-bit Pro

After cleaning my PC’s interiors yesterday, I started getting “no signal” on my monitor. I checked connectors, switched RAM around etc., but nothing helped, so I followed another piece of advice – I reset the BIOS by removing the battery from the mobo. After that and some more fiddling with cables etc., I got the monitor to show signal again… and the shutdowns after exactly 30 minutes started, be it in Windows or BIOS. I checked the power settings, I checked the temperatures etc., and nothing out of order was found. I assume it might be corrupted IME, and I am not sure what to do after the initial suggestions failed me.

What I did:

-per post #3, I flashed the newest official BIOS F15 using Q-flash and an USB drive (success!)
-per post #3, I downloaded ME System Tools Package V9.1 package from the linked forum thread and tried using it as instructed; first I was unable to use the command prompt with administrative rights in WIN32 folder
-when I used Lost_N_BIOS’s handy shortcut (post #6), it worked at first, but after reaching 100%, it was stopped with the nasty error 7 (screenshot attached to the post)
while at this, I created the FD.bin file (per post #14), uploaded it here:…218859392147987

I have installed INF from here, but when I try to install IMEI, it says that “this platform is not supported” (in case of the one for Windows 10 64-bit) or that the system doesn’t meet system reqs (the older version for Win 8 64-bit and below).

I am not sure how to proceed now. Please, send help! :frowning:


Error 7 often means you need to reboot. So reboot and try that ME FW write again

Tried again after a reboot. Same story. Thanks for coming to the rescue so quickly! :smiley:

Thanks, we may have to wait on pro help from ME Pro Plutomaniac, I have an idea and looked through that other thread, don’t look like we discussed it there. Please wait!

plutomaniac does the old Gigabyte incorrect region offset storage at FD cause error 7 in FPT when trying to write ME region only?
I looked at FD and it looks like this is one of the affected BIOS, but I can’t tell for sure (don’t remember exactly where offset should be in FD, but seems it’s not set since I do not see 500000/0000005 anywhere)

Not sure, I guess it should affect the BIOS region only. You can find the offsets from a picture in the FD thread if I remember properly.

plutomaniac Thanks, yes, I plan to try and hunt down that post, but from what I see in FD I don’t think ME Region offset is defined either, unless I’m just not seeing it.
Of course, I need to find that thread and image, then maybe we can know, or I can fix FD and then try again. Gigabyte leaves all this unlocked, so usually there is not any errors with FPT doing anything, that’s why I assumed maybe it’s this

I had tried to clean or update ME in several 1155 GIGABYTE mobos,and they all works.
Actually you should just update it by Q-flash so that all region could be reflash.

@gloobox - yes, FD is unlocked. I don’t think Qflash writes ME region unless it’s new. Maybe if he downgrades BIOS to much older, AND ME FW then downgrades too, then he could Qflash update ME FW
But I don’t think Qflash can downgrade the ME FW like that (SVN/VCN rules), so FPT may be only way. We’ve been through this before, same board too.
I think the issue is what I mentioned (hopefully), we need to fix FD region offsets, then error 7 will go away, then we can FPT flash ME region.

But, now that you mention, I think EFIFlash will flash it all! Especially if using /X or /Z flag, so that should be tried next before we look into correcting FD
@monkie - Please flash latest BIOS from DOS with EFIFlash >> EFIFlash.exe filename.bin /X
If that does not work, ME error remains N/A or 0.0./0.0, or it gives you error at /Z flag >> EFIFlash filename.bin /Z

YAY, guys! I am cautiously optimistic! I flashed BIOS using DOS with Efiflash as instructed above, with /X added. And it’s now been over 30 minutes since the last shutdown! On top of that, HWiNFO64 is now showing an additional tab on the “left” screen, under Motherboard… and that is Intel ME! It wasn’t there before, I am certain about that – when Lost_N_BIOS (I think) suggested the guy in the other thread to check what’s written in the Intel ME section of HWiNFO64, I just couldn’t find any Intel ME-related sections there. Is there anything else I should check before I can happily start using my PC again…

…and start worrying about less serious things such as the graphics not working properly? :wink:

EDIT: Oh my, oh my, it seems that with that BIOS flashed your way, the graphics problem is gone as well! Some details in case it helps that one other person somewhere: since my discrete VGA (Radeon R9 270) almost died six months ago, I have been using the internal CPU graphics (Intel 4600 off my i5-4440). After the cleaning operation and the CMOS reset on Sunday, it stopped working, too – it disappeared from the Device Manager, I couldn’t install the drivers because of not meeting system reqs, anything. The only workaround I found that allowed me to see anything on the monitor was to pull that almost-dead Radeon from the bottom of my drawer, connect it again and use it with the “basic Windows graphics” driver, without allowing Windows 10 to update the driver. The screen would go black as soon as any “normal” Radeon drivers were installed, either by Windows or by myself, and the Radeon attempted normal operations. Now, with the BIOS flashed with Efiflash, my 4600 internal graphics works again! THANK YOU, guys! Thanks to you, I should be able to wait the pandemic out and buy myself a new PC after the prices drop to acceptable levels again.

I met error 7 on some mobos when flashing with FPT,but it’s OK on AFU.
Thanks for your experience!So that I could flash the full bios with more method.

@monkie - Great to see that worked for you and fixed ME FW! I assumed you had memory (timings/speed) and graphics issues, but just hadn’t mentioned them or noticed yet.
Sometimes fans even run full speed 100% all the time when ME FW is messed up. Great to see EFIFlash was able to finally fix this for you!

I wonder why FPT write and -rewrite doesn’t!! I know FPT write skips one NVRAM volume in BIOS area, but I always though -rewrite erased all first, maybe not.
I guess that doesn’t apply here, since we didn’t use to write BIOS region, but we did write ME FW with FPT and it didn’t write in something that it should have been doing!
I didn’t ask you to do FPT -rewrite for ME region, but I think I did in the other thread you linked and it didn’t help, of course we never got that far due to error 7 stalling FPT progress

@gloobox - Yes, I do not like AFU flashing, due to sometimes it can CAUSE this error and 204 (I think is the one), due to that and sometimes bricking people more often than other things, AFU is dead last on my list of choices or ways to suggest to anyone about flashing a BIOS.
I try to talk everyone into programmer before AFU even! It’s more “OK” for stock BIOS flashing, but even then I try to steer clear of it whenever possible (ie if Intel system, no way, use something other than AFU).

Yes,I dead on AFU several times esp on windows!And sometimes brick my machine!So I use it on DOS!

@gloobox - Unless system is AMD, I use AFU like this >> Put it in a folder, hide deep into your spare HDD, nested way back into some long string of folders, inside folders, inside folders, and then never look at it again
And even when system is AMD, it’s my dead last resort It’s not reliable, as you know it can often brick, and it sometimes causes issues with other flash tools in future flashes.
Everything else, all other options and possibilities, should be considered long before AFU on modern systems (ie systems made in past 10-15 years )