Gigabyte G1 guerilla Proper 3TB+ patch requested

hello. good day. i got a g1 guerilla board here.
and it has big bios bug…
the board received a bios update to support 3tb or larger drives.
well… the problem is. it only works for one 3tb+ connected drive
if i try to boot the system with more than 1 4tb drives connected (2 times 4 tb in my setup)
it wil get stuck on “verifying dmi pool data” (i also disabled the sata 3 controller)

the 3tb bios update does not allow the sata 3 controllert to accept any larger drives whatsoever…

and even with several bios releases after the 3tb patch it never got fixed…

any help would be appreciated…

i even tried a pcie sata controller with no results

the bios is a AWARD bios the motherboard

the bios i’m currently running is F4D. which i updated to multiple version to test if one of it would fix it…

this board has a bios recovery so if it gets bricked. it should not be impossible to fix


also a second bug (idk if it can be fixed)

but my keyboard turns off when in post. or in the boot selection menu.

my gaming keyboard turns off. but my “dumb” hp keyboard stays on.

yes i enabled legacy mouse support ect.

@sebaskitty - First, DO NOT ever rely on “Dual BIOS” to save you, if your BIOS ever bricks you “May” get lucky and it can help, but that is rare and few-far-between.
If you want to be sure you can always recover, order $3 CH341A + $3.50 SOIC8 Test clip with cable, then you can feel safe.

Did you test with both drives in SATA0-1, not 4/5/6 etc. Stick to the Intel controller ports too for your main OS drive.
As for the Marvell, if you ask about this in the Marvell thread, someone might know if a Marvell update or mod has been confirmed for 2TB+ drives for Marvell 9182 roms.

This is something only Gigabyte can address, you’ll have to open a ticket with them. Due to the age of this BIOS, and how they added the 3TB compatibility, it’s probably only possible to use with one drive and they know this and just left it out of the specs.
What you can do to use your other 2nd large drive is cut it into two partitions, then you will have no issues.

Keyboard off when “in POST” do you mean during power up and through POST, but works once in windows? Is this USB or PS/2 keyboard? If PS/2, does it work OK if you use PS/2 to USB adapter.
If you have not tried that, test it, some keyboards work OK like that but some will not, it may help if your will work this way. Some keyboards are just not compatible with the pre-OS drivers, so you can’t use them for BIOS/DOS etc.
Nothing you can do about that except see if you can get it to work via changing the USB settings, if nothing and PS/2 adapter does not work this is also something Gigabyte would have to address (and since board is so old I doubt they will do anything on this issue now)

i’ll give connecting the 2 drives to sata 0 and sata 1 a shot…

right now the nvme boot drive is on sata 0.

i didn’t realy expect to run at this problem…

absolute worst case would e using a 2nd rig and tossing nas software on it.

also i didnt know “splitting” it in partitions would bypass this entire problem


`hmm the drives in
0 and 1 seemed to make no difference…

i wanted to try the split partitions option but apparnatly if you setup the drive as mbr it wont allow me to make the 2nd partition (greyed out)

i thought there used to be a way (or atleast seagate used to have software for that)


NVME boot drive can’t be on SATA0, this is an SATA Port

Use proper partition tool, good free one is EaseUS -
Yes, with 2TB or less partitions then you do not have any “Larger than 2TB issue” I’d split right in half, 1.86GB each
First you need to delete what all you have and make the disk RAW again, the initialized as GPT not MBR, then split.
GPT would be required for 3/4TB drive as a whole too, so if you were trying to use MBR previously this may be your issue there.