Gigabyte GA-MA69vm-S2 Bios F10e - AMD Phenom II X4 955 95w

Hello,

Confirmed the CPU is working and everything else is working, Phenom X4 chip is recognized by BIOS but when attempting to install Windows or Linux get Segmentation Faults and kernel panics. Thinking maybe the BIOS does not actually support the chip and wanting to confirm that it does and if not, then MOD the BIOS to support the chip.

I’ve finally been able to open up the BIOS and get the data from is using cbrom but do not know where to find the Microcode for AMD chips, found plenty for Intel and guides for intel but none for AMD

attached is the latest BIOS, just hoping someone can take a look at it and maybe point me in the right direction to mod this chip so i can use my new CPU

@ Vasator:
Welcome at Win-RAID Forum!

Unfortunately there is no attachment.
Note: You have to compress the file by using WinZip or WinRAR. Files with another extension are not accepted by the Forum software.

Regards
Dieter (alias Fernando)

ah! that’s why it didn’t show up
let me give it another try
okay the original file name was ma69vms2.f10 I just renamed it to MA69VMS2-f10e.zip

MA69VMS2-f10e.zip (512 KB)

You need to change the microcode in NCPUCODE

Table.png



The microcodes content is this:

AMD_CPU.png



Your CPU needs 1043 (100F43) CPUID. There is already one in there, but I have a newer cpu1043_ver010000C8_date#11-03-2010 microcode. The size is the same, so replacing with a hex editor should be easy. The problem is that you need to fix the checksum and it is tricky with CBROM, as your BIOS has MINIT right at the bottom. The second problem is that you need to also replace the AGESA module from 3.3.2.7 to at least 3.7.0.0, if not latest 3.7.1.2, to fully support your CPU. Since the size varies and it is placed above MINIT, you can only use the dummy module method. The AGESA module could be problematic in itself, as it should be loaded as fast as possible, so moving it could get you a brick just like moving MINIT.

Maybe I could make you a modded BIOS, but there is an extremely big chance your board will not boot.

Well if your willing to give it a try i am as well. I have another motherboard that this chip works in but the main difference between the boards is this one has a PCie x4 slot where the other one has three X1 slots. I was thinking of using the X4 slot for a SATA 3 card or SAS card. I’m using this system for virtualization using Proxmox. Right now running an AMD dual core 4000 which runs fine but really want to max this board out in specs. I’ve had it forever and it’s never given me an issue until trying to upgrade. would be cool to get it working with the quad core.

I also found this guide: Gygabyte GA-880GM-UD2H (rev. 1.3) (3) but got lost in the steps and didn’t know where to find another ncpucode fro AMD chips

Maybe I will provide some test files tomorrow, but you are the sole responsible for using them. They could brick your board or help you with the issue. If you accept this condition and you are willing to test no matter what happens to your board, then I will work on them once I have your agreement. Unfortunately your board is not equipped with Dual BIOS and I presume you don’t have a programmer, which would minimise the risk.

yeah I understand the risk. Like I said I have another board similar to this one that I can use if this one dies. This board is kinda useless to me if it won’t accept the chip I wan to put in it. Even though gigabyte states on the website that it is supported and it clearly isn’t

Here are the files. The file MA69VMS2-mod1a.10e has only updated microcodes, it should be safe in theory, but might not solve your issue. File MA69VMS2-mod2b.10e has updated microcodes and AGESA 3.7.1.2, should be considered dangerous. I believe you can use CBROM without the fear of moving MINIT, but I used a dummy.bin just to eliminate this risk. AGESA will be moved no matter what, but if MINIT is safe to move and GV3 is not, then I also added MA69VMS2-mod3c.10e that is similar to mod2b, but AGESA begins at original offset, with the use of an older CBROM. As dangerous as mod2b or even more. Test in this order.

Bellow are the new microcodes. The presence of the 13th microcode was a surprise, it is not part of NCPUCODE, maybe a leftover from older BIOS versions.

CPU.png



What could go wrong in mod2b and mod3c:
- if AGESA is loaded from old offset or this version is not compatible with your CPU, your machine won’t boot with mod2b. If I’m not wrong, this new AGESA should fix bugs and add X6 support, so the compatibility should be present.
- if MINIT is loaded from old offset or AGESA is incompatible, your machine won’t boot with mod3c.
- if both MINIT and AGESA are fixed, you loose either way.

MA69VMS2.10e-mod.rar (1.02 MB)

Thank you!
Will test these and see which ones work and let you know

Well, here are the results

1a seemed to work, could start up proxmox and waited about 15 minutes until a kernel panic; re-installation caused a kernel panic; windows 7 install hung
2b seemed to work as well but same issue as above
3c misreported the memory at 128MB instead of 16GB, and would not boot to the drive

The only thing I find aggravating is that the Gigabyte website states it supports this chip and it doesn’t. was a great attempt though, with 1a and 2b it took a lot longer for the system to go unstable

Thanks for the help but I’ll probably be using the other motherboard.

again Thank you for the help, it is greatly appreciated

You didn’t have to test all of them, 2b and 3c were the same in content, just different position for sensitive modules. But since 1a and 2b didn’t worked, I suppose you had nothing to lose. The report with 3c proves that MINIT was a sensitive modules and CBROM simple cannot be trusted to tamper with it. If 2b didn’t worked despite having updated CPU modules, then the problem could be somewhere else. I see that your BIOS is having and old version of AMD RAID ROM, version 2.5.1540.36, which I suspect is also used for AHCI. I do have an “1002-4380 AMD RAID 3.2.1540.6” module, but don’t know if it is fully compatible, even if it has the same ID.

Have you checked the logs, mainboard components, cables, PSU?

Yeah went through a myriad of testing:

system is now running with an AMD 64 dual core 4000 - works great
Testing:
Took out all PCI cards (Had a gigabit network card and a usb/Firewire card installed) issue persisted
Swapped Video Cards - issue persisted
Took out Video card and used on-board video - issue persisted
swapped memory from other system - issue persisted
Swapped power supplies (one was a 400w, the other 500w) - issue persisted
checked BIOS settings
Turned off cool & quiet - issue persisted
Sata Controller set to IDE - issue persisted
SATA Controller set to AHCI - issue persisted
Tried with three different drives (80GB Fujitsu, 160 WD Caviar, and 250GB WD)

Didn’t really think that any of the components were bad as the system runs perfectly with the dual core processor installed but I figured I would be thorough
I tested the memory on the other system as well, let memtest run for a few days to be sure and nothing found bad there, and the processor works on that one

only thing troubleshooting pointed to was the motherboard.

If the system is running with a different CPU and the problematic CPU works in another mainboard, then mainboard + CPU is the probable issue. What model is the other mainboard, so I can take a look at its BIOS? Have you tested any other Phenom or x4 on the problematic board?

Yeah other mainboard is a GA-MA790X-UD4P

I don’t have any extra AMD CPU’s to test with though

That board is more powerful from the beginning, if you count AM3 support, new chipset, better RAM etc… So the comparison is not possible. But it comes with AGESA 3.7.1.0, it has AHCI 3.0.1540.59 (a cut-down version of RAID ROM), it was full RAID 3.0.1540.59, it is simply more updated.

But have you checked the CPU support list of the lower board? It shows X4 955 only for AM3 and from 10e. If you do have that socket, better check TweakTown for a beta BIOS, maybe they released something else.

UP

I have a x4 945 95w working Since 2015 in This mobo.

I Need voltage support or support for phenom x6 1065t 95w.

Any modded BIOS in order to get this?