gigabyte GA-Z270P-D3 + i9-9900K

hi, im trying to get 9900K working in a gigabyte Z270P-D3 board
i patched BIOS with CoffeeTime0.85a

boots w/ kaby lake OK with patched BIOS, but with 9900K, just bootloops. hear PSU clicking on and off… not sure what’s wrong.
i am writing and reading with SPI programmer
i tried flashing M_BIOS and also B_B.IOS just in case too, but nothing
pins isolated as shown in the image

here is the dump after writing…iew?usp=sharing

also tried different source BIOS, F5, F6, and F8, all don’t work.
would appreciate any help, thank you

@define - Please send me your original untouched BIOS dump of latest BIOS (programmer or FPT) and I will make mod BIOS for you Or, give me your Ethernet MAC ID and I can edit stock BIOS for you instead
Pads look good above You may need to do the connect two pads though, I’m not sure this is already done on all Gigabyte boards internally.

PM sent :slight_smile:

For now, please program in latest stock BIOS using EFIFlash and use command >> Efiflash.exe Z270PD3.F8 /DB
IF that command fails, or you don’t see it updating both BIOS, then program back original Backup chip contents (we never have to touch that with programmer)
You can however update it later via hotkey combo from main, once you have main working how you want

* edit - @define - Here, please test, you can put in new CPU first if you want, should be OK - FYI to anyone using later >> 506E8+506E3 microcode removed…462067764451796

After programming in this BIOS, before starting system if using flash programmer to program in BIOS, remove 24/8 pin PSU Cable from board and press button or short the power on pins for 10-15 seconds, then let system sit for one minute without ANY power (CMOS battery OK)
If flashing in BIOS via FPT, then after FPT Flash (FPTw.exe -f filename.bin) << Change Extension from .F8 to.bin for FPT), additionally enter the following command and be ready for auto-restart, if it does not auto-restart then above power drain method is required >> FPTw.exe -greset
This 1+ minute zero power drain on board resets ME FW state, this is required here since you are downgrading ME FW version, and since we are messing with ME FW in general should always be done anyway

*** WARNING *** - This BIOS is user specific! If you are not user define at forum, DO NOT USE THIS BIOS As-Is!!
If you do, and you are not define, then you will loose your Ethernet LAN MAC ID, unless you edit yours in first (then OK).
You have been warned!!!

@Lost_N_BIOS same behaviour :(… beginning to wonder if it’s the CPU itself now
or my boards cursed haha

@define - Did you get the CPU new or used? Can you afford to grab some other cheapest coffee compatible board to test with, or maybe friend in town with Z370/Z390 will break down board and test your CPU for you?
Please wait >> @dsanke or @chinobino @PCGH_Torsten - Is there any known issue, or special thing that needs done for GA-Z270P-D3 + 9900K?
BIOS at #4 should be OK, built with stock BIOS as base, Coffeetime Advanced mode 1-8 + REM ME-Rec all 1 by 1, ucodes separately later with MMTool 52

@define have you shorted 2 pins on the cpu?…n4_CjABuPvn.jpg

@Pierug - Thanks, but that should not be required on GBT board, however (!), maybe this model they didn’t do the connect internally? Have you read this model required it?

@define - how are you flashing in the BIOS? If using Qflash, be sure to pick Full/-In-tact if asked, if not asked, then use programmer or FPT (FPTw.exe -f filename.bin) << If that fails too, and you do not have flash programmer recover and try this instead >> FPTw.exe -rewrite -f filename.bin

CH341A SPI programmer with a SOIC8 clip direct to BIOS chip.
macOS flashrom version 1.2

Used, seller said it was functional.
Yeah I might order a Z390 board just to make sure.

@define @Lost_N_BIOS Does the motherboard actually POST (beep once) and then reboot? Just remember that motherboard only has 4+2 power phases (CPU+iGPU) and can reach max current limit (ICCMax) with a 9900K.

The only things I can think of are to try connecting SKTOCC, checking for bent socket pins, testing if the 9900K works in another board and trying a different power supply (especially if old or cheap).

@define - Does any BIOS you’ve tested work OK after flashrom programming with older CPU? Just asking to be sure the write is going in OK. You did do the power drain/1+ minute correct?
Please test this BIOS, and see if same -…710569729443850

Also, test these two with HT disabled by default to see if that is the issue. This may alleviate the max current limit, if that is part of the issue (and if works, then this CPU not ideal fit for this board, since you’d have to cramp it’s style to use it )
In this package, One is same I sent before, other is same as above, but both with HT disabled by default -…311773790150327

Don’t know, will have to attach speaker to see.
I ordered a proper Z390 board, it’ll be a couple days for delivery.
PSU is corsair HX850i 80+ plat, don’t think we have problems there

Yes, the board boots after flashing with the old CPU installed.
I did the power drain steps as well.

Let me try the HT disabled BIOS, will get back to you.

@define - Also, please test that first BIOS I sent above at post #11, before you test the HT Disabled ones
Sorry you had to order Z390 board, but at least maybe it will be a much better fit fot this CPU anyway, due to the smaller VRM on this board it’s not really ideal anyway. Which model did you get?
For this one, grab a 4C/8T or maybe try 6C/12T if you feel lucky, I bet 4C/8T will be no problem though

Ok, tested all 3 BIOS’s - same behaviour.
I booted it with the old chip first and all 3 BIOS work fine but when I swap in the 9900K, doesn’t work.

I tested no CPU in the socket for fun and it does the same behaviour so I think the board is not detecting the CPU.
PSU clicks on and off on a loop, cpu fan spins though. Looks like I have to wait until my Z390 board arrives.

Got an AsRock Z390 PRO4… hopefully I don’t have a dead chip.

@define - Bummer! Thanks for results on all three BIOS. At least you’ll know if CPU OK or not once the new board arrives
Did you test the two pins that you have to connect on CPU pads, maybe on this particular model Gigabyte didn’t do the SKTOCC connection already (So you may need to connect those pads)
If you don’t want to connect the pads on the CPU, do you have other lesser Coffee CPU? If yes, try it instead, then you’ll know if you need to do the pad connect or not.
If you do have other lesser Coffee, let me know the model/SSPEC so I can add it’s microcode if needed in a BIOS repack for you to test with.