Gigabyte X470/ X570 Aorus BIOS mod thread

Let me know how it goes @Mili2110

I’ll test it tomorrow and write in about it. I downloaded it from your link the other day, but had to order a memory card to flash it in bios easy. What changes have been made did I miss the post. And thank you for the answer on the PCIe lanes. I have 1 gen 4 nvme installed when I used the bottom slot it was running gen4x2 so I swapped it with the top slot now it is running gen4x4 full speed my alternate nvme is a 600p Intel gen3 so having it set to gen4 it has gen4x2(gen3x4) it seems to run better than before it was slower running gen3 x2 in the bottom in userbenchmark. I really like the interface that the f41 bios has and when they went to f50 it seems they reverted everything back losing the graphical rgb interface. If the F41 has anything more to give or the F50 could get gen4 back i would love to test that out. And I’ll be donating very soon just have to get some extra money with this quarantine life is sucking and I want to do something. I was thinking about lapping my 3900x for fun but am afraid ill do it lopsided… anyways that was a side thought stupid cpu hits 78c on one tmp sensor as the rest float around 56 really hurting my top end having to lower speeds and was thinking the ihs may be wonky and not flat

Also the older F31 bios used to set my cpu to 4350mhz all core and it never fluctuated correctly the voltages were wrong and they had a lot of problems. The F41 had all that fixed then they BORKED all of it after that. Thank you again @Ket your awesome.

AMD are pretty good usually with their integration of the IHS they use indium to attach the IHS to the cores and normally the IHS itself is pretty flat, you can try lapping it but don’t be surprised if you don’t gain much. I’d try the glass paine water test first myself, its literally a drop of water on the IHS and then gently press down a small glass pane, if everything spreads out quite well lapping the IHS shouldn’t be necessary. Older gen drives tend to do a little better when put on newer ports so I’m not surprised a gen3 drive is doing a bit better on a gen4 slot. Theres quite a lot of extra stuff with the modded firmware you’ll be quite surprised when you dig in and explore :wink: We are all aboard the USS Isolation for the moment but there is a bright side - I have more time to turn out modded firmwares

I’m not surprised about this its not the first time GB have messed things up badly, Let me know how it all goes

Okay sorry I’m a few days late had trouble with the dumb memory card I am flashing it as I’m typing from @bios in windows. After unzipping the rom file is read and starts no problem.
…waiting…for…install… :slight_smile:
Directly after finishing I pressed reboot in the @bios and it turned windows off but has not fully rebooted.will wait a minute before I hard shutdown.
Is the mobo code ill have to check gigabyte troubleshoot codes after this.
I had to toggle my SB to 1 then I switched my bios_sw to the alternate my 2 booted my system into bios then switched back to the f31 modified bios 1 while still in bios and now am running qflash back to the previous f41 because the 2 was f50a I flashed both with the newest a while back.
Still haven’t looked up 07
Its saying the ram timing for 06-07 i may have to pull 2 of the 4 sticks of ram out for stability.
But am already in the middle of flashing back. I’ll wait for your ideas maybe I may try again but not during typing.

@oOoCLOUDoOo Flashing from Windows is going to cause serious problems, theres a reason why I design these modified images to be flashed with QFlash directly on system boot or through an EFI shell You’re also going to get problems because you are trying to downgrade the firmware manufacturers typically do not allow this because of AGESA changes I override these lockouts allowing for downgrades which is why you must flash these modified images through QFlash (not Winderp version) or through an EFI shell as this will allow for a complete erase and reprogramming of the ROM. Theres also quite a lot of footnotes with GB boards, especially for 3rd gen Zen and 4 DIMM compatibility, specifically in your case; You need at least F40 to run that 3900X, so the F31 version I modified likely won’t do you any good I’d need to check manually if theres any support for 3rd gen Zen with F31 GB simply didn’t bother to mention.

There are a LOT of other footnotes from GB as well you need to be mindful of and if you didn’t do any of these steps you really should completely erase the ROM from an EFI shell to make sure everything “takes” properly. I don’t know why GB made this process for the newer firmwares such a mess, but thats GB for you I suppose.

1. F31 was the last simple firmware image, which is to say no hoops required to jump through before/when updating so consider this your baseline safety net.
2. From F31 and BEFORE updating to F40 you MUST run the EC FW Update Tool B19.0517.1 (or newer) to avoid 4DIMM DDR incompatibility on 3rd Gen Ryzen CPUs (this is probably why you get no POST with moded F31)
3. Now you can safely update to F40
4. Now you can update to F50

If you need to know how to erase and update from an EFI shell I detail how you can do this >>HERE<< under “How To Flash”.

Any updates @oOoCLOUDoOo ? If necessary I can do an experimental firmware using more updated code in your case.

I had my main computer go down i need to replace the c:\ i was using a saberent gen 4 nvme and it forgot how to boot. i was having trouble with it when i first bought it but was aboe to get it booting by doing a direct clone. but not having the older operating sytstem to copy again it is a brick until i can replace it with a more reliable drive. im sorry for not testing it again immediately but i will definitely try again with the qflash directly in bios soon.

Ah ok no problem @oOoCLOUDoOo let me know when you are sorted and we will pick up where we left :wink:

@ket can you make b450 aorus elite also BIOS mod?

@Redox199 thats the plan I don’t have any GB X470/B450 boards though so have to rely on others willing to test for me.

@ket if you want i can test a modded bios on my b450 aorus elite

EDIT: i was so confused, sorry, my motherboard is a b450 aorus pro!!!

@Redox199 that would be very useful I’ll put something together.

@ket really thank you. If you need some information here I am, you can ask what you need.

I’m also willing to test, I have a " B450 AORUS PRO WIFI "

Hello! I came across this topic in the hope of getting rid of nervous exhaustion.
The fact is that I am the owner of the motherboard Gigabyte Aorus x470 Gaming 5 Wi-Fi. Overclocking on it does not add performance, but only brings pain and suffering.
To begin with, here you can’t do a simple overclocking of the processor through the multiplier and setting the voltage. My Ryzen 7 2700 processor has a lower voltage, and the board does not allow increasing Dynamic VCORE higher than +0.300. What is not enough for 4.0 Ghz. It is necessary to make "overclocking" through P-states. Same thing with SoC voltage.
But at least these problems can be solved. The main problem is overclocking RAM. We can say that it is not at all. The maximum that can be obtained is 3066 Mhz.
Higher values do not pass stress tests. At first I thought that the matter was in my RAM, they have Hynix MFR chips. However, there are no problems on other boards.
I recently changed the kit to Samsung B-die, (ADATA AX4U320038G16-DT41), but I still can’t increase the frequency above 3066 Mhz. I tried almost all the settings that are available to me in the Ryzen DRAM calculator. I think there are similar problems on Aorus Ultra Gaming.
My board behaves the same with overclocked processor or without him.
I also noticed that I do not have some settings in bios, for example, BGS / BGS alt, LLC is missing. And during voltage tests, they behave unstably. BCLK jumps so much that the memory frequency of 3200 Mhz can increase to 3360 Mhz.
I tried increasing the timings, adding or decreasing the voltage, but this does not affect the result. So I would like to know if there is a way to fix this?

@Redox199 & ok I’ll get something together soonish, very busy atm. @Messier26 I can probably do something to remedy at least some of those problems.

@Messier26 very quick edits but here is something you can try. PBO is disabled which should help with getting stable manual OCs. Also try swapping the DIMM banks your memory is in. Clicky.

I want to change the name in UEFI "Manufacturer" & "Product"?

For example, the Geekbench to show something other than…

How to do it?

Looking for some help or some answers…

I can’t run any of the newer gigabyte bios and have windows 7 boot. F14 is the oldest bios that I can boot windows 7 in.

I’ve done the plethora of troubleshooting and then saw someone on another board with similar problems who also fixed the windows 7 issue with using an older bios.

I’m curious about the new Ryzen 5000 series, is there a way to put the new chips microcode inside the F14 bios? Is it as easy as the intel chips? I have no experience with the amd side, but a while ago I did play around with UBU utility for intel. Someone please guide me, I’m curious if I will be able to use ryzen 5000 if this method is possible. Thanks in advance