Gigabyte X570 i Aorus Pro WiFi low resolution Aorus bootlogo

Hi guys!

I have this mb with a Ryzen 5 3600 and a Sapphire RX580 4gb Nitro+. I’ve the latest F33 bios on mb.

The bootlogo is in a very low resolution and it shows in hires only a couple of seconds before Windows 10 desktop shows.

I’ve tried with a Rx570 and it’s the same.

Is there any mb BIOS issue related for it?

Thanks in advance for the reply!

Congrats…u have a fast booting machine…normal in UEFI boot.

EDIT: Most modern motherboard can display the OEM logo in 2 different ways, according the bios setup (CSM ON/AUTO or as UEFI), UEFI as the best resolution image according the OEM design, CSM could show it or not, if not in this case
ull see the Windows logo. As u described ur boot, seems a normal situation using modern hardware in UEFI mode and SSD/NVMe drive…it boot in seconds…so the OEM only displays a very short time. Some bios have an option "Full screen logo"
Now im the one that doesnt understand ur issue…

Thanks for the reply!

I don’t think I’ve clearly understand…so: I have “fast boot” option disabled in BIOS options.

Should I try to change anything in bios settings?


Thanks for the explanation!

The issue I have is that I have other build (intel 4th gen and 8th gen, for example) that shows the mb logo from the very beginning of the boot in hi resolution (1920x1080), while with this x570 Gigabyte I have lower resolution logo (using the same GPU I used for 8th gen Intel build).

I would like to know if there’s a way to have the hi Res boot logo

Now ur talking of an older model… different situation as this applies the same settings as explained before but the bios could not have the same options for boot display (AUTO -FULL SCREEN - DISABLE), but CSM/UEFI is the same procedure.
Now for example older MSI motherboards, even selecting UEFI can display Low res full screen logo, but if the option Full screen/Auto logo display is enable, it changes to small centered high res logo/Different logo.
Asus only display logo if UEFI selected, else windows logo…All this varies from OEM to OEM, but mostly aal now is centered high res logo in UEFI.

EDIT: I can try to have a look in the bios structure/strings, to witch model of motherboard, the X570 or the older one? State the bios version used and boot type (CSM or UEFI).
CSM ON is the same as a Legacy bios…u wont get it higher than 1024

I have CSM disabled and full screen logo.

Is there any way to solve this “issue”? I’ve read in the forum that some users have modded some Gigabyte bios to enable Windows 10 WHQL, that were hided in the bios. I don’t know if it’s my case!

I’ve found this thread: [SOLVED] B450 Aorus Elite & Nitro+ RX580 1024x768 EFI resolution

It seems to be the same issue as me.

I’ve used AMICBP to enable windows 10 WHQL, setting it to USER mode. After saving it, q flash or @bios tells me the bios is corrupted. In the thread, the user said that he changed a byte to make it flashable.

Can anyone help me to understand how can I modify the saved bios file to make it flashable?


Flashing Gigabyte while avoiding "Invalid BIOS image"

Seems that ur posting all around this forum… u must wait for users to help…this is not a 24h TI live support, its a user forum.

And be aware that mods and flash can damage ur system and no one here is responsible for ur decisions/actions, insure that know the risks and recovery methods.

Thanks for the link. As you’ve already seen, I wrote in that thread.

I know it is not a chat support, I just asked in different places of this forum (and in a sort of different ways, because of the different situations) if anyone who already has experience with the issue can help me.

If it is not allowed, I’m sorry for this and of course admins can remove my posts.