Gigabyte Z390 Aorus Pro Wifi - Enable SPD Write

I need to enable SPD write on my Z390 Aorus Pro Wifi motherboard, and I am not sure how to go about it, the option does not appear in BIOS.

@SE7EN - I can make you BIOS with this set to False, but I can’t make it visible. Also, this is not always the thing stopping you from writing to SPD, sometimes it’s the chip on the memory itself is write protected.

If you know how to use AMIBCP, get AMIBCP 5.02.0031, and then at Setup >> PCI-I/O Config >> SPD Write Disable (Change to False for both columns), then save.
To flash the mod BIOS via Qflash, make this edit on the BIOS as a whole via hex (For BIOS F8c or F12c only, I only checked these two).
If you are not using F8c or F12c (See below for offset for F12c), do not make this edit yet, wait and tell me BIOS version and I will get you correct byte to edit for that version in case it’s not same byte
>> At offset >> FD0BD7 >> Change 01 to 00
Then flash mod BIOS via Qflash

If you need me to do the edits for you, let me know what BIOS version

@Lost_N_BIOS I am not quite sure what I am doing wrong, I have never edited a bios before. I am on bios f12c, I downloaded ‘mb_bios_z390-aorus-pro-wifi_f12c’ extracted, then opened ‘Z390AOPW.12c’ with a hex editor. ‘FD0BD7’ is not found. I even tried looking for it manually, but it goes from FD0BD0 to FD0BE0. I am not sure what exactly to do if I did find it anyways. If you could do them for me on f12c I would appreciate it.

@SE7EN - FD0BD7 is an offset/location, you go to this location in hex editor, not search for it.
Ohh! Sorry, I see, you just aren’t familiar with how to count in hex And sorry, I gave incorrect offset location for F12c above (Edit above to correct/direct here)
You need to go to line FD08E0, then out to column 7 = 0xFD08E7. If the image below still does not help you let me know and I will edit F12c for you to do this mod and change the SPD setting too while I’m at it

So, for anyone reading later, here is the correct offset to edit for each BIOS
F8c >> 0xFD0BD7 >> Change 01 >> To 00
F12c >> 0xFD08E7 >> Change 01 >> To 00

Here is image of 0xFD08E7 location in F12c >>


are you saying you would enable SPD write, AND something else too? or did I misread?

edit @Lost_N_BIOS I should probably just grab one you edit, I think I kind of understand what to do, but I don’t want to brick it.

I was saying, if you wanted, I would do this edit above to allow Qflash of the mod BIOS, and do the SPD Write Disable change to False
* Edit - To your edit, OK, give me a second

* Edit @SE7EN - Here, all mod done by hand (no AMIBCP used), SPD Write Disable >> False at all possible location (NVRAM Main/Internal + PEI volume shadow copy, Setup, AMITSE/SD) + Qflash unlock Mod…448359655378294

Flash BIOS via Qflash

@Lost_N_BIOS I am not having any luck with this. No RGB control, no SPD info on CPU-Z. I tried a second set of different ram (non-rgb) and no SPD info in CPU-Z either. Is it ok to downgrade from 12c to 8c with a regular qFlash? Do I need to flash standard first, or can I just flash a modded 8c over the 12c?

@SE7EN - SPD info on CPU-z? That is easy, open CPU-z, go to SPD tab, on upper left corner there is a drop out menu, hit that and select another channel if nothing is showing at the bottom by default when you open this tab.
Or, please explain in more detail what you did, what you’re trying to do, what your actually talking about (ie BIOS edit, or memory info messed up after SPD flash programming, or what etc??? )
If you have messed up editing SPD/XMP profile, and now SPD info is blank, then flash back in a known working stock SPD/XMP profile, you can generally find them in google on forums if you did not dump yours before it was messed up.
Sounds like maybe you did this ^^

Yes, you can downgrade BIOS, unless Gigabyte says in BIOS download page you can’t. Usually ME FW or Microcodes may make them say you can’t and block it, but there are ways if you get stuck and need to downgrade.
I would not downgrade to 8 from 12, if 12c is latest stay on that, or maybe some F11 you were using before. This (BIOS version) has nothing to do with anything you mention above, unless there is some extreme BIOS bugs going on, if you think so then try F11 or F10 maybe, but I wouldn’t go so far back as F8

If you are talking about RGB controls in BIOS being an issue in general, with the BIOS/settings and not specifically some SPD/XMP issue with your memory (ie related to this thread), then you may want to see the backdoor method to both sets of RGB options via edit + backdoor
See the red * here, and then “Bug/Backdoor” #1/2 section below - [OFFER] Gigabyte Z390 M Gaming UPD + Completely Revised Blue Theme

Sorry about that. I guess I never specified what was going on with my computer. I have some Corsair rgb ram sticks in my computer, the rgb controls are nowhere to be found; neither in icue or rgb fusion. The SPD info shows up on the motherboard, but it is all blank, all 4 slot numbers, in CPU-Z. I ran memtest to make sure I didn’t have bad sticks, and tried a different pair of ram (different model, non-rgb) and have the same issue of no SPD info in CPU-Z but does show on motherboard.

I did a lot of searching before this site, and almost every answer was enable SPD write on the bios, asked on another forum and was referred to here by someone who was helped by you on the Master version of the board I have. I just want my ram to show up in icue so I can change the colors with the rest of my hardware, and more importantly be able to turn the lights off when need be. Thank you for your help and patience.

edit: @Lost_N_BIOS can you tell me what to change on f10 / f11 and hopefully I can get one to work. F12c had other issues for me so maybe I’ll get lucky and that version was the only issue.

@SE7EN - Sorry, not sure what icue is? Did you install RGB Fusion application? If yes, did you try a few versions? I see there is some discussion in google (maybe at reddit, I forget) where some older versions only work best for certain brands/models of memory and new one only works for certain ones too.
Memtest wont help tell you if SPD is bad, did you flash the SPD at all ever? SPD Write Disable on the BIOS is to allow you to program in modified SPD/XMP profiles on your memory sticks (if not write-protected themselves) That is the ONLY thing this setting is for.

I don’t think there is anything to change on any BIOS version for the issue you mention. Please dump your SPD with Taiphoon burner and send me a copy, and make a thread on Corsair site and ask them to confirm the SPD is OK/Correct for your model, if not ask them if they will provide you a corrected one
If fixing your SPD is required, you will need to purchase paid version of Taiphoon burner, unless Corsair gives you some tool to use.

To access hidden RGB settings for the board itself, which may or may not help or control your memory RGB, see the link I gave at end of above post and read what I mentioned.
If you need me to edit a BIOS for you, check first without mod and see if you see can see both RGB options in BIOS via the bug 1/2 or not. If not, let me know and I will edit F10/F11 for you.
I don’t know if these options in BIOS control memory RGB though, I’ve only tested strips and onboard colors, I don’t have any RGB memory (I think those come with apps usually, but not sure if board can control sometimes too or not)

This could be a BIOS bug with the brand/models of memory you are using and this particular board. See if you can find other user with exact same memory and board in google, then contact them and ask if they can see SPD info in CPU-Z or not.

* Edit - For now, here is 12c with RGB mod (This is built on top of SPD Write Disable=False mod I made you before), you will need to access it via the method I outlined in the link above - Bug 1/2…107931117761004