Gigabyte Z390 Designare - BIOS Flashing with CH341A possible without desoldering?

Do the F10 and F11/ F12 keys even work?
I tried it on the Aorus Master but they don’t do anything at all.
Then again, the Aorus Master has the dip switches for single/dual bios mode and primary and backup bios as current bios.

I remember on the OLD gigabyte P67 boards, you couldn’t even do those key strokes without a PS/2 keyboard. A USB keyboard was possible but it was as hard as trying to enter windows safe mode boot menu on any current system.
At least I hope it’s better.

And I wish I had found this thread much easier. I would have recommended you buying the Skypro programmer rather than the CH. The software on the Skypro is MUCH better, updated repeatedly and supports so many chips. Used it to TDP mod my MXM GTX 1070 and backup bioses.

http://www.coright.com/product/showproduct.php?lang=en&id=51

Now they have a Skypro III…oh dear…
http://www.coright.com/product/showproduct.php?lang=en&id=58

And for Gigabyte, if I recall, to stop boot loops in the past, you’re supposed to flash both the main and the backup bioses to the same version.
But you can’t get to the chip :frowning:

Have you tried a Pomona 5250 clip? the teeth are narrower than many of those cheap chinese clips you see all over.
https://www.amazon.com/CPT-063-Test-Clip…/dp/B00HHH65T4/

Also the Designare is not their highest end board. It’s considered to be around the level of the Ultra, but with features catering to a different audience (Ultra is catered more towards gamers). Look at the PCB of the Ultra then you’ll see.
Only the Master and Xtreme have the bios jumper selection switches.

I only have a USB keyboard, so I’ll probably never be able to do the ctrl + F10 trick… and no, I haven’t had any success with ctrl + F10 before…

I don’t know what’s going on with this mobo… it’s pure lunacy… now that I know that the backup bios is a liability rather than a benefit, I will have to return the mobo…

The sly folks at Gigabyte have really outdone themselves placing the backup bios directly next to a tall capacitor, just slightly beneath a heat sink…I’m not even sure if these Pomona clips would help… you can see the location of the backup bios in the image I provided in the original posting.



I looked at the picture.
The Pomona clip SHOULD fit.
the part with the teeth is flat up to the body of the clip and there seems to be 2mm of distance between the teeth and the very edge.
Eyeballing that solid state cap, there seems to be JUST enough space to get a read on it. Don’t quote me on that. That’s just an educated guess. But it isn’t an expensive purchase. Besides everyone should have a Pomona 5250 clip. They’re a lot higher quality than those cheap black ones.

@Falkentyne - I’ve used on recent boards as new as Z170, it’s just different now for UEFI BIOS, but it still works (F10-F12 do different things, with ALT or CTRL)
Yes, it works with USB too that’s all I use now and just used this feature recently on Z170 too. USB worked way back in P67 as well, but when possible it’s easier with PS/2

@Lumberjack these hotkeys will get the backup BIOS changed for you, all you have to do is get on it
But yes, I agree with Falkentyne, unsure about Pomona clip since I don’t have one, but it looks to me like the cheapo clip should fit. If not, that heatsink likely has a pad on it, remove it just be careful squeezing the pins together on backside to push through, so you don’t scratch PCB, unless it’s screws then you’re all set.
if the edge of the clip is against capacitor too much, grind/file the clip down on one side

@Lost_N_BIOS - I already tried the cheapo clip and it doesn’t fit at all. The capacitor is simply way too tall.

In the meantime, I got a brand new Z390 DESIGNARE which i have successfully flashed with the newest F6a bios version. No more reboot problems, it just works as it’s supposed to.

The experience with the faulty Z390 DESIGNARE has certainly left its mark on me. The flashing process today was a nerve-wrecking undertaking and I’m even scared to adjust the bios settings. What if I overdo some CPU or RAM overclocking? Will the system erase my main bios and flash it with the backup bios or will the main bios remain except that optimized default settings will kick in? Is it best to stick with the XMP profile and leave the CPU at stcok settings?

I talked to Gigabyte about the backup bios: The tech suppoorter told me that the backup bios always remains at the factory bios version (in my case F3) no matter if the main bios was flashed successfully or not. So I guess just flashing the main bios should have been sufficient. In my case, it wasn’t of course. I don’t know what has happened exactly but I sure now that it is all due to the corrupted bios flash - all these reboots, 12h rest - working cycles are all due to a failed bios update. I still can’t believe it. Not even a proper flash with the CH341A was able to make it work it had to be a completely new board…

@Lumberjack - glad you have a good working board now! So alleviate your worries, since you are now on the latest BIOS, go ahead and reflash the backup to match the main using the hotkey combos I mentioned.
If you hit wrong one redo again using opposite command (If CTRL flashes backup to main, then use ALT instead, once you re-update the main to version you wanted)

If you mess up an overclock generally it will try a few times, then fail and let you know in the BIOS overclock failed. Sometimes when pushing certain things too hard that kind of recovery fails, and you would simply be forced to clear CMOS to get back into BIOS.
That is how boards work normally, and your new one should work like this always, not sure how you ended up at situation with the other board but I doubt you’ll see that mess again.

XMP, overclock etc, that’s all up to you Don’t be scared of BIOS, you wont run into same issue as before!

Tech support knows nothing, except simple scripts. That statement is wrong on a few levels. Some BIOS will update the backup BIOS by itself, when Qflash version changes for example, and there is other times this may happen as well (major security updates etc).
Or you can change it yourself as mentioned, I suggest making it match current latest version once you are sure you like that BIOS.

@Lost_N_BIOS - Thank you once again for all your helpful posts! I will try the CTRL + F10 before the bios screen tomorrow so that the backup bios is updated to F6a, too. Would you recommend doing the CTRL + F10 command with optimized bios settings or should I first set the settings to my desired values, including overclocking, before I use CTRL + F10?

If I reset the CMOS - via the CMOS jumper or the CMOS battery removal - after an inappropriate overclock or detrimental setting, will the PC automatically start with the backup bios or will the main bios be used?

I’ll definitely report back tomorrow.

You’re welcome @Lumberjack - Settings used don’t matter, it’s always a base copy, wont carry over any overclock or saved profiles etc

Resetting CMOS it will boot with normal BIOS at fail safe defaults, until you again apply optimal defaults.



I really don’t know why Gigabyte didn’t include the bios dip switches on that board.
I was able yesterday to flash my backup bios to f8b by just setting the mode to single bios mode and setting the 2nd dip to bios #2. Then it booted to the (stock) F4 bios, then I flashed it with f8b and it flashed properly.
Then I switched it back to the main bios (#1) and my saved profiles were still there. It was easy and worked as expected.

The dual bios configuration without hardware switch control is just a plain lot of work. Doesn’t Asus even include dip switches for manual switching on their boards? Do they also have two bios chips?

@Lost_N_BIOS & @Falkentyne - I tried the hotkey trick several times before the bios screen (CTRL + F10) to no avail. I contacted Gigabyte once again and they have informed me that they have officially removed these bios flash hotkey commands after their Z170 motherboard line.

He also told me that if the board doesn’t have a physical bios switch, there is no way to induce a backup bios flash. Some dualbios boards without a bios switch do feature an automatic backup bios update, however, it depends on whether or not the developers deem it necessary for a particular board to update the backup bios every time the main bios is successfully updated. And I agree: It’s a damn shame that a board in this price league - it’s definitely among the more expensive Z390 boards - doesn’t at least have a bios switch or socketed insertions.

Is there any other way left, besides the programmer, to update the backup bios to the main bios version? Now that I know that the main bios is working correctly and I won’t play around with the bios settings, will there even be a need for a backup bios? Is it possible that the main bios corrupts out of the blue?

They may have removed them now @Lumberjack - last board I’ve used them on is Z170. If you insert a new Qflash module it will update the backup, but since that is brand new board and latest BIOS I’m sure it already has latest. Only option left is programming.
You can try the DOS Flash tool included with the BIOS downloads, and add these switches to end of command testing each one at a time, you will see it flash second BIOS after first, if it happens >> /X or /Y or /Z

Making backup match main is good for two reasons, one you know that version is compatible with your CPU, and two it’s better for stability that way.

@Falkentyne - That’s how to do it when they’re nice enough to give you physical control!
Asus rarely gives switches, sometimes uses dual BIOS but mainly only on non-mainstream boards, and they haven’t even being doing that much in past 3-5 years either, and are now starting to use soldered BIOS instead of socketed too which they used to always use.



I still say go with the Pomona 5250 clip. It’s a VERY nice clip and it’s not as ‘fat’ as those cheap chinese prebuilt clip adapters.
I just took a picture of the Pomana clip and a chinese clip side by side.
I’ll let you be the judge on if you think the Pomona clip can fit around that fat capacitor. I think it will. It’s obvious the chinese clip won’t.
If I were you I would just buy it anyway. You have nothing to lose even if it doesn’t work, you get a MUCH nicer clip anyway that is more durable.

You’re still going to need some jumper wires to hook it up. These will do.

https://www.amazon.com/gp/product/B01EV7…Q25ENKVJ1&psc=1

20190104_125852_HDR.jpg

@Lost_N_BIOS - I can’t believe it… after the PC has been performing normally over the last few days, all under the newest Firmware F6a, it’s again stuck in a reboot loop. Like a curse… what can put the motherboard into a reboot loop a few days AFTER a successful bios update to the newest firmware? It happened out of the blue… I was restarting the pc a couple of times because I wanted to fine-tune the hackintosh clover boot options and settings, and all of a sudden, and after the fourth time or so, it got stuck in a reboot loop.

Surely it can’t be a corrupted main bios once again? Are maybe some cables behind the motherboard causing short circuits etc.?

@Lumberjack - maybe you have some instability issue, are you running stock speeds? What is your memory speed and how do you have it setup (XMP or manual etc)? Have you ran extended Memtest on this as it’s setup now?
Were you forcefully rebooting, shutting down by force mid startup etc? That can cause it if done in certain ways

@Lost_N_BIOS - No, I was just rebooting for the fourth time. I haven’t touched any physical buttons, just reboot from Mac OS X. My PSU is still under warranty, so I’ll send it in and see if it’s maybe the PSU that’s at fault here. Other than that, I don’t have any options left. The motherboard is new, the RAM is new, CPU is new, GPU is a bit older but I already tried it without GPU and it leads to the same reboot loop. Only component left is the PSU.

I doubt it’s PSU, but maybe could be if it’s badly unstable. More likely memory or CPU instability, new means nothing here, nor does using auto settings.
This is especially true for memory and in regards to memory sometimes XMP or auto can be worse than setting things yourself to stock values, especially if the memory is not made for this chipset.

@Lost_N_Bios - So far it seems to be the PSU’s fault. I got a new one today, installed it, and now the system functions as it’s suppossed to. Maybe it’s because the motherboard was disconnected for several days. At this point nothing would surprise me. I bought a PSU tester specifically to rule out a PSU failure, but I guess delivering good voltages into a handsized PSU teste ris no guarantee that it will perform as good under realistic load…

Give it a few weeks before you are sure, remember this time, and before, you used system for a while before anything happened. Disconnected for a few days shouldn’t cause that, but if CMOS battery socket is loose, or battery is not good, you might loose settings or time
I agree, PSU tester only gives a good indication if it’s reasonably OK, but is in no way a proper way to know 100% for sure if all rails are stable or if there are major spikes or drops that would cause issues that you might only see for milliseconds with an oscilloscope.