Gigabyte Z87-HD3 bios downgrade

Hi to all,
i’m having a problem with my current bios and i’m trying to downgrade it to previous F7 version. I tried with FPT tool but i didn’t work.

Is it possible to do it on this motherboard?


This is the error i’m getting when trying with FPT tool: Error 337: Hardware timeout occurred in SPI device. FPT Operation failed.

@datoneer - Few things here about FPT.
First, FPT should not be used unless you are first dumping BIOS with FPT, modifying it, then flashing it back.
And for that, and what you want to do, you need a some skills in modifying BIOS, so not ideal probably. Or you need to modify the BIOS you plan to flash in first, to put in LAN MAC ID at least.
Second, see end of first point above, this is not ideal tool or method to do this.
Third, if/when using FPT, you need to use the correct version from the ME System Tools package that matches your current ME FW version. If using in windows, ME drivers must be installed, otherwise run from DOS/EFI versions

To downgrade BIOS, put BIOS on USB, flash via QFlash from within the BIOS. If Qflash says no, then try with @BIOS that is exact version from your boards driver download page.
What are you wanting to download the BIOS for? And, from what version are you using now?

@Bios and QFlash doesn’t work, already tried. It shows me the message about outdated bios. Everything was working fine with F7 version, don’t ask me why i updated bios to latest F8 version.

Computer is having problems with power, if i turn it off i won’t be able to turn it on without pulling out one of the memory sticks. This started to happening with latest bios version.

@datoneer - @BIOS says that too? If yes, then that means there is a reason for this and it’s not date. I will check, usually this is due to Qflash version difference between the two BIOS, or ME FW possibly (Not this, I checked).
I checked Qflash versions, and they are the same version 1.05, but different sizes, so something is different between them, and they didn’t change the version. Anyway, this is why it’s telling you NO, nothing to do with date

Do BIOS downgrade in DOS, with the tool that comes with the BIOS EFIFlash >> Use command like this >> Efiflash Z87HD3.F8 /X
If you still get outdated version message when using /X flag, let me know and I will edit EFIFlash for you and send you mod version
If you get outdated, or other error, tell me the exact error and I will made mod EFIFlash 0.44 for you to bypass the error

As for the issue you mention, sounds like your ME FW may be corrupted, can you see ME FW version w/ HWINFO64 as shown below, or is it missing, or N/A or


Thank you a lot! Efiflash did the trick!

@datoneer - You’re welcome, and great to hear all sorted now!