Got UEFI RAID Intel RST to work for Server 2016 / Win 10 on a MSI C236M after spending a few hours fighting a BSOD


I wanted to post this here in the hopes of savings others hours of time. i ran into an issue and while some suggestions on this forum helped ultimately it was different attempts on my own that solved my issue.

I ran into an issue when using UEFI mode, RAID mode, and trying to install Windows Server 2016 (also tried Windows 10) on a MSI C236M. The board came with AMI BIOS Ver D.2 dated 2016-03-03. This had Intel RST (RAID) driver ver 13.x built in. On Intel’s site they list ver 14.8 as the first to support Windows 10. When trying to install Win10 or 2016 it said “no drives detected”. I’ve seen this before so I downloaded the RAID driver from Intel’s site onto a flash drive and supplied it during the setup. When the setup tried to use this driver it would then BSOD and restart before it got to copying files. I could have used the legacy non-UEFI mode but my drives are 6TB so I would have been limited to using only 2TB of it with the legacy option. I also could have used AHCI but then would not have been able to run the two drives in a RAID.

I solved this by flashing AMI BIOS Ver D.4 dated 2016-07-27. This included Intel Rapid Storage Technology RAID driver ver 14.8. I then started the Server 2016 install again. This time it saw the drives but threw an error when it got to the “copying files” step. I one last time started the install running the D.4 BIOS and supplied the Intel RST ver 14.8 drivers from MSI’s website manually using the Load Driver option during setup. This time the install went through without any issues. Server 2016 found all needed drivers except 4. Running the Intel Chipset Driver ver from MSI’s site installed the rest.

My settings that worked
Intel RST Driver: 14.8
Secure Boot: Disabled
Win 8.1/10 WHQL: Enabled
Win 7 Install: Disabled
MSI Fast Boot: Disabled
Fast Boot: Disabled
SATA Mode: RAID Mode
*Make sure only UEFI devices are listed in the “Boot Priority” section, if not your settings are wrong. Boot Mode Select should also show "UEFI"

Hope this helps someone

@protivakid :

Although you are Forum member since July 2015, I want to take the opportunity to welcome you at Win-RAID Forum and to thank you for your detailed report about how you got the OS installed onto the RAID0 array.
Additional question:
Which sort of SSDs (manufacturer/model/protocol) are the members of the Intel RST RAID array?

Dieter (alias Fernando)

Thanks Fernando, this forum seems like a great place for all Intel Raid related topics. No other forum I found really dives into this as deep as this one.

I am actually running two WD 6TB RED drives in a Raid 1 configuration. I think any RAID configuration over 2TB though where UEFI is required would have caused the issue I had. I just wanted to save someone the time if they find this by Google-ing down the road.