[GUIDE] Adding Bifurcation Support to ASUS X79 UEFI BIOS

Recieved and installed, as expected the system detected correctly all the nvme. But I feel I cheated somehow.
Every nvme has x4 link at pcie 3.0 to the card has a x16.0 3.0 to cpu1
Speeds I see close to 3000MB/s, need more testing.
Thanks



Hi, I need a modified BIOS on the asus Z9PA-d8 motherboard to boot from the M. 2 NVME SSD on a PCI-E 16x adapter. Could you do that? For Z9PE-D8, you already did. I would be very grateful.

hello i am very new to bios modding in general, i already modded my bios on an asus x79ws/sys board with nvme support.
the great thing is that i have 6 pcix slots genaration 3 and two with full 16 lanes.
i also want to buy this asus hyper card and use it on one 16-lanes pcix slot to get up to 4 nvme ssd to work.
as i undrstand it right i can modify my bios to support bifurcation and also use up to 4 nvme ssd with asus riser card?

@ ZelliBigED
From first post:


So that’s a no you cannot use 4 drives on that card, just 2 on x79.


These do work with 4 NVME without bifurcation.

Hello Lost_N_BIOS,
I have already nicely working 3930k + P9x79 PRO with NVME mod by Fernando, but I have some question before upgrading to the one you posted with bifurcation support:

- will I have to reinstall the OS (Win10 Pro x64) after BIOS that update ?
- I am planing to use ASUS HYPER M.2 x16 Card V2, will I be able to use all 4 NVME slots ?

Many thanks in advance.
- Murko



No.
No.

Does anyone have the P9X79 modded bios (for NVME and Bifurcation)?

I Would be interested in P9X79 MODD

I’am banging my head against the wall. help

All here on post#1 for BiF, for adding NVMe follow this guide here and use MMtool method: [HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS




I’m just getting into this topic and I think this is exactly what I’m looking for for my P9x79 PRO, I got a 4-slot NVME card and need to enable Bifurcation to see all 4.

I cannot seem to download your file though, can you verify this is the safe mod that I would need to enable viewing all 4 NVME drives on 1 PCIE lane.

your link is broken

I also see that the P9x79 Pro with Bifurcation mod WONT allow me to have a PCIE with x4x4x4x4 and see all 4 NVME drives?

Lost has been away since January, i suggest that u all start addressing request to latest users (@username) u can still share it, if no one provide the MOD, starting reading and get ur hands dirty… like we all do.
There is plenty of info to get the work done in several post besides this one.



@MeatWar thanks for the reply, is there any harm in using the non-Pro version that @JackSted has posted at the start of this thread? I dont think there is a difference of the x79 and the x79Pro regarding the bios.

the second question was regarding the allowing 4xnvme on one x16 slot with this or is it just two? If it is just two I’m not sure its worth going through the potential of bricking my system :frowning:



@AmonRatWR do you have the working x79 Pro mod with Bifurcation MOD handy? would love to just plug and play it into my mobo without worrying about bricking :frowning:

also were you able to see all 4 NVME drives on 1 PCIE slot?

@Darwinn Thats a no on both accounts. To get 4 NVME to work you need something like this: https://www.ebay.com/itm/164655518145?ha…70AAOSwfGNfkOUq



@JackSted Thanks for the quick reply, okay so from my understanding there is no way to get this (JEYI iHyper m.2 X16 TO 4X NVME PCIE3.0 GEN3 X16 TO 4NVME RAID CARD PCI-E VROC CARD RAID Hyper M.2X16 M2X16 4X X4 NVME4 RAID) to work on anything? or just older motherboards?

Current Motherboards available:

ASUS p8Z77-V Pro
MSI X99S SLI PLUS
ASUS P9X79 PRO

If newer Motherboards will work with what I bought, I may just have to buy a new Mobo :frowning: I want to use the 4xnvme in Raid for Chia plotting and speed.

@Darwinn
If you want those to work you need full 4x4x4x4 bifurcation, TR4 boards have this and RAID support. I recommend you do some research and/or start your own topic.

thanks for your efforts put into this project.
i have a P9X79 {the standard version, 2blue 1white PCIEx16 slots}, currently on the latest official bios (4801).
when i try to flash your bifurcation modded bios (from your forum signature link "Asus P9X79-4701-Mod-NVME-SA-Switch" which i assume is for this exact mobo) with the EZ FLASH 2 utility inside bios it says "Selected file is not a UEFI BIOS".
I tried putting the official 4701 bios file on the usb drive and it accepts that one (so the error shouldnt be related to the flash drive or its formatting (fat32, tried different older drives and different formatting with win/rufus too).
Both names were P9X79.CAP. However i didnt proceed with the official 4701 version downgrade yet, as well as didnt try to use the bios flashback function with your modded file because im worried about creating more trouble or bricking until i get some affirmation.
Do i need to flash the official 4701 first?
Do i need to use the bios flashback function to flash your bios because ez flash maybe recognizes it has been modified?
Does the bios flashback still work even if previous flashing process critically fails (such as powerloss mid-flash?)

This files mods are for using the Asus USB FBF feature, never EZ or any other method, because as u saw it, Asus security features do not allow modified bios files to be used.
USB FBF will always works even if the mod prevents the boot.
U should update to the oficial 4701 (EZ or FBF) then apply the 4701 mod (FBF ONLY), if later the oficial 4801 is applied u loose the mods off course.

@msdq9 Yes bios flashback is required. The BIOS in my sig is indeed for "P9X79" I recommend you reset default options before and after you do a downgrade. You should not need to flash the stock 4701 first.
Also bricked BIOS should still flash with bios flashback flashing is then done by an independent system. Most here would recommend getting a hardware BIOS flasher just in case, tho you could do that when all else fails.

@JackSted
Thanks for the excellent tutorial.

I was able to apply your guide and modded ASUS Rampage IV Formula BIOS (enabled System Agent + PCI Configuration menu).
I tested the functionality with this bifurcation board – https://riser.maxcloudon.com/en/bifurcat…to-4x4-set.html and several GPU-s
I can confirm that it’s impossible to use x4x4x4x4 config even in this case, I can only use option with x8 + x8 and 1-st and 4-th outputs of the bifurcation board work (though, at x4 speed – but this is limitation of the bifurcation card, need to order another variant)

However, it looks like I’m running out of PCI resources for Win10 – USB riser in slot 4 (the one at the bottom) stopped working and there are errors in Device Manager.
I tried to use “Above 4G decoding” option in BIOS – but this leads to no output from my GTX 1080ti to monitor, and I had to clear CMOS.

Did anyone tried this option? Are there any other workarounds?