[Guide] Award/Phoenix BIOS Modding

I’m using CBROM. EXE in DOS mode.
>cbrom yyy.bin /D to list content. There is a module “PCI ROM[B] compressed size 37.39K RAID_OR.BIN” - I guess this is the one
to be replaced by the newer ROM_v11.2.0.1527 (file size 119K) code?
Looking for a “Replace” command in CBROM and how the new code can fit in since it’s much larger?

@ jookeer:
You should not compare the compressed size of a module, which is within a BIOS, with an uncompressed size of another one, which will be compressed after its insertion as well.
If you want to know the uncompressed size of the originally present PCI ROM named "RAID_OR.BIN", you should extract it.
Then you can compare the uncompressed size of both modules.

OK - thanks!
1. CBROM says the "Original size" is 61K. I guess this is the uncompressed size? Please see original BIOS as attachment, AB9_27.BIN
2. Using "cbrom ab9_27.bin /group extract" -> creates a 20K file. Looks too small? Anything wrong here?
3. Intel OROM v11.2.0.1527 file size is 119K, uncompressed I guess? Please see attachement 1527.BIN

4. What are the CBROM commands to replace "RAID_OR.BIN" section with 1527.BIN? Google cannot find a complete CBROM manual or tuturial, so some hints/help would be appreciated, thanks!

Why don’t you read the start post of this thread (especially chapter D) before writing any already answered questions?

Hi, i from Brazil, Help me used cbrom195 ?

@ geremias1234:
Welcome at WinRAID Forum!

It is not easy to guess, what you mean. What is your problem?
Which BIOS do you want to modify? Which modules do you want to update?
Do you need the tool named CBROM32_195?

Dieter (alias Fernando)

Just wanted to say thanks a ton! I updated my old gigabyte ep45-ud3p 1.6 with no problems whatsoever.

The old version of of the raid rom wouldn’t recognize my 5tb drives properly. If I tried to setup RAID, intel’s old rom saw them as 500 GB drives.

Just replaced ICHARAID.BIN with v11.2 and the system now correctly identifies their proper 5TB size.


Brand new here! Thank you so much for all these resources and the amount of work.

I’m following this guide to update the NVRAID of an ASUS P5N-D motherboard.

I get until this point:

The line of the NVRAID has changed (the new one was actually added and not replaced in the first place). Although the new NVRAID is below PPMINIT, the old NVRAID was above.

More, comparing the offsets in the two files, the "PPMINIT" string is located at two different offsets.

You suggest to fix correct that problem before proceeding, without changing the checksum.

How can I do that?
Thanks for your help!!!|addpics|4lp-3-466b.png|/addpics|

@yakou32 :
Welcome at Win-RAID Forum!

All inserted/replaced Option ROM modules are added at the bottom of the numbered BIOS module structure listed by CBROM.
In this case it was a mistake to use one of the latest CBROM versions like CBROM32_198, because they all try to (re)move the sensitive modules into the correct place while replacing any Option ROM, which has been listed above of them, but do not succeed with this operation. The older CBROM tools like v1.55 do not move the sensitive modules while replacing any Option ROM modules.
The safest method is to replace the current NVRAID.ROM module by an inactive "Dummy" module. After having done that you can insert the desired NVRAID.ROM module. For details please have a look into the first 3 posts of >this< thread. Additionally I recommed to read the posts of >this< thread.
As you will recognize after reading the posts of the linked threads, the desired update of the NVIDIA nForce RAID ROM will not easily been done and the risk of a failure while trying to flash the modded BIOS is high.
That is why I recommend to let the modded BIOS been checked by an expert (I don’t know enough about this kind of BIOS modding) before you are going to flash it.

Good luck!
Dieter (alias Fernando)

Thank you very much for your kind advises and the appropriate links.

I think I understood the main proces; one phrase sums it up :

1. Build a dummy NVRAID OROM : extract the original one, and then deactivate it by replacing its vendor and device IDs by fake values.
2. Replace the NVRAID OROM by the dummy one in the BIOS ROM
At this point, the global size above the PPMINIT should not change.
3. Add the new NVRAID OROM at the end of the BIOS ROM (after PPMINIT)

But, even if I understand the main idea, I don’t understand how the hexa editor works, and I don’t identify the values to be replaced.

I’m afraid to be stuck with some 4TB drives that won’t be recognized by my old RAID :frowning:

Maybe someone can help you to do it.

What makes you so sure, that you would be able to solve this problem by updating the NVIDIA nForce RAID ROM module?
According to my knowledge not even the latest nVRAID ROM modules do support > 2TB RAID Volumes.

Well, I don’t really remember where I read that information.
It was saying that Mediashield 9.x was required to bypass the 2TB RAID limitation.

I re-searched, and found that other post: https://forums.geforce.com/default/topic…85-or-newer-/1/
It seems to be working…

By the way, it seems that those people use the cbrom-only method which would cause a change of the file size. But still, it seems to be working…

@yakou32 :
If you tell me the nForce chipset of your mainboard resp. the HardwareIDs of your on-board NVIDIA nForce RAID Controller, I will create for you a suitable NVIDIA MediaShield ROM module v9.87.

Thank you so much!!
That’s really nice of you.

The nForce chipset is the 750i SLI.
The hardware ID of the ATA channel is 10de-0265
The hardware IDs of the Raid nForce controler are ACPI\NVRAIDBUS and *NVRAIDBUS

I was just re-reading the post on the GeForce forum :

I think I could give a try with the untouched NVRAID.ROM, don’t you think?

Thanks again!

One of these infos is obviously wrong.
The DeviceID of the nForce 750i (=MCP55) SATA Controller is either DEV_036F, DEV_037E or DEV_037, whereas the DeviceID DEV_0265 belongs to the nForce 430/410 chipset (=MCP51).

This is correct, but you have to be sure regarding the HardwareIDs/nforce chipset of your system.

Hmm… This is strange.
Here is what I have:

I finally tried to update the BIOS with a modified version (nvraid.rom untouched at the end of the bios file).
Bios update went fine, and Mediashield is now 9.x. Disks are now properly identified as 4TB.
However, the mirrored RAID is 2TB…

@yakou32 :
I just have checked it: The latest original BIOS 1401 for your mainboard contains the NVIDIA MediaShield RAID ROM v6.70 for the DeviceID DEV_0265.
This indicates, that you have inserted the correct MediaShield RAID ROM v9.xx, if it has been designed for DEV_0265 as well.


I’m trying to determine the current ROM versions and possibly update them.
I see from your guide you are also using a GA-X58A-UD3R board.

I was able to find the ROM for the Intel and the Gigabyte (JMicron) controller but not the Marvell.
From what I can tell from the CBROM and HxD outputs PCI ROM[A] is the Intel AHCI ver 1.20e, [B] is Intel MSM ver v8.9.0.1023, [C] is Gigabyte 1.07.06, [D] is Realtek PCIe GBE Family Controller Series v2.29 (06/30/09).
I noticed in CBROM, GROUP ROM[17] refers to a M9123FW.bin but having problems extracting it (think I have a syntax issue).

I’ve attach a copy of my BIOS file, any assistance would be appreciated.


@ed168 :
Welcome at Win-RAID Forum!

That was not my mainboard (I never had an X48 chipset system), I just used this BIOS for my guide.

This indicates, that the BIOS doesn’t contain any Marvell AHCI/RAID Option ROM module.
There is no need to insert an Intel AHCI/RAID ROM module unless you want to boot off a SATA HDD/SSD, which is connected with one of the Marvell ports running in AHCI or RAID mode.

This seems to be the Marvell Firmware, but not an Option ROM module.

Dieter (alias Fernando)

good morning, Dmitri,

i’m having SO much trouble with my bios. I have a Dell Mini 1010. the bios version is Tigera A11. The problem is that there is 1) no ACHI function & 2) only 8 MBs of shared video memory. I also have a Mini 1012 that’s working perfectly. it’s bios version is Samosa A12. that one has the Sata option. I’ve tried the CBROM & Andy’s Tool. I’ve also tried The Phoenix Bios Editor. NOTHING WORKS! So if i’m doing something wrong, please tell me. all I want to do is getting a SATA option in the Mini 1010 & to get at least 64MBs of GPU. i’ll give you specs.

Manufacturer: Dell
Model: Inspiron Mini 1010
Motherboard: M036P
BIOS Version: Tigera 11
Bios Manufacturer: Phoenix
Ram: 2GB
CPU: Item Atom 1.86Ghz
Video Card: Intel GMA 500

I was thinking that I can extract the SATA rom from the Mini 1012, then add it to the Mini 1010. it’s really frustrating. so please help me if you can. Thank you in advance, Peace, & God bless you & yours.

O.G.A. South Bronx, NYC…