[Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization

What subfolder, iAMTNVM, is this? I believe it is out of date; and if i’m right, which one are you referring to today?
Because I am unable to continue the process.


My data:


Intel ME System Tools v8 r3;

Thanks in advance!

You haven’t given me any info on what firmware you are trying to clean. I’m fairly certain you are following the wrong instructions/section because that tool is for ME 2-3 only.

Thanks for the answer!
I edited my post before I knew that you already answered me, could you review it?
Thank you.


Hello everyone!

Because of my haste, I hadn’t read the post more calmly, but then, being more careful, I realized that in the post itself there are examples for all versions.
Thank you very much.
Until any time.

I’m trying to clean this bios dump and i’m a bit confused because it’s a new type for me(it has PMC).

First problem is that it seems to have OEM Public Key Hash , however there is no field for SMIP Signing Key


Second problem is that i’m not sure if i need to do anything about PMC, do i need to mess with it if i just want to clean the ME region?

Link to dump

Hello, my laptop is vbios was corupted and always freeze when I tried to install the and graphic driver, and after I flashed a cleaned ME bios I found on badcaps but my AMD graphic card not showing up. I just remembered I made a bios backup with fptw64 from a long time ago right when I bought the laptop, can I flash this bios back to fix my corupted Vbios ?

Hello, everybody!

I just came across a contradiction:

I opened the dump file for my bios in UEFITool and it shows these messages:


So I opened it in HxD and made the changes:





Then, I opened it again in UEFITool and the invalid checksum message is gone!


But as my goal is to ‘clean up’ the ME, I opened it in MEA to confirm that everything is right and I ended up facing this contradiction:


… that is, while UEFITool says "Checksum: 5Dh, invalid, should be 7Ch", MEA says "Wrong $FPT Checksum 0x7C, expected 0x5D! "

Would someone, please, tell me which one I should consider correct? (or wrong)

I will keep waiting.
Thank you very much.

Here is my dump file:

testeR.rar (3.55 MB)

ME Analyzer is correct, UEFITool is wrong.

Okay. I already suspected it but needed confirmation.

All right,
thank you very much!

Hello everyone!

As I am still a beginner in the area of ​​maintenance of laptop’s and PC’s, some things I’m still ‘catching’ …

for example: I have the motherboard “qcl40 la8221p” from Asus’ laptop “a45a” and its problem was doesn’t turn on. After cleaning [and draining possible static energy] I managed to turn on the equipment and it gave a video; but for getting excited [beginner’s thing …], I didn’t even back up the original BIOS and I’ve been trying to update the BIOS (using the update file downloaded from the website) through the machine’s SETUP, since its HDD was not being recognized.

Conclusion: at the end of the process there was a verification error, which I interpret as a checksum error [image below]



So I started my research on editing bios and now, that I found this forum and interlaced myself with fitc.exe, I made about 15 BIOS versions between fitc.exe, several versions of ME and other means of BIOS edits that I learned. So far I’ve tested 5; three of them did not show an increase in current, but the remaining two showed similar results as follows:

I press the ‘power’, the led lights up and stays on for about 6 seconds and goes off; I try again, and as I try, the amperage in the bench-top source increases, for example: in the first one it gives 20 milliamps; on the 2nd, 30 … and so on until it reaches something around ‘0.070 A’ and then drops to ‘0.000 A’. But now, the increasing of amperage only happens if I drain all the motherboard energy and repeat the process.

I’ll continue trying, but if this information already indicates something [that is really a BIOS or motherboard problem] to someone with more experience and can give me a ‘tip’, I will certainly already take a good step forward in completing my service.

Obviously, after I fix it I post the details here.

Thank you.

ytsoc - how did you solve this question? for easy cleaning CSME 12c - it is necessary to unite the region with PMC or not? Thanks

sorry, i do not have a solution

@plutomaniac - Can you explain, or update the guide, how we should use EXTR to clean/update ME FW manually, on our end to be fixed for other users to then flash in via FW Update tool.
I thought you told me before it’s OK with V12+ to use EXTR for this process, but I just tested and I see original settings are not same in before/after XML, thus stuff from the EXTR is being carried over during the process.

I still recommend to use RGN for cleaning firmware dumps with "Initialized" File System States, when available. The next best thing is EXTR or EXTR-Y (not EXTR-N) with "File System State : Unconfigured" & "OEM Configuration : No". FWUpdate tool has nothing to do with cleaning as the File System is not touched.

Well I already updated ME to latest RGN + latest PMC already for user, but wanted to now send him clean updated latest EXTR ME FW version that he could program in with FW Update tool.
But, I can’t, due to EXTR by itself says no FW Update possible, and if I want to merge PMC with this to make it FW update possible, then incorrect settings are transferred over during this process.
So, is it not possible to do what I wanted? Or, is the Y/N the answer here? * Edit - I guess that does not apply, target goal =

@Lost_N_BIOS Doesn’t your FIT v12 write FWupdate files, too? If I merge Intel CSME Firmware v12.0.71.1681 (CON H BA) with Intel PMC CNP Firmware v300.2.11.1025 (H B) just as an example, flash components “0”, build, I get:

“FW update image written: …/Intel CSME System Tools v12 r28/Flash Image Tool/WIN32/cse_image_FWU_Base.bin
FW update image written: ./Intel CSME System Tools v12 r28/Flash Image Tool/WIN32/cse_image_FWU_Full.bin”


As far as I understood FWUpdate doesn’t transfer any settings, so it doesn’t really matter which configuration might be stored in the image?

I don’t understand, what incorrect EXTR settings? lfb6 is right, FWUpdate tool does not care about configuration. You can use whatever you want (RGN, EXTR/EXTR-Y) as a firmware base before merging PMC and/or PCHC, PHY etc, as log as MEA does not say “FWUpdate Support : Impossible.” FWUpdate updates CODE only, not DATA. This guide is for cleaning CSE firmware dumps, not for FWUpdate. Detailed instructions on what FWUpdate does, how it works and what it requires to update the firmware of a given platform can be found at Intel Management Engine: Drivers, Firmware & System Tools.

OK, let me explain. I took full already clean/UPD ME FW (older) complete BIOS image, tried to update to, after compare before/after outimage and settings do not match.
I prefer to use full BIOS image when doing anything ME FW, on my end. Then I planned to extract ME FW to give to user to flash via FW UPD tool.
Yes, thank you both, I did forget that ME FW Update tool will not transfer in incorrect settings, but still, I should not be seeing them, thus my questions.

Latest PMC already integrated in previous BIOS w/ latest RGN clean UPD, already flashed in and tested.
I was simply trying to make a file so user could update to the latest version (EXTR) with FW Update tool, since I could not update to EXTR while clean/UPD on my end.

As for the mis-matched settings on before/after, here is an example area, and now I noticed it’s just this area


If I were to send him cse_image_FWU_Base.bin, but until I found why the reason for above, I would not trust this file.

I see what I intended is not possible (extract UPD ME from BIOS = FW Update = NO)
So I will have to use cse_image_FWU_Base.bin anyway, but I now see latest NO, with the latest version, so as usual, I’m a mess and lost with ME FW I used to only have to fight X79 ME FW

Why do we use Base over Full, both are identical?

@Lost_N_BIOS This time it’s really not too easy to understand what you mean/ did…

OK, but that’s a “clean” thing, right? You put in a complete bios image, update, build outimage. Then you put in generated outimage.bin, save settings and compare original and new xml- files and they don’t match- as shown on the picture. Is that correctly understood?

  • You cant (for newer ME firmware >=12) use Extracted regions directly for FWupdate.
    - You don’t have to care about most of the settings if you followed the guide. (I’m not sure what FIT does when generating update files?)
    - If you reopen an update binary in FIT again, you’ll possibly see some/ most settings set back to standard configuration since they simply weren’t stored in the update file?

    If you look at the structure it seems the update file don’t have any ‘bootable’ configuration but a much larger set of code/ firmware bricks, see attaached text files.

    You don’t need any basic settings for generating an ME update v12, see Plutomaniacs guide. The post with this guide was edited shortly, I think this part is new(er),and I think there’s few possibilities for misunderstanding/ wrong interpretation left. Only thing I wasn’t aware off: “FWUpdate Support” has Yes, No and Impossible as possible answers- A CSME with “No” can be used by FIT to build an update, a CSME with “Impossible” can’t.

MEA -dfpt for region v12.txt (13.4 KB)

MEA -dfpt for update file v12.txt (16.2 KB)

@lfb6 - What I meant, tried to explain, was I attempted to clean/UPD ME FW like you normally would, as I’ve done a million times without issue.
The problem here is me trying to figure out how to hand user proper file to use for ME FW update tool I guess, without the issues I’m seeing being a part of that file I pass to him.

I never work with ME FW update tool, or ME FW by itself, always entire BIOS and FPT.
So I’m sure some of my concerns here may be due to that, however, I don’t see how/why I should not be concerned.

This is what was done already, flashed in and user is using as we speak >> BIOS Fixed, Unlocked, ME FW Updated to latest RGN/PMC (As we normally do, mentioned above)
However, due to latest actual ME FW version was not RGN, I used older one that was last RGN version. So, now, I want to give him file to use to update to latest actual version, and there is where problems begin.
PMC is already latest, but I can re-integrate that without issue, but I don’t see how to give him safe file to use, provided what I showed in the image above
That the update ME via FIT with latest EXTR proves out changes that should not be, thus I don’t see how cse_image_FWU_Base.bin would not also contain these same incorrect changes that should not be happening

I know you both want to help, but when I get lost on a ME FW issue, I usually can’t absorb how to get around it.
I still avoid ANY X79 ME FW update for this reason, for anyone, and only direct them how to use ME FW Update tool and latest provided file.

Yes, some of your points/questions, I have the same concerns, thus my question here.
I have since noticed you can’t use extracted ME FW, even cut to size, for ME FW Update tool, so I got that now

Maybe you could help the user? If yes, do you need me to link you to the last BIOS I gave him, with latest RGN ME + Latest PMC, or can you help him directly with none of that?

I have read the guide, but it and what you quoted is not at all related to anything I am asking (really this).
I know how to make proper ME files, it’s just not happening here in a way that I trust, due to changes in before/after comparisons that should not be there.

Meaning >> I would not give this BIOS with updated ME FW (From EXTR) to user to put on with unlocked FD and FPT, or a flash programmer either, there is a problem.
The oddities I mentioned above (previous post/image) with cse_image_FWU_Base.bin and or Before/After XML on actual BIOS image.
I don’t trust those incorrect things in the BIOS image before/after are not also going to be flashed in during a ME FW update using cse_image_FWU_Base.bin created at same time as outimage with incorrect settings as shown in the image above.

Quicker summary >> If I use EXTR via FIT and make BIOS/ME, before/after XML does not match properly.
How am I to know/trust cse_image_FWU_Base.bin generated right then too, is not also going to contain the same incorrect changes? << This sums up my questions and concern perfectly, nice and brief too

@Lost_N_BIOS Please attach the files/ bios or post the link to these files.

My point still being that you can’t know if there really are different settings in an update file since you have to use FIT for checking these settings. And you don’t know which settings are standard settings just shown by FIT itself and never were stored in the update image. FIT doesn’t have a way to differentiate between region/ bios mode and update mode- where it should grey out not processed/ not relevant settings…

I think it’ll be less writing with the files at hand and a result to compare.