[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

@Lost_N_BIOS I only tried it on Asus boards as those have their bios’s locked. May get around to a permanent solution.


What I mentioned applies to Asus as well, different BIOS or different series may need Shell or Shellx64 as the name, you can always tell which by looking at BIOS in AMIBCP and select this exit option and you’ll see what name it’s going to look for in the help text for that entry in AMIBCP.
This only applies to BIOS with this option on the exit page (or hidden exit page), for BIOS without this option I am not sure what the ideal name would be to do how you mentioned, I always suggest this method for users who can’t hit that choice on their BIOS exit page - [Help needed] Hidden Advanced menu Bios HP Z1 J52_0274.BIN (2)

hello my issue is the bootx.efi file doesn’t load on my system, even if I rename it.
I just get a black screen with a frozen cursor. any help would be great

@f3bandit - What is bootx.efi? Do you mean generally, the file attached at post one? If yes, what is your model, or link to your BIOS, or send me a FPT dump etc, can’t really help without knowing what system/BIOS we’re discussing

Did you disable secure boot? Is USB MBR FAT32 partitioned?


@f3bandit - That is not a large enough answer to what all I asked, do you need help or not? If you do, please >> what is your model, or link to your BIOS, or send me a FPT dump etc

USB Does not have to be DOS bootable, but can be. However, .efi file does need to be in root of USB (ie not in folder) and probably not on USB 3.0/3.1 port either, unless that is all your system has

The .efi file does have to be a specific name, which I can’t guess, I have to check your BIOS before I can tell you that name.

First off, thanks for making this guide.

Second: Im having an issue when following it. I have pretty much the exact same problem and I can follow it pretty much upto step 15, but when when I do it tells me that setup has 6 bytes and that the offset is out of range. Any suggestions what I might have done wrong?

@Kuhman - You’re welcome, and thank you too, good to hear it’s always being put to use

Please show me an image of what you are describing, sometimes this is normal/expected, if not followed by more error.
Also, you can check what the “current” value is by >> setup_var variable (only, no setting following variable)

Some BIOS types, you need to use other setup_var, or use other tools such as Intel H20UVE etc.
What motherboard do you have, please link me to it’s stock BIOS download page

Hello, thank you for this guide. This question may be dumb, but I want to make sure I don’t brick my mobo… I’m on step 12, and I don’t have “Clear Secure Boot Keys” as an option. I can delete each key by going further into the PK, KEK, DB and DBX menus but I don’t know if that’s correct. If so, should I delete all 4 keys?

Using Asus Z170 Sabertooth S - Ultimately trying to flash modded Coffeelake bios via USB Flashback

[[File:190831234903 (1).jpg|none|auto]]

190831234903 (1).jpg

@slvrsurfr - You’re welcome! None of that can brick the board, it would only give you issues while trying to get to grub. The keys can always be restored by re-enable/install default keys or BIOS reflash.
However, I don’t think you need to do that, once you disable secure boot and reboot, that section should be hidden or empty I think

I checked BIOS 3801 and I see this option on your BIOS at this location, so this setting is either hidden from you always, or not there because you have disabled secure boot already and need to reboot possibly.
If you have secure boot enabled, do you then see clear keys option? I could make it always visible for you, but then you’d have to flash in that mod BIOS first, so we’d be right back here.

Just make sure secure boot disabled, reboot and then go to grub, should be OK

* Edit - USB Flashback does not require any of this. Put mod BIOS on root of FAT32 USB (Smaller/cheaper is best 128MB-2GB) and flash away - be sure file is in a signed capsule and is named Z170STS.CAP
To check if it’s signed, drop in UEFITool, and then in middle you’ll see AMI Capsule Signed or Unsigned. If it’s not signed, upload your file for me and I will fix for you.

Actually some USB keyboard couldn’t work in this GRUB,could you have another GRUB?

Can I avoid using GRUB and set all needed VAR values via FTPw.exe console?

@gloobox - I’ve never heard of such a thing, you can try the grub’s for this that have been modified to allow setup_var2 and setup_var3, but I think they use this as base.
Probably your issue is some USB setting, like XHCI or legacy USB forced enabled or something like that.

@klaxklax3 - you always have the funny questions, well always asked in strange ways I think you mean can you mod BIOS to make these changes in BIOS itself? If so, yes, this can be done, but you need to unlock the BIOS first otherwise you can’t flash in that mod BIOS.
Best way to do it is to unlock so you can flash with FPT, once confirmed you can, then dump BIOS again and then it’s already done for you, then use that as your new base BIOS to flash in first (ie now) and then always use that as your base BIOS moving forward for any mods and it will remain unlocked.


Ha ha, no I mean exactly "can I unlock BIOS straight from FPTw?"

I saw there are many strange options to set VARS, CVARS, CFGGEN and more, I just have no idea what they do and how to use them, you just need to run FPTw.exe -help

Well, that explains why it sounded odd then No, FPT is a BIOS flashing/dumping too, but can make some changes at ME FW level, but it’s not a BIOS editing too.
FPTw.exe -help shows you what each of those command flags does


I am getting mad, yesterday I had access to write bios, today i have no access… and my VARs doesnt work anymore…

What is going on?

Please have a look at the attached IFR.txt of my setup area.
I am getting a error 8 when I try to flash a modified bios

Error 8.JPG

I’ve already FF’d the desc region

Appreciate your thoughts/opinions!

Section_Freeform_subtype_GUID_97E409E6-4CC1-11D9-81F6-000000000000_Setup_Setup_body IFR.txt (463 KB)

@nikey22 - Can’t see the command you entered. This often means you maybe tried to flash some region that does not exist

What is your ME FW version? Are you in DOS? Try FPT v8 instead
What did you want me to see in IFR?

What do you mean FF’d the descriptor region? YOu can’t FF the desc region, but you can FF some bytes to unlock descriptor, these two mean very different things when talking hex and FF’n something in a hex edit.
Upload a copy of the BIOS you are trying to flash, and then show me command you are using and error on same screen image.

@Lost_N_BIOS , sorry about that.
command was : fpt –BIOS –f IMAGEA1N.BIN, when the command is issued, it clears the screen to that error code.
using fpt version 7
ME version : 7.1
Yes I’m in DOS using a USB FreeDos startup

My idea was could there be a PRR that is preventing me from writing to the BIOS region. So I uploaded the startup IFR to see if there was a “block” somewhere to remove. However, this is not the typical error code for that. I’ve done a search of error 8 here on the webiste and I can’t see anyone else with it. There are a few reports of Error 7.

desc.bin region, I meant I FF’d the appropriate bytes to allow read/write access to the desc/ME/GBe regions. So I don’t think that is what is causing the failure to write to the BIOS region.

I’ve tried version 8 of fpt
now I get:

ERROR 7 : Software Sequencing failed. Make sure you have access to the target flash area!
It seems that it reads it, but when it tries to erase, it immediately throws this error.

Interestingly, AFUDOS.exe /IMAGEA1N.bin /p /b /k1 /r /sp writes the BIOS image to the region without a problem (This is the command & parameters that Lenovo uses normally when you do a bios upgrade). I just don’t know why fpt doesn’t.

Try Win98 SE instead. Also, make sure you are not using any odd characters in the command path such as %/ etc.

PRR would give you PRR error, as you mentioned. I did look at the IFR before I replied, and didn’t see any lock SMM/SMI/BIOS Lock, nor FPRR/PRR/Protected/Range etc.

Thanks for clarification on the desc FF Asked to be sure Do you get same errors within windows too?

Upload the BIOS file for me to check out, maybe something is wrong at the desc (include stock BIOS or whatever your pre-mod source BIOS is, and your mod you are trying to flash, also dump current BIOS contents with FPT and include too >> FPT -d SPI.BIN)

Can you flash that BIOS region only, if you extract BIOS region from the file and give it only that as the source to flash?