[Guide] How to flash a modded AMI UEFI BIOS

If you had read the links Fernando provided, then you already have know that AMI tools will not work as the ASUS bios security prevents modified files from being flashed, if it was possible all this guides and the alternatives i posted weren’t needed right…
Same situation prevents it in bios with EZ Flash… welcome to the mod world…

Hello! It seems that the /GAN command is missing…even though i’ve downloaded the 64bit version of the afuwin. Is there another version that the GAN command will work? When I try, it feels like nothing work. The only message there was, “Press any key bla bla bla” The description on the text was “AMI Firmware Update utility(APTIO) for pure 64bits WINDOWS.”
Did I use the wrong version?


1 Like

Why didn’t you read the start post carefully?
Here is an excerpt of it:

According to my knowledge the " /GAN" command works with all AFUDOS version, but only with older AFUWIN versions (as WeatWar has written).

1 Like

Thanks! Got it working under the version as meatwar mentioned. Already flashed on my Asus Z87K. Glad that I found this post!

3 posts were merged into an existing topic: [GUIDE] Update CPU Microcode + Fix FIT Using UEFITool / Hex


Yes, you obviously used a not working AFUWIN version, because you haven’t read the related part of the start post.
Bad consequence for MeatWar and me: We both wasted our free time unnecessarily for you.
Don’t expect any further support from my side.

But CH341A programmer and Intel FPT tool are too complicated for me…
It looks like the road ends here and without flashed bios :disappointed_relieved:

ASUS bios mod on motherboards without USB BFB, options are AI Suite, CH341A, Intel FPT tool or AMI /GAN…and welcome to the mod world…what did you expected from trying modified files to be flashed.

Only flash option I can try is Afudos with usb key or Afuwin / GAN

Hi MeatWar.
I followed the instructions created by the oldguy user with the same H87 mobo but stopped at those last instructions. I can’t run afuwin64.exe in the command line windows 10.could you show me where and how to insert exactly please?

Successfully done.Last question.
Where I can find the the right bios settings for NVMe ssd with pcie adapter installed .

To read and learn: [HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS - NVMe Support for old Systems - Win-Raid Forum

A post was merged into an existing topic: [HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS

Hi, I was trying to use your guide, but the link to re creating the CAP file seems to be broken, and I seem to need that step to proceed?:

Only for ASUS BIOSes, whose capsule had been removed by extracting the “Body”, but shall be flashed by using the ASUS USB Flashback feature:
Don’t forget to re-insert the original capsule and to save the modded BIOS as *.CAP file!

Can you either point me to the correct place ,or just explain what needs doing, thanks in advance.

Edit by Fernando: Broken and misleading link within the quoted text removed

You… who…??? Use @username and that user will be notified.

Using the UEFI tool to extract (UEFItoolNA version) and replace (UEFI tool regular version) the bios region, by the mod one.

LongSoft/UEFITool: UEFI firmware image viewer and editor (github.com)

That’s Correct Fernando, just what I was trying to do.
This is a different link to that previously pointed to, but suggests an answer.
Seems I just rename the .rom file as specific name .cap file, and put it onto a USB stick…
so I can use USB flashback…
So far it fails… but there we go.

So, to be clearer. I downloaded the file for my motherboard, P8Z77-V-PRO-ASUS-2104.CAP
and the NvmExpressDxe_5.ffs file to add the NVMe capability.

downloaded UEFITool.exe and extracted the body, to get a rom file.

Downloaded and used the MMTool to put the NVM into the rom file.

renamed the rom file Z77VP.CAP as per the document DE103_Z77_H77_Series_BIOS_Renaming.pdf

Dropped it onto a recently formatted small size USB stick, and put it into the flashback usb port.
Shutdown the computer, pressed the usb flashback, and waited? 4 maybe 5 flashes, then with a light on? for 10 mins or so, and nothing seemed to happen, so something failed.
Tried with a few usb sticks… no change…

No…after inserted the NVMe dxe driver, the mod rom is to replace the previous bios region you extracted with the UEFItool, again on the CAP file, then the file is renamed and USB BFB will work.

EDIT: Where did i mentioned MMtool for the bios region swapping operation on the CAP???.. i said UEFI tool, MMtool is only for the insertion of NVMe DXE


REPLACE with the mod file already with NVMe inserted:

Saving will now ask to rebuild and view the new file.

EDIT: “Within the CAP file, so the newly created file, is presumably the file to rename and then flash to the bios…”
Yes, now rename the CAP according Asus BFB and use it with it, thats it if the NVMe was correctly inserted upon the guide, follow the OS nstallation instructed also in the guide.

Oh OK…
so, after MMTool used to put NVM into the rom file…
How do you then replace the bios region in the cap file with this version?

Or, do you just edit the CAP file with the MMTool to put the Nvm driver directly into it?
In which case why use the UEFITool at all?

Thought I was following the instructions Ok before, now not sure at all.

OK, so use UEFItool to extract the Bios region only.

Your images do not show the AMI Aptio capsule level… again, maybe relevant.

edit the exported rgn file to add the NVMe driver.

and then you have an option to replace the bios region with this file? its greyed out for me, as per your first image?

I note you seem to be using 2 different version of UEFITool, is that relevant?
The version I have is NE alpha 60

I also note your file is a .BIN file not .CAP?

OK, downloaded another version, following your version numbers, the latest is 0.26.0 and this does let me replace the bios, as you said…
Within the CAP file, so the newly created file, is presumably the file to rename and then flash to the bios…

EDIT 3: Yep… That worked, I now have NVMe support in the Bios…
Now to setup the OS on device.
Thanks Very much for your help on this, much appreciated.