[Guide] How to flash a modded AMI UEFI BIOS

Hi, I am new to any of this.
I have Asus Tuf Gaming FX705GE, where I want to flash my custom BIOS image which I am unsuccessful of. I am using AFUWINGUIx64, I open my Custom IMAGE and do FLASH. And it shows 18 - Error: Unable to start a secure flash session.
Any ideas?

Welcome to the Win-RAID Forum!
Please read carefully the ASUS BIOSes related chapter of this thread’s first post and follow the advices.
Good luck!
Dieter (alias Fernando)

Thank you for your reply.
I viewed all possible ways to flash Modded BIOS on my Asus Laptop. Most of them are not possible due to limited hardware and software support. I end up using AmiWin method, which still did not work and result to same issue. Unable to start a secure flash session.
I looked over for possible issue solution and couldn’t figure anything out. Is there anything else that could help me?

Standard methods usually are not viable for mod files, due to security preventing flashing modified firmwares…well know issue on mod community.
An alternative for Intel based machines…
[GUIDE] [UPDATE] Usage of AMI’s AptioV UEFI Editor + FPT Flash Method - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

the main issue here is the actual state of SPI regions access, described here:
[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

A note…this tool (Intel FPT) doesnt care of the content of the files, it flashes all bad or not.
The users should only engage in this process if they know how to recover the system and have done SPI backups, of course they should be a little experienced on this…not a task for 1rst time users.

Thank you very much for this. Seems like I succeeded to flash. Thank you again.

Hello All.
I have 2 server Fujitsu RX300S7 and RX300S8.
RX300S7 - flash and have NVMe Support.
RX300S8 - give me error (add images).

I use MMTool and UEFITool, but bios give me error when I try flash.
Maybe anyone have this problem? Thanks!

Correct, on CAPSULE bios files and other OEM securities.
Preventing this only working with extracted Intel Image or Bios region (UEFI tool) from the original bios update or spi dump of the system.
This happens more frequently on AMI V core bioses, less in AMI IV based.

The bios is an AMI IV core, use UEFItool_NA for extraction, UEFItool 0.25/0.28 for replacing.
Keep an eye on structure changes and/or missing pads when performing these operations.
Captura de ecrã 2023-10-20 222947
Captura de ecrã 2023-10-20 223056
Captura de ecrã 2023-10-20 223204

A little more guidance here, [GUIDE] NVMe on UEFI bios lacking space volume

EDIT: The file D2939-B1.UPD doesn’t have any CAPSULE, use MMtool v4.x, not v5

1 Like

How I can fix it?
Maybe you have manual?
Thanks for you help information!

Hello. I tried to follow your instructions but got the same error. :frowning:

I use MMTool Aptio 4.50.0023, edit D2939-B1.UPD and save.
When save dont see error, but when I flash this D2939-B1.UPD

Flash Service Interface reports Image Signature Error!
ERROR - GABI Progress Code: 833D

EDIT 22.10.2023

Hello All. I find solution how to flash.

  1. I download BIOS from official fujitsu site.
  2. MMTool Aptio 4.50.0023 → (open) D2939-B1.rom → (add) NvmExpressDxe_5.ffs → (save) D2939-B1.rom file.
  3. AMI AFUWin64 v3.05.04 with GAN support → (open) CMD With admin rights → (flash with this command) → AFUWINx64.EXE D2939-B1.rom /GAN
  4. Server reboot and work! BIOS see NVMe.

Thanks all for Help!

1 Like

@andriiwork @MeatWar
Since your recent discussion was mainly not about how to integrate the NVMe module into the BIOS, but about how to get the modded BIOS properly flashed, I have moved the related posts into this better matching thread and hope, that you agree with me.
Good luck!

i managed to flash the latest bios for my supermicro x10slh-f using the ami tool that came with the bios.

simply use rufus to create a freedos and flash the bios via the ami.bat file and it should work.

what happened in my case was after POST, it went into a restart loop for like 4-5 times but each time it got further and further in the POST process until it just goes through.

Good luck!

1 Like

@clarencelimzj Thank you for your feedback.

Was the restart loop a one time thing or does it happen on every fresh start ?

1 Like

i am trying Modding my bios with afuwin ami
but i keep getting this error
18 - error: secure flash rom verify fail
my mother board is msi B760m-p
i searched about Solution in your website i did found this but i didn’t understand what is

what i should do with it ?

Nothing to do with mods flash…
platomav/MEAnalyzer: Intel Engine & Graphics Firmware Analysis Tool (github.com)

Bios mod on modern motherboards only flashed with Intel FPT tool (Should be v16)
or an SPI programmer.
Dump your bios with the tool, (bios_region must allow writing, MSI usually allow it) mod it and flash it back.
If no experience on this area and not familiar with the tools, do not procede, i will not teach this to anyone as it’s no easy task and time consuming.
VERY high risk of getting a braked board.

You should wait for others users pov.

EDIT: Use the search box on the forum…your task and your time, not mine.

1 Like

sorry if i bother you can i get the link of FPT v16 ?

Since you are obviously searching for a tool to get a modded MSI BIOS properly flashed, I have moved your request (and the reply given by MeatWar) into this already existing and much better matching thread.
Don’t forget to read its start post before sending new posts.
Good luck!


1 Like

since i looking for fpt (CSME System Tools v16) i found the last 2 version of it and i would like to upload it for others if they looking for it later
thanks for helping @MeatWar https://mega.nz/file/tddyRJYA#USa3sj1qh2g2c-RNlbP-XzLHGR8WUOboUF1Ewu6oMgQ

Those tools are present in the forum, in the correct section and thread related to ME tools.
I just told you to search for it… all users will find it in the:

Intel Converged Security Management Engine
Drivers, Firmware and Tools
CSME 16+

Lates v16.0 is the CSME System Tools v16.0 r8
Lates v16.1 is the CSME System Tools v16.1 r0


7 posts were split to a new topic: [Problem] Change of the MB’s Serial Number

Need some help with this Asus TUF H370 Pro Gaming Bios, i have modded this Bios but can´t Flash it.

First of all here is the Original Bios File:

TUF-H370-PRO-GAMING-ASUS-3101.zip (8.5 MB)

Cleared all Keys in Secure Boot and set System to “Other OS” Secure Boot: shows deactivated

First i looked for locked Bios with USB Stick and Shell.EFI with GRUB but it´s unlocked as standard
(Bios LOCK 0xBC9 = 0x00 i set it to 0x00)
(FPRR 0x5BE = 0x00 standard)
(BIOS GUARD 0x1CC = 0x00 standard)

Then I have tried to Flash it in several ways:

This Asus Mainboard have no Bios Flashback so it´s more complicated

  • Flash from UEFI Bios itself: Says Can´t Flash this Bios File

  • Next i tried AFUDOS this says 22 - Error Problem allocating memory.

  • FTP (DOS) & FTPW says this Error 167 Protected Range Registers are set by Bios, preventing Flash access.
    Same if I first make a Bios dump of original Bios with “ftp -d backup.bin”, when i wan´t to reflash this with “ftp -bios -f backup.bin” Same Error 167

  • Then I tried Asus AI Suite and replaced the .CAP File (as in Guide), it flashed the Bios 3101 but without Modifications.

  • Last i tried Flashrom 1.2 with programmer “internal”
    Here are the Errors from Flashrom:

Bios Region SMM Protection is enabled
SPI Configuration is locked down
FREG0: Flash Descriptor Region (0x00000000 - 0x00000fff) is read only
FREG2: Management Engine Region (0x00003000 - 0x002fffff) is read only
Enabling Hardware Sequencing because some important OPCODE is locked
Found programmer Flash Chip “Opaque Flash Chip”

Here is my MEInfo64 Output:
Meinfo.zip (1.5 KB)

Who can help me to get this working or have some Guides for me that i haven´t found at this time ?

1 Like