[Guide] How to flash a modded AMI UEFI BIOS

Greetings Fernando!

Incidentally, my motherboard is also ASUS P8Z77-V with the stock BIOS (v2104.)

Can you point me to the download link for the latest modded BIOS — thank you.

@RaidWin :
Welcome to the Win-RAID Forum!
Since I gave away my ASUS P8Z77-V mainboard already several years ago, I don’t have any modded BIOS for you.
So you will have to do the required modification yourself.
Good luck!
Dieter (alias Fernando)

Hello everyone!

I’ve been trying to mod my BIOS using the guide from this forum: How to get full NVMe support for all Systems with an AMI UEFI BIOS
In that guide I used AMI’s MMTool 4.50 to insert a NVMe-module and saved it. Coming from that program, the BIOS-file had the .fd file extension. (Not sure if that’s important.)
The original BIOS-file I extracted from the motherboard (MSI 970A-G46) had no file extension at all and it gave me the option to name it whatever.

Now all have to do is flashing the BIOS but I can’t figure it out. I used Rufus to format the USB not knowing what options I have to use. First I tried to select the BIOS-file with the Boot selection option “Disk or ISO image”. That doesn’t work apparently. Rufus reponds: “Failed to scan image”. So I formatted non bootable and put the file on there.
Unfortunately when I go to BIOS with that USB inserted M-flashing tells me: "There isn’t any BIOS File in this USB key (root folder) Please copy BIOS File to this USB key (root folder)"

If I try the same procedure with the original BIOS extracted from the motherboard, the same error message appears.

Edit: Meanwhile I also tried renaming the BIOS eine to MSI.ROM without ans success.

Edit 2: I figured it out. Will update later.

Edit 3: Alright. What I needed was a flash utility. In my case it was called afudos. Then I made a bootable memory stick using Rufus-Tool with FreeDOS. I put the BIOS-file and the executable named afudos on there.
Starting into FreeDOS I could flash the BIOS-file by the command: afudos insert name of BIOS-file

I have a n asus prime z270-p and want to downgrade the ME. I tried booting with the ALC887 pin 1 and 5 shorted and I flashed the bios with AFUWIN64 tool v3.05.04 and the /GAN option, but no luck. Is there another tool I can try besides SPI flashing?

i don’t know how to create flash mod bios on msi nb
uses some protection, the bios looks just like the original ".10F"

but I don’t use flash
"Failed, wrong image format 11!"

bios is unlocked , but I don’t see any protection setting
,.nb GT75 7RE

thanks for the advice

@NeXt3R :
Since your request has nothing to do with the UBU tool, I have moved into this better matching thread.

I have problem with flash the bios. When I flash the original bios, I get this message:
afuwinx64 46 - Error: problem getting flash information.

A Have Lenovo ThinkCentre M92p.

It is possible to flash this board with mod bios?

Can I try flash bios with mod *.cap file with original tool?

@Lost_N_BIOS :
Can you help okokokok?
Thanks in advance!

Yes, I need help with flash this board, please.

I got just this answer…

C:\flash>AFUWINx64.EXE IMAGE9S.rom /GAN
| AMI Firmware Update Utility v3.05.04 |
| Copyright (C)2013 American Megatrends Inc. All Rights Reserved. |
46 - Error: Problem getting flash information.

@okokokok :
Since I am not an expert regarding your specific issue, you will have to wait until @Lost_N_BIOS has the required time to give you support. He is currently very busy and cannot take care about all help requests immediately.
Please be patient…

okokokok, what is the mobo? Version 3.* support Aptio 4 only, You must use version 5.07, this version for Aptio 4 and V and know key /GAN. I don`t know about another versions.

Thank you. Core version is 04.06.
I don’t have afuwin version with /GAN. Where is possible to donwload?


@okokokok :
The download link to the " /GAN" supporting AFUWIN v3.05.04 can be found within the start post of this thread (chapter B. of the ASUS section).

And my mainboard is: LENOVO MAHOBAY, Intel Q77 (Panther Point DO), BIOS: 9SKT9CAUS,

And please, what does it mean the option ‘/GAN’ ?
I have version 5.12.03 - there is this option: ‘/DPC - Don’t Check Aptio 4 and Aptio 5 platform.’

@okokokok :

With this command extension modded BIOSes may be flashed by using the AFUWin tool.
Only old AFUWin versions up to v3.05.04 do support the " /GAN" extension. Please read the related part of the start post carefully.

Flashing all without any check of modded bios.

Try its.

I don’t know, how to flash this board.
When I use: AFUWINx64.EXE image9s.rom /GAN version 3.05.04 I get this answer: 46 - Error: Problem getting flash information.
It is possible flash with antother version of AFUWINx64.EXE?